oss-compat_2+deb7u2_amd64.deb


Advertisement

Description

oss-compat - Open Sound System (OSS) compatibility package

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name oss-compat
Package version 2+deb7u2
Package architecture amd64
Package type deb
Installed size 7 B
Download size 4.92 KB
Official Mirror ftp.br.debian.org
This package ensures that Open Sound System support is provided in
some way. On Linux, it enables the ALSA compatibility modules. On
other kernels where OSS is the default interface, no action is
taken.
The purpose of this package is for applications that only support OSS
to depend on it, hence preventing common "/dev/dsp not found" errors
that would confuse unexperienced users.

Alternatives

Package Version Architecture Repository
oss-compat_2+deb7u2_i386.deb 2+deb7u2 i386 Debian Main
oss-compat - - -

Requires

Name Value
kmod -

Download

Type URL
Binary Package oss-compat_2+deb7u2_amd64.deb
Source Package oss-compat

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install oss-compat deb package:
    # sudo apt-get install oss-compat

Files

Path
/lib/oss-compat/linux
/usr/share/doc/oss-compat/changelog.gz
/usr/share/doc/oss-compat/copyright
/usr/share/lintian/overrides/oss-compat

Changelog

2014-09-23 - Stephen Kitt <skitt@debian.org>
oss-compat (2+deb7u2) wheezy; urgency=medium
* Give the correct destination when copying the new configuration
file. (Closes: #762547.)
2013-10-02 - Stephen Kitt <skitt@debian.org>
oss-compat (2+deb7u1) wheezy; urgency=low
* Use softdep directives in the modprobe configuration. (Closes:
#660803.)
* Remove oss-compat.conf when removing the package, so it doesn't load
the OSS modules when configured but not installed. (Closes: #718241.)
2012-03-05 - Christoph Egger <christoph@debian.org>
oss-compat (2) unstable; urgency=low
[ Stephen Kitt ]
* Add VCS information.
[ Christoph Egger ]
* Team upload
* Do not depend on module-init-tools
* On linux it's transitional for kmod anyway
* on kfreebsd it got uninstallable due to changes in module-init-tools
recently (and there's nothing needed on kfreebsd)
* Make package arch:any so we can simplify Depends: to kmod [linux-any]
2012-01-15 - Stephen Kitt <steve@sk2.org>
oss-compat (1) unstable; urgency=low
* Switch to single-component versions.
* Declare the package is "Multi-Arch: foreign", thanks to Steve Langasek
for the hint! (Closes: #651335.)
* Make /etc/modprobe.d/oss-compat.conf a file, handling the various
upgrade cases, and only removing it on purge. (Closes: #649507.)
(LP: #340873)
* Add kmod as an alternative dependency to avoid preventing
module-init-tools' removal.
2011-06-08 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
oss-compat (0.0.6) unstable; urgency=low
* Team upload.
* Re-upload without changes, because the last binary upload changed the
Maintainer field to myself by accident, which made the package look
hijacked.
2011-06-06 - Stephen Kitt <steve@sk2.org>
oss-compat (0.0.5) unstable; urgency=low
* New maintainer. (Closes: #594376.)
* Only modprobe snd. (Closes: #390747.)
* Update copyright file, switch to DEP-5 format.
* Drop obsolete modutils dependency.
* Switch to dh7 short form.
* Specify source format "3.0 (native)".
* Override depends-on-essential-package-without-using-version
explicitly; the dependencies allow this package to be installed on
hurd.
* Standards-Version 3.9.2, no further change required.
2009-03-18 - Michael Biebl <biebl@debian.org>
oss-compat (0.0.4+nmu3) unstable; urgency=low
* Non-maintainer upload.
* debian/{postinst,prerm}
- Update the symlink in /etc/modprobe.d/ to have a .conf suffix as
is required now by module-init-tools. (Closes: #518149)
2008-12-19 - Martín Ferrari <tincho@debian.org>
oss-compat (0.0.4+nmu2) unstable; urgency=high
[ Frank Lichtenheld ]
* Non-maintainer upload.
* Add the "install snd-{mixer,pcm,seq}" items alsa-base previously
had. Also remove the "install snd" item, we have no guarantee
that is is used anyway (see #397765).  (Closes: #500460) 
[ Martín Ferrari ]
* Uploading Frank's changes.
2008-07-22 - Steve M. Robbins <smr@debian.org>
oss-compat (0.0.4+nmu1) unstable; urgency=low
* Non-maintainer upload.
* debian/dirs: add etc/modprobe.d.  (Closes: #395423)
2006-09-30 - Robert Millan <rmh@aybabtu.com>
oss-compat (0.0.4) unstable; urgency=low
* Don't abort postinst if modprobe fails.  (Closes: #387379)

See Also

Package Description
oss-preserve_1.1-6_amd64.deb Program to save/restore OSS mixer settings
oss4-base_4.2-build2006-2+deb7u1_amd64.deb Open Sound System - base package
oss4-dev_4.2-build2006-2+deb7u1_all.deb Open Sound System - development files
oss4-dkms_4.2-build2006-2+deb7u1_amd64.deb Open Sound System - DKMS module sources
oss4-gtk_4.2-build2006-2+deb7u1_amd64.deb Open Sound System - simple GTK2-based mixer control
oss4-source_4.2-build2006-2+deb7u1_amd64.deb Open Sound System - drivers sources
ossim-core_1.7.21-4_amd64.deb The OSSIM core utilities
otags_3.12.5-1_amd64.deb tags file generator for OCaml
otcl-shells_1.14+dfsg-2_amd64.deb OTcl shells
otf-freefont_20120503-1_all.deb transitional dummy package
otf-ipaexfont-gothic_00103-14.1_all.deb transitional dummy package
otf-ipaexfont-mincho_00103-14.1_all.deb transitional dummy package
otf-ipaexfont_00103-14.1_all.deb transitional dummy package
otf-ipafont-gothic_00303-10.1_all.deb transitional dummy package
otf-ipafont-mincho_00303-10.1_all.deb transitional dummy package
Advertisement
Advertisement