orbit2_2.14.19-0.1_amd64.deb


Advertisement

Description

orbit2 - a CORBA ORB

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: orbit2
Package version: 2.14.19
Package release: 0.1
Package architecture: amd64
Package type: deb
Installed size: 157 B
Download size: 103.92 KB
Official Mirror: ftp.br.debian.org
ORBit2 is a high-performance CORBA (Common Object Request Broker Architecture) ORB (Object Request Broker). It allows programs to send requests and receive replies from other programs, regardless of the locations of the two programs. CORBA is an architecture that enables communication between program objects, regardless of the programming language they're written in or the operating system they run on. This package contains the command-line utilities ior-decode-2 and typelib-dump.

Alternatives

    Download

    Source package: orbit2

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install orbit2 deb package:
      # sudo apt-get install orbit2

    Files

    • /usr/bin/ior-decode-2
    • /usr/bin/linc-cleanup-sockets
    • /usr/bin/typelib-dump
    • /usr/share/doc/orbit2/AUTHORS
    • /usr/share/doc/orbit2/NEWS.gz
    • /usr/share/doc/orbit2/README
    • /usr/share/doc/orbit2/TODO
    • /usr/share/doc/orbit2/changelog.Debian.gz
    • /usr/share/doc/orbit2/changelog.gz
    • /usr/share/doc/orbit2/copyright
    • /usr/share/man/man1/ior-decode-2.1.gz
    • /usr/share/man/man1/linc-cleanup-sockets.1.gz
    • /usr/share/man/man1/typelib-dump.1.gz

    Changelog

    2011-10-18 - Michael Biebl <biebl@debian.org> orbit2 (1:2.14.19-0.1) unstable; urgency=low * Non-maintainer upload, for the GNOME 3 transition. * New upstream release. * Update watch file. * Use dh-autoreconf: - Drop debian/patches/700-autoreconf.patch. - Add Build-Depends on dh-autoreconf. - Add autoreconf.mk include. * debian/rules: - Don't include autotools.mk as we already include gnome.mk. * debian/patches/001-dont-use-atexit-handlers.patch: - Don't use atexit handlers, as they cause gnome-settings-daemon to crash. Use a GNU C extension instead. Patch by Rodrigo Moya. (LP: #788710, Closes: #645704)

    2011-05-29 - Luk Claes <luk@debian.org> orbit2 (1:2.14.18-0.2) unstable; urgency=low * Non-maintainer upload. * Remove references to other libraries from dependency_libs field (Closes: #619205).

    2010-04-08 - Sebastian Dröge <slomo@debian.org> orbit2 (1:2.14.18-0.1) unstable; urgency=low * Non-maintainer upload. * New upstream bugfix release, one API addition: + debian/patches/700-autoreconf.patch: - Regenerated for the new version.

    2009-11-24 - Sebastian Rittau <srittau@debian.org> orbit2 (1:2.14.17-2) unstable; urgency=low * debian/control: Added minimum version to debhelper and pkg-config build-depends. * debian/liborbit2.lintian-overrides: Ignore that the package name does not match the .so names. This has historic reason and is not going to change. * debian/control: Fixed a typo in orbit2-nameserver's description. + Closes: #557830 "Typo in package description: "This packages""

    2009-10-04 - Sebastian Rittau <srittau@debian.org> orbit2 (1:2.14.17-1) unstable; urgency=low * Acknowledge NMUs. Thanks, people! + Closes: #460403 "diff for NMU version 1:2.14.10-0.1" + Closes: #471275 "diff for NMU 2.14.12-0.1" * Update Standards-Version to 3.8.3, no additional changes needed. * Bump debhelper compatibility level to 7.

    2009-03-06 - Sebastian Dröge <slomo@debian.org> orbit2 (1:2.14.17-0.1) unstable; urgency=low * Non-maintainer upload. * New upstream bugfix release. No API changes. * Update Standards-Version to 3.8.0, no additional changes needed. * Build depend on autotools-dev to get config.{sub,guess} updated.

    2008-11-14 - Josselin Mouette <joss@debian.org> orbit2 (1:2.14.16-0.1) unstable; urgency=low * Non-maintainer upload. * New upstream bugfix release. No API changes.

    2008-06-03 - Sebastian Dröge <slomo@debian.org> orbit2 (1:2.14.13-0.1) unstable; urgency=low * Non-maintainer upload. * New upstream bugfix release: + Robustness fixes. + Locking fixes in linc. + Fixes for handling of local requests.

    2008-03-17 - Sebastian Dröge <slomo@debian.org> orbit2 (1:2.14.12-0.1) unstable; urgency=low * Non-maintainer upload. * New upstream bugfix release: + Fixes build with glib 2.16 (Closes: #464525). + 700-autoreconf.patch: Regenerated for the new version. + Build depend on libidl-dev (>= 0.8.10).

    2008-01-12 - Josselin Mouette <joss@debian.org> orbit2 (1:2.14.10-0.1) unstable; urgency=low * Non-maintainer upload. * New upstream release with API additions. * Increase shlibs version to 2.14.10. * Use ${binary:Version}. * Standards version can be 3.7.3. * Fix FSF address in copyright.

    Advertisement
    Advertisement