orange_0.4-2_amd64.deb


Advertisement

Description

orange - extracts CAB files from self-extracting installers

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: orange
Package version: 0.4
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 64 B
Download size: 9.80 KB
Official Mirror: ftp.br.debian.org
Orange is a tool and library for squeezing out juicy installable Microsoft Cabinet Files from self-extracting installers for Microsoft Windows. It currently supports the following kinds of installers: * Early support for installers created by Installer VISE. * Support for some installers created by Inno Setup. * Early support for the installer used by TomTom products. * InstallShield versions 5 and 6. * Setup Factory versions 5 and 6. * Some other installer (using a DLL called inflate.dll). This is used by for example Macromedia Flash Player 6 for Pocket PC 2002. * Microsoft Cabinets (also self-extracting) when you have Cabextract installed. * Zip archives (also self-extracting) when you have UnZip installed. This package contains the binary which can be used to extract CAB files.

Alternatives

    Download

    Binary package: orange_0.4-2_amd64.deb
    Source package: orange

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install orange deb package:
      # sudo apt-get install orange

    Files

    • /usr/bin/orange
    • /usr/share/doc/orange/changelog.Debian.gz
    • /usr/share/doc/orange/changelog.gz
    • /usr/share/doc/orange/copyright
    • /usr/share/man/man1/orange.1.gz

    Changelog

    2011-04-30 - Evgeni Golov <evgeni@debian.org> orange (0.4-2) unstable; urgency=low * Switch my email-address. * Add fix_ftbfs_binutils_gold.patch from Ubuntu. Closes: #555871 * Promote unzip and cabextract to Recommends. Closes: #584878 * Format 3.0 (quilt) * Drop -l from the manpage, it does not exist. Closes: #583772 * dh7 rules.tiny. * Add ${misc:Depends} to Depends, thanks lintian.

    2009-02-19 - Evgeni Golov <sargentd@die-welt.net> orange (0.4-1) unstable; urgency=low * New upstream release * debian/control: + Wrap Build-Depends. + Remove Build-Depends on non -dev packages. + Add Build-Dep on quilt. + Add Depends on libsynce0-dev, libdynamite-dev, libunshield-dev for liborange-dev. (Closes: #515818) + Remove duplicate Section header from the orange binary package. + Slightly adjust the short and long descriptions to explain the difference between the packages. * debian/rules: + Use quilt for patch handling. + Only configure with --host when we are cross-building. + Don't use rm in the clean target, dh_clean can handle it. + Copy /usr/share/misc/config.{sub,guess} unconditionally, we depend on autotools-dev. + Remove useless comments. * debian/patches/orange-0.4-libtool-1.5.26.diff: + Add a new patch that contains relibtoolization with libtool 1.5.26 instead of 2.2, as the latter breaks --as-needed. * debian/copyright: + Update copyright years. + Update to a newer machine-readable copyright proposal. + Use GPL-1+ instead of GPL-any, so lintian does not complain. * debian/liborange-dev.install: + Do not install liborange.la.

    2008-06-10 - Evgeni Golov <sargentd@die-welt.net> orange (0.3.2-1) unstable; urgency=low * New upstream release. (Closes: #483283) * debian/control: + Added build-dependency on libmagic-dev (suggested by upstream). + Added build-dependency on libgsf-1-dev. + Bump Standards Version to 3.8.0. (No changes needed) + Fix spelling of liborange description. * debian/rules: + Call configure with --enable-inno --enable-vise --enable-msi --with-libgsf, thus enabling INNO, VISE and MSI support. + Removed unneeded manpage-fixes. + Set LDFLAGS="-Wl,-z,defs -Wl,--as-needed"

    2008-05-09 - Evgeni Golov <sargentd@die-welt.net> orange (0.3.1-1) unstable; urgency=low * New maintainer. (Closes: #469411) * New upstream release. * debian/control: + Add build-dependency on pkg-config. + Add a Homepage field. * Remove unneeded .dirs files. * debian/rules: + Install upstream changelog. + Don't set CFLAGS and INSTALL_PROGRAM. * Update watch file. * Use upstream manpage. * Use the machine-readable format for debian/copyright.

    2008-03-03 - Barry deFreese <bddebian@comcast.net> orange (0.3-3) unstable; urgency=low * QA upload. + Set maintainer to Debian QA Group <packages@qa.debian.org>. * Add libglib2.0-dev build-dep. (Closes: #465633). * Remove version from package description. (Closes: #400257). + Thanks to Michael Gilbert. * {Source-Version} -> {binary:Version} in -dev package. * Remove unneeded debhelper commands from rules. * Fix minor bashism in rules. * Make clean not ignore errors. * debian/orange.1 - Fix whatis entry for description. + Clean up help2man cruft. * Fix zip extract to actually extract and not remove the files. + Thanks to Thomas Viehmann for the fix. * Bump debhelper build-dep and compat to 5. * Bump Standards Version to 3.7.3. (No changes needed).

    2005-09-15 - Volker Christian <voc@debian.org> orange (0.3-2) unstable; urgency=low * Fixed dependency problem

    2005-09-14 - Volker Christian <voc@debian.org> orange (0.3-1) unstable; urgency=low * New upstream release * Changed Maintainer Email to voc@debian.org * Update watch file * Update standard version to 3.6.2

    Advertisement
    Advertisement