openvpn-auth-ldap_2.0.3-5.1_amd64.deb


Advertisement

Description

openvpn-auth-ldap - OpenVPN LDAP authentication module

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: openvpn-auth-ldap
Package version: 2.0.3
Package release: 5.1
Package architecture: amd64
Package type: deb
Installed size: 168 B
Download size: 45.64 KB
Official Mirror: ftp.br.debian.org
A plugin that implements username/password authentication via LDAP for OpenVPN 2.x. It features: * Simple Apache-style configuration file. * LDAP group-based access restrictions. * Will authenticate against any LDAP server that supports LDAP simple binds -- including Active Directory.

Alternatives

    Download

    Source package: openvpn-auth-ldap

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install openvpn-auth-ldap deb package:
      # sudo apt-get install openvpn-auth-ldap

    Files

    • /usr/lib/openvpn/openvpn-auth-ldap.so
    • /usr/share/doc/openvpn-auth-ldap/README
    • /usr/share/doc/openvpn-auth-ldap/changelog.Debian.gz
    • /usr/share/doc/openvpn-auth-ldap/copyright
    • /usr/share/doc/openvpn-auth-ldap/examples/auth-ldap.conf

    Changelog

    2013-04-19 - Julien Cristau <jcristau@debian.org> openvpn-auth-ldap (2.0.3-5.1) unstable; urgency=high * Non-maintainer upload. * Build with gobjc-4.6 (closes: #641811)

    2012-11-19 - Alberto Gonzalez Iniesta <agi@inittab.org> openvpn-auth-ldap (2.0.3-5) unstable; urgency=low * Updated patch from Antoine Beaupré to fix FTBFS.

    2012-11-12 - Alberto Gonzalez Iniesta <agi@inittab.org> openvpn-auth-ldap (2.0.3-4) unstable; urgency=low * Add patch from Antoine Beaupré to fix "No remote address supplied" error. (Closes: #692936)

    2012-06-05 - Alberto Gonzalez Iniesta <agi@inittab.org> openvpn-auth-ldap (2.0.3-3) unstable; urgency=low * Acknowledge Matthias Klose's NMU. Thanks! (Closes: #667316) * Bumped Standards-Version to 3.9.3

    2012-05-29 - Matthias Klose <doko@debian.org> openvpn-auth-ldap (2.0.3-2.1) unstable; urgency=low * Non maintainer upload. * Fix build failure with GCC 4.7 (Matej Vela). Closes: #667316.

    2012-02-20 - Alberto Gonzalez Iniesta <agi@inittab.org> openvpn-auth-ldap (2.0.3-2) unstable; urgency=low * Acknowledge Matthias Klose's NMU for #625146. * patched/STARTTLS_before_auth.patch: Run STARTTLS before authenticatingi to the LDAP server. Thanks Andre Pawlowski for finding this and the fix. (Closes: #610339) * debian/control: added Homepage field, added autotools-dev Build-Dep * Added debian/source/format * Added debian/watch

    2011-08-28 - Matthias Klose <doko@debian.org> openvpn-auth-ldap (2.0.3-1.1) unstable; urgency=low * Non maintainer upload. * Configure with --with-objc-runtime=GNU. Closes: #625146. LP: #771029.

    2009-07-23 - Alberto Gonzalez Iniesta <agi@inittab.org> openvpn-auth-ldap (2.0.3-1) unstable; urgency=low * Initial release (Closes: #471356)

    Advertisement
    Advertisement