libzookeeper-st2_3.3.5+dfsg1-2_amd64.deb


Advertisement

Description

libzookeeper-st2 - Single threaded C bindings for zookeeper

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libzookeeper-st2
Package version 3.3.5+dfsg1
Package release 2
Package architecture amd64
Package type deb
Installed size 124 B
Download size 60.44 KB
Official Mirror ftp.br.debian.org
ZooKeeper is a centralized, reliable, service for maintaining configuration
information, naming, providing distributed synchronization, and group
services. All of these kinds of services are used in some form or another by
distributed applications.
This package contains the single-threaded libraries for the C bindings.

Alternatives

Package Version Architecture Repository
libzookeeper-st2_3.4.5+dfsg-2+deb7u1_i386.deb 3.4.5+dfsg i386 Debian Security Updates Main
libzookeeper-st2_3.4.5+dfsg-2+deb7u1_amd64.deb 3.4.5+dfsg amd64 Debian Security Updates Main
libzookeeper-st2_3.3.5+dfsg1-2_i386.deb 3.3.5+dfsg1 i386 Debian Main
libzookeeper-st2 - - -

Requires

Name Value
libc6 >= 2.3.4
multiarch-support -

Download

Type URL
Binary Package libzookeeper-st2_3.3.5+dfsg1-2_amd64.deb
Source Package zookeeper

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libzookeeper-st2 deb package:
    # sudo apt-get install libzookeeper-st2

Files

Path
/usr/lib/x86_64-linux-gnu/libzookeeper_st.so.2
/usr/lib/x86_64-linux-gnu/libzookeeper_st.so.2.0.0
/usr/share/doc/libzookeeper-st2/changelog.Debian.gz
/usr/share/doc/libzookeeper-st2/changelog.gz
/usr/share/doc/libzookeeper-st2/copyright

Changelog

2012-05-28 - James Page <james.page@ubuntu.com>
zookeeper (3.3.5+dfsg1-2) unstable; urgency=low
* d/patches/fixes/ZOOKEEPER-1431: Fix up memory leak in zookeeper
python binding which results in significant memory growth for large
result sets (Closes: #665962). Thanks to Johan Rydberg for identifying 
this bug and Kapil Thangavelu for the patch.
2012-05-10 - Matthias Klose <doko@debian.org>
zookeeper (3.3.5+dfsg1-1.1) unstable; urgency=low
* Non maintainer upload.
* Fix build failure with GCC 4.7.
2012-03-21 - James Page <james.page@ubuntu.com>
zookeeper (3.3.5+dfsg1-1) unstable; urgency=low
* New upstream bugfix release.
- d/fix-broken-c-client-unittest.patch: Dropped - accepted upstream.
- Refreshed all other patches.
* Bumped Standards-Version: 3.9.3.
* Fix issue with quoting of parameters in zkCli.sh (Closes: #661837):
- d/patches/fixes/ZOOKEEPER-1403: Ensure parameters are correctly
quoted - thanks to John Eikenberry for this fix.
2012-01-30 - James Page <james.page@ubuntu.com>
zookeeper (3.3.4+dfsg1-3) unstable; urgency=low
* Sync changes from Ubuntu:
- Switch zookeeperd upstart configuration to use start-stop-daemon.
Thanks to Clint Byrum for this fix.
- Enable C and Java test suites:
- d/patches/fixes/ZOOKEEPER-1374: Use __sync_* primitives
instead of ASM code when available to improve portability across 
supported platforms.
- d/patches/fix-broken-c-client-test.patch: Fixes the unit test so
it will pass with EINVAL which is the correct error. Thanks to
Clint Byrum for this fix.
- d/rules: Enable C client test suite for all architectures.
- d/rules: Only run core Java test suite when building 
Architecture: all packages.
2011-12-12 - James Page <james.page@ubuntu.com>
zookeeper (3.3.4+dfsg1-2) unstable; urgency=low
* Added new libzookeeper-st{2,-dev} packages (Closes: #650938) and 
renamed libzookeeper{2,-dev} -> libzookeeper-mt{2,-dev}.
* Added transitional package libzookeeper2 -> libzookeeper-mt2.
* Convert libzookeeper-{st,mt}2 for MultiArch support.
* Disable detection of cygwin as not relevant for Debian based
installs and complicates configuration (Closes: #650882). Thanks
to Akira Kitada for this patch.
* Really close RFH (Closes: #579791).
2011-12-01 - James Page <james.page@ubuntu.com>
zookeeper (3.3.4+dfsg1-1) unstable; urgency=low
[ James Page ]
* New upstream release:
- d/patches/fixes/ZOOKEEPER-1117: Dropped - fix included upstream.
- Refreshed patches.
* Added support for upstart under Ubuntu (LP: #862762):
- d/rules,d/zookeeperd.upstart.in: Detect Ubuntu and swap in provided 
upstart configuration if required.
- d/ubuntu|debian_control_vars,d/control,d/rules: Provide different Depends 
for zookeeperd package when building under Ubuntu/Debian.
* Enabled C and Java test suites:
- d/control,d/compat: Bumped debhelper compat level to 8 to allow 
arch/indep overrides.
- d/rules: Enable test suites for -arch and -indep builds.
- d/patches/debian/patch-build-system: Patch unit testing to exclude 
InvalidSnapshot and Upgrade tests (non-free data) and to pickup 
junit4 from system library.
- d/rules: Disable test suite execution for the time being as does 
not run reliably.
* Close RFH for this package (LP: #579791).
[ Damien Raude-Morvan ]
* Add DMUA flag for James Page.
* Build-Depends on procps for test suite.
2011-08-31 - James Page <james.page@ubuntu.com>
zookeeper (3.3.3+dfsg2-2) unstable; urgency=low
* Updated patch for ZOOKEEPER-1117 with fixes accepted into
zookeeper 3.4.0 upstream; should also resolve FTBFS on ia64.
* Close RFH from original maintainer (Closes: #602694).
* debian/zookeeper.cron.daily: handle return code of 1 so daily cron job
does not produce error emails when the package is removed but not
purged (Closes: #582757). Thanks to Clint Byrum for this fix.

See Also

Package Description
libzookeeper2_3.3.5+dfsg1-2_amd64.deb C bindings for zookeeper - transitional package
libzoom-ruby1.8_0.4.1-5_all.deb Transitional package for ruby-zoom
libzoom-ruby_0.4.1-5_all.deb Transitional package for ruby-zoom
libzorp-dev_3.9.5-4_amd64.deb Development files needed to compile Zorp modules
libzorp3.9_3.9.5-4_amd64.deb Runtime library of Zorp
libzorpll-dev_3.9.1.3-1_amd64.deb Zorp low-level functions - development files
libzorpll3.9-1-memtrace_3.9.1.3-1_amd64.deb Zorp low-level functions - memory debugging version
libzorpll3.9-1_3.9.1.3-1_amd64.deb Zorp low-level functions
libzrtpcpp-dev_2.0.0-3_amd64.deb Headers and static link library for libzrtpcpp
libzrtpcpp2_2.0.0-3_amd64.deb ccrtp extension for zrtp/Zfone support
libzthread-2.3-2_2.3.2-7_amd64.deb Object-oriented synchronization library for C++
libzthread-dev_2.3.2-7_amd64.deb Object-oriented synchronization library for C++
libzvbi-common_0.2.33-6_all.deb Vertical Blanking Interval decoder (VBI) - common files
libzvbi-dev_0.2.33-6_amd64.deb Vertical Blanking Interval decoder (VBI) - development files
libzvbi-doc_0.2.33-6_all.deb Vertical Blanking Interval decoder (VBI) - documentation files
Advertisement
Advertisement