libzmq-dev_2.2.0+dfsg-2_amd64.deb


Advertisement

Description

libzmq-dev - lightweight messaging kernel (development files)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libzmq-dev
Package version 2.2.0+dfsg
Package release 2
Package architecture amd64
Package type deb
Installed size 998 B
Download size 360.64 KB
Official Mirror ftp.br.debian.org
ØMQ is a library which extends the standard socket interfaces with features
traditionally provided by specialised messaging middleware products.
ØMQ sockets provide an abstraction of asynchronous message queues, multiple
messaging patterns, message filtering (subscriptions), seamless access to
multiple transport protocols and more.
This package contains the ZeroMQ development libraries and header files.

Alternatives

Package Version Architecture Repository
libzmq-dev_2.2.0+dfsg-2_i386.deb 2.2.0+dfsg i386 Debian Main
libzmq-dev - - -

Requires

Name Value
libzmq1 = 2.2.0+dfsg-2

Download

Type URL
Binary Package libzmq-dev_2.2.0+dfsg-2_amd64.deb
Source Package zeromq

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libzmq-dev deb package:
    # sudo apt-get install libzmq-dev

Files

Path
/usr/include/zmq.h
/usr/include/zmq.hpp
/usr/include/zmq_utils.h
/usr/lib/x86_64-linux-gnu/libzmq.a
/usr/lib/x86_64-linux-gnu/libzmq.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libzmq.pc
/usr/share/doc/libzmq-dev/changelog.Debian.gz
/usr/share/doc/libzmq-dev/changelog.gz
/usr/share/doc/libzmq-dev/copyright
/usr/share/man/man3/zmq_bind.3.gz
/usr/share/man/man3/zmq_close.3.gz
/usr/share/man/man3/zmq_connect.3.gz
/usr/share/man/man3/zmq_device.3.gz
/usr/share/man/man3/zmq_errno.3.gz
/usr/share/man/man3/zmq_getsockopt.3.gz
/usr/share/man/man3/zmq_init.3.gz
/usr/share/man/man3/zmq_msg_close.3.gz
/usr/share/man/man3/zmq_msg_copy.3.gz
/usr/share/man/man3/zmq_msg_data.3.gz
/usr/share/man/man3/zmq_msg_init.3.gz
/usr/share/man/man3/zmq_msg_init_data.3.gz
/usr/share/man/man3/zmq_msg_init_size.3.gz
/usr/share/man/man3/zmq_msg_move.3.gz
/usr/share/man/man3/zmq_msg_size.3.gz
/usr/share/man/man3/zmq_poll.3.gz
/usr/share/man/man3/zmq_recv.3.gz
/usr/share/man/man3/zmq_send.3.gz
/usr/share/man/man3/zmq_setsockopt.3.gz
/usr/share/man/man3/zmq_socket.3.gz
/usr/share/man/man3/zmq_strerror.3.gz
/usr/share/man/man3/zmq_term.3.gz
/usr/share/man/man3/zmq_version.3.gz
/usr/share/man/man7/zmq.7.gz
/usr/share/man/man7/zmq_cpp.7.gz
/usr/share/man/man7/zmq_epgm.7.gz
/usr/share/man/man7/zmq_inproc.7.gz
/usr/share/man/man7/zmq_ipc.7.gz
/usr/share/man/man7/zmq_pgm.7.gz
/usr/share/man/man7/zmq_tcp.7.gz

Changelog

2012-06-03 - Alessandro Ghedini <ghedo@debian.org>
zeromq (2.2.0+dfsg-2) unstable; urgency=low
* Make -dev package Multi-Arch: same too (Closes: #674601)
2012-05-22 - Alessandro Ghedini <ghedo@debian.org>
zeromq (2.2.0+dfsg-1) unstable; urgency=low
* New maintainer (Closes: #673619)
* Repack upstream tarball to remove bundled openpgm tarball and xmlParser
- Mangle dversion in watch file
* Switch to short-form dh rules file
- Use autotools-dev plugin
* Bump debhelper compat level to 9
* Update copyright file using Copyright-Format 1.0
* Remove source options
* Remove unused lintian overrides
* Add Multi-Arch headers
- Fix *.install files to use multi-arch paths
* Vcs-* tags point to collab-maint repository
* Fix short and long descriptions formatting
* Ignore beta 3.x releases in watch file
* Remove outdated and uselss README.Debian
2012-05-20 - Martin Lucina <martin@lucina.net>
zeromq (2.2.0-1) unstable; urgency=low
* [5661946] Imported Upstream version 2.2.0 (Closes: #672427)
* [bbf467d] Bump Standards-Version to 3.9.3 with no changes
* [0da0708] Add Vcs-Git and Vcs-Browser to debian/control
2012-01-23 - Martin Lucina <martin@lucina.net>
zeromq (2.1.11-1) unstable; urgency=low
* [4016b65] Imported Upstream version 2.1.11
* [eaa74d0] Maintainer e-mail address changed
* [9943256] Run testsuite during build (Closes: #655620)
* [5ea0ff8] Remove unneeded libzmq.la from libzmq-dev (Closes: #633292)
2011-10-03 - Martin Lucina <mato@kotelna.sk>
zeromq (2.1.10-1) unstable; urgency=low
* New upstream version. 
2011-09-08 - Martin Lucina <mato@kotelna.sk>
zeromq (2.1.9-1) unstable; urgency=low
* New upstream version. 
2011-05-13 - Martin Lucina <mato@kotelna.sk>
zeromq (2.1.7-1) unstable; urgency=low
* New upstream version. (closes: #619374)
* --with-system-pgm is now used instead of the embedded OpenPGM library. 
* Added Debian watch file.
2011-04-07 - Martin Lucina <mato@kotelna.sk>
zeromq (2.1.4-1) experimental; urgency=low
* New upstream version.
* OpenPGM re-enabled for amd64 and i386, still using embedded library.
2011-03-28 - Martin Lucina <mato@kotelna.sk>
zeromq (2.1.3-1) experimental; urgency=low
* New upstream version.
* The zeromq-bin package has been removed, as upstream has removed the
devices.
* Temporarily disabled OpenPGM builds on i386 and amd64 due to changes in
upstream OpenPGM intergration. 
2010-10-21 - Martin Lucina <mato@kotelna.sk>
zeromq (2.0.10-1) unstable; urgency=low
* New upstream version.
* Upstream now uses DFSG-clean OpenPGM tarball, so dropping .dfsg from 
the Debian version.

See Also

Package Description
libzmq1_2.2.0+dfsg-2_amd64.deb lightweight messaging kernel (shared library)
libzn-poly-0.8_0.8-1.1_amd64.deb A library for polynomial arithmetic in Z/nZ[x]
libzn-poly-dev_0.8-1.1_amd64.deb A library for polynomial arithmetic in Z/nZ[x]
libzookeeper-java-doc_3.3.5+dfsg1-2_all.deb API Documentation for zookeeper
libzookeeper-java_3.3.5+dfsg1-2_all.deb Core Java libraries for zookeeper
libzookeeper-mt-dev_3.3.5+dfsg1-2_amd64.deb Development files for multi threaded zookeeper C bindings
libzookeeper-mt2_3.3.5+dfsg1-2_amd64.deb Multi threaded C bindings for zookeeper
libzookeeper-st-dev_3.3.5+dfsg1-2_amd64.deb Development files for single threaded zookeeper C bindings
libzookeeper-st2_3.3.5+dfsg1-2_amd64.deb Single threaded C bindings for zookeeper
libzookeeper2_3.3.5+dfsg1-2_amd64.deb C bindings for zookeeper - transitional package
libzoom-ruby1.8_0.4.1-5_all.deb Transitional package for ruby-zoom
libzoom-ruby_0.4.1-5_all.deb Transitional package for ruby-zoom
libzorp-dev_3.9.5-4_amd64.deb Development files needed to compile Zorp modules
libzorp3.9_3.9.5-4_amd64.deb Runtime library of Zorp
libzorpll-dev_3.9.1.3-1_amd64.deb Zorp low-level functions - development files
Advertisement
Advertisement