libxvidcore-dev_1.3.2-9_amd64.deb


Advertisement

Description

libxvidcore-dev - Open source MPEG-4 video codec (development)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libxvidcore-dev
Package version 1.3.2
Package release 9
Package architecture amd64
Package type deb
Installed size 1.24 KB
Download size 371.31 KB
Official Mirror ftp.br.debian.org
Xvid (formerly XviD) is an open source MPEG-4 video codec, implementing MPEG-4
Simple Profile, Advanced Simple Profile, and Advanced Video Coding standards.
It is written in C with assembler optimizations for quality and speed
(including MMX, SSE, and 3Dnow! code for i386 and AltiVec for PowerPC), and is
especially optimized towards offline, multi-pass compression for storage and
archival purposes.
.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libxvidcore-dev_1.3.2-9_i386.deb 1.3.2 i386 Debian Main
libxvidcore-dev_1.3.2-dmo1_amd64.deb 1.3.2 amd64 Multimedia Main
libxvidcore-dev_1.3.2-dmo1_i386.deb 1.3.2 i386 Multimedia Main
libxvidcore-dev - - -

Requires

Name Value
libxvidcore4 = 2:1.3.2-9

Download

Type URL
Binary Package libxvidcore-dev_1.3.2-9_amd64.deb
Source Package xvidcore

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxvidcore-dev deb package:
    # sudo apt-get install libxvidcore-dev

Files

Path
/usr/include/xvid.h
/usr/lib/x86_64-linux-gnu/libxvidcore.a
/usr/lib/x86_64-linux-gnu/libxvidcore.so
/usr/share/doc/libxvidcore-dev/changelog.Debian.gz
/usr/share/doc/libxvidcore-dev/changelog.gz
/usr/share/doc/libxvidcore-dev/copyright

Changelog

2012-03-18 - Andres Mejia <amejia@debian.org>
xvidcore (2:1.3.2-9) unstable; urgency=low
* Pass hardened CPPFLAGS to CFLAGS. (Closes: #664512)
2012-03-17 - Andres Mejia <amejia@debian.org>
xvidcore (2:1.3.2-8) unstable; urgency=low
* Add in hardened CFLAGS.
2012-03-16 - Andres Mejia <amejia@debian.org>
xvidcore (2:1.3.2-7) unstable; urgency=low
* Allow dev package to be multiarch installable.
* Bump to Standards-Version 3.9.3.
2011-09-17 - Andres Mejia <amejia@debian.org>
xvidcore (2:1.3.2-6) unstable; urgency=low
* Convert package to support multiarch library.
2011-07-29 - Fabian Greffrath <fabian+debian@greffrath.com>
xvidcore (2:1.3.2-5) unstable; urgency=low
* Introduce a debian/confflags file to conditionally disable
assembly optimizations on certain archs until we introduce flavours.
* Disable yasm support for kfreebsd-amd64 again, it is known
to be broken and also disabled in FreeBSD (Closes: #635719).
2011-07-28 - Fabian Greffrath <fabian+debian@greffrath.com>
xvidcore (2:1.3.2-4) unstable; urgency=low
* Add patch by Pino Toscano to add support for GNU Hurd as target OS,
requires running autoconf (Closes: #635662).
* Extend Build-Depends on yasm to [any-i386 any-amd64].
2011-07-26 - Andres Mejia <amejia@debian.org>
xvidcore (2:1.3.2-3) unstable; urgency=low
* Fix typo to location of LGPL-2 on Debian systems.
2011-07-26 - Reinhard Tartler <siretart@tauware.de>
xvidcore (2:1.3.2-2) unstable; urgency=low
[ Fabian Greffrath ]
* Build-Depend on yasm. A recent enough version is in Debian now and
the configure script prefers it over nasm.
[ Reinhard Tartler ]
* document copyright and license of altivec assembler
2011-07-25 - Andres Mejia <amejia@debian.org>
xvidcore (2:1.3.2-1) unstable; urgency=low
[ Fabian Greffrath ]
* Imported Upstream version 1.3.2 (Closes: #531040)
+ dropped the debian/ directory from release tarballs.
+ updated the configure helper scripts.
+ Makefile does not include platform.inc in clean rules anymore.
+ Makefile now shows build infos in the default build rule.
[ Andres Mejia ]
* Update to my @debian.org email.
* Update debian/copyright to reflect licensing of new upstream release.
* Update debian/copyright to DEP-5 spec.
2011-05-03 - Andres Mejia <mcitadel@gmail.com>
xvidcore (2:1.3.1-1) UNRELEASED; urgency=low
[ Fabian Greffrath ]
* Imported Upstream version 1.3.1
* Remove configure.in-fix.patch and no-exec-stack-elf32.patch,
applied upstream.
* Upstream updated their configure script, so drop autoconf.
* Update debian/gbp.conf and document filtering in git-import-orig.
* Fix so-symlink in debian/libxvidcore-dev.links.
* Simplify the changes to show build options during build.
[ Andres Mejia ]
* Show build options during build.
* Simplify setting of CFLAGS.
* Bump to Standards-Version 3.9.2.
* Fix description-synopsis-starts-with-article lintian warnings.
* Support parallel builds.
* Enable -O3 instead of -O2.
* Include Vcs-* entries.
* Add DM-Upload-Allowed: yes.
* Include local options to unapply all patches and abort on any upstream
changes.

See Also

Package Description
libxvidcore4_1.3.2-9_amd64.deb Open source MPEG-4 video codec (library)
libxvmc-dev_1.0.7-1+deb7u2_amd64.deb X11 Video extension library (development headers)
libxvmc1_1.0.7-1+deb7u2_amd64.deb X11 Video extension library
libxxf86dga-dev_1.1.3-2+deb7u1_amd64.deb X11 Direct Graphics Access extension library (development headers)
libxxf86dga1_1.1.3-2+deb7u1_amd64.deb X11 Direct Graphics Access extension library
libxxf86vm-dev_1.1.2-1+deb7u1_amd64.deb X11 XFree86 video mode extension library (development headers)
libxxf86vm1_1.1.2-1+deb7u1_amd64.deb X11 XFree86 video mode extension library
libxy-bin_0.8-1+b1_amd64.deb xylib - utilities
libxy-dev_0.8-1+b1_amd64.deb xylib development files
libxy3_0.8-1+b1_amd64.deb Library for reading x-y data from several file formats
libxz-java-doc_1.0-2_all.deb Documentation for libxz-java
libxz-java_1.0-2_all.deb Java library with a complete implementation of XZ data compression
libyahoo2-11_1.0.1-1_amd64.deb Yahoo Messenger protocol C library
libyahoo2-dev_1.0.1-1_amd64.deb Yahoo Messenger protocol C library (development)
libyajl-dev_2.0.4-2_amd64.deb Yet Another JSON Library - development files
Advertisement
Advertisement