libxerces-c28_2.8.0+deb1-3_amd64.deb


Advertisement

Description

libxerces-c28 - validating XML parser library for C++

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libxerces-c28
Package version 2.8.0+deb1
Package release 3
Package architecture amd64
Package type deb
Installed size 4.28 KB
Download size 1.29 MB
Official Mirror ftp.br.debian.org
Xerces-C++ is a validating XML parser written in a portable subset of
C++.  Xerces-C++ makes it easy to give your application the ability
to read and write XML data. A shared library is provided for parsing,
generating, manipulating, and validating XML documents. Xerces-C++ is
faithful to the XML 1.0 recommendation and associated standards (DOM
1.0, DOM 2.0, SAX 1.0, SAX 2.0, Namespaces, XML Schema Part 1 and
Part 2).  It also provides experimental implementations of XML 1.1
and DOM Level 3.0.  The parser provides high performance, modularity,
and scalability.

Alternatives

Package Version Architecture Repository
libxerces-c28_2.8.0+deb1-3_i386.deb 2.8.0+deb1 i386 Debian Main
libxerces-c28 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libicu48 >= 4.8-1
libstdc++6 >= 4.1.1

Conflicts

Name Value
libxerces28 <= 2.8.0-2

Replaces

Name Value
libxerces28 -

Download

Type URL
Binary Package libxerces-c28_2.8.0+deb1-3_amd64.deb
Source Package xerces-c2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxerces-c28 deb package:
    # sudo apt-get install libxerces-c28

Files

Path
/usr/lib/libxerces-c.so.28
/usr/lib/libxerces-c.so.28.0
/usr/lib/libxerces-depdom.so.28
/usr/lib/libxerces-depdom.so.28.0
/usr/share/doc/libxerces-c28/README.Debian
/usr/share/doc/libxerces-c28/changelog.Debian.gz
/usr/share/doc/libxerces-c28/copyright
/usr/share/lintian/overrides/libxerces-c28

Changelog

2012-06-29 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0+deb1-3) unstable; urgency=low
* Package cleanup: update standards version, switch source format,
hardening
2009-08-24 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0+deb1-2) unstable; urgency=low
* Apply patch to correct CVE-2009-1885: DoS attack from nested DTDs.
(Closes: #541986)
2009-08-21 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0+deb1-1) unstable; urgency=low
* Repackage to eliminate tarball-in-orig.tar.gz packaging.  This is the
same version as 2.8.0.  (Closes: #538572)
* Updated standards to 3.8.3 (no changes required).
2009-06-11 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0-4) unstable; urgency=low
* Added '02-gnu.patch' and '12-gnu-reconf.patch' patches to add support
for Hurd.  Thanks Marc Dequènes (Duck) <duck@hurdfr.org>.
(Closes: #530283)
* Converted patches to use quilt
* Created README.source
* Updated standards version to 3.8.1
2008-07-04 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0-3) unstable; urgency=low
* Change priority from extra to optional as priority optional packages
depend on xerces-c2.
2008-06-28 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0-2) unstable; urgency=low
* Apply kbsd patches adjusted from xerces27.  (Closes: #487653)
* Replace Apache License with reference to file in common-licenses.
2008-03-22 - Jay Berkenbilt <qjb@debian.org>
xerces-c2 (2.8.0-1) unstable; urgency=low
* Reorganize package in preparation for xerces 3.0.0:
- source package: xerces28 -> xerces-c2
- binary package: libxerces28 -> libxerces-c28
- dev package: libxerces28-dev -> libxerces-c2-dev
- doc package: libxerces28-doc -> libxerces-c2-doc
2007-12-10 - Jay Berkenbilt <qjb@debian.org>
xerces28 (2.8.0-2) unstable; urgency=low
* Change build dependency to libicu-dev instead of libicu36-dev
* Update standards version to 3.7.3 (no changes required)
2007-09-15 - Jay Berkenbilt <qjb@debian.org>
xerces28 (2.8.0-1) unstable; urgency=low
* New upstream release
2007-08-21 - Jay Berkenbilt <qjb@debian.org>
xerces28 (2.8.0~rc1-1) experimental; urgency=low
* Initial release.  Note: doc-base refers to non-existent file here, but
this should be fixed for the real release.

See Also

Package Description
libxerces-c3.1_3.1.1-3+deb7u2_amd64.deb validating XML parser library for C++
libxerces2-java-doc_2.11.0-6_all.deb Validating XML parser for Java -- Documentation and examples
libxerces2-java-gcj_2.11.0-6_amd64.deb Validating XML parser for Java with DOM level 3 support (native code)
libxerces2-java_2.11.0-6_all.deb Validating XML parser for Java with DOM level 3 support
libxext-dev_1.3.1-2+deb7u1_amd64.deb X11 miscellaneous extensions library (development headers)
libxext-doc_1.3.1-2+deb7u1_all.deb X11 miscellaneous extensions library (documentation)
libxext6_1.3.1-2+deb7u1_amd64.deb X11 miscellaneous extension library
libxfce4menu-0.1-0_4.6.2-1_amd64.deb freedesktop.org compliant menu implementation for Xfce
libxfce4menu-0.1-dev_4.6.2-1_amd64.deb Development files for libxfce4menu
libxfce4ui-1-0_4.8.1-1_amd64.deb widget library for Xfce
libxfce4ui-1-dev_4.8.1-1_amd64.deb Development files for libxfce4ui
libxfce4util-bin_4.8.2-1_amd64.deb tools for libxfce4util
libxfce4util-common_4.8.2-1_all.deb common files for libxfce4util
libxfce4util-dev_4.8.2-1_amd64.deb Development files for libxfce4util4
libxfce4util4_4.8.2-1_amd64.deb Utility functions library for Xfce4
Advertisement
Advertisement