libxenapi-ocaml-dev_1.3.2-15_amd64.deb


Advertisement

Description

libxenapi-ocaml-dev - Xen Cloud Platform - OCaml bindings

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libxenapi-ocaml-dev
Package version 1.3.2
Package release 15
Package architecture amd64
Package type deb
Installed size 6.43 KB
Download size 1.15 MB
Official Mirror ftp.br.debian.org
The Xen Cloud Platform (XCP) is a server virtualization and cloud
computing platform, with support for a range of guest operating systems,
including Linux network and storage support.
XCP addresses the needs of cloud providers, hosting services and data
centers by combining the isolation and multitenancy capabilities of the
Xen hypervisor with enhanced security, storage, and network
virtualization technologies to offer a rich set of virtual infrastructure
cloud services. The platform also addresses user requirements for
security, availability, performance, and isolation across both private
and public clouds.
XCP consolidates server workloads, and enables savings in power, cooling,
and management costs. This improves reliability and adaptability in
ever-changing IT environments, with optimized use of existing hardware,
and contributes to environmentally sustainable computing.
This package contains OCaml libraries for the XenAPI. These will
allow a program to communicate with an XCP host running xapi.

Alternatives

Package Version Architecture Repository
libxenapi-ocaml-dev_1.3.2-15_i386.deb 1.3.2 i386 Debian Main
libxenapi-ocaml-dev - - -

Requires

Name Value
libxcp-ocaml-dev-fajb9 -
ocaml-nox-3.12.1 -

Download

Type URL
Binary Package libxenapi-ocaml-dev_1.3.2-15_amd64.deb
Source Package xen-api

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxenapi-ocaml-dev deb package:
    # sudo apt-get install libxenapi-ocaml-dev

Files

Path
/usr/lib/ocaml/xcp/xapi-client/META
/usr/lib/ocaml/xcp/xapi-client/aPI.cmi
/usr/lib/ocaml/xcp/xapi-client/aPI.cmx
/usr/lib/ocaml/xcp/xapi-client/api_errors.cmi
/usr/lib/ocaml/xcp/xapi-client/api_errors.cmx
/usr/lib/ocaml/xcp/xapi-client/api_messages.cmi
/usr/lib/ocaml/xcp/xapi-client/api_messages.cmx
/usr/lib/ocaml/xcp/xapi-client/client.cmi
/usr/lib/ocaml/xcp/xapi-client/client.cmx
/usr/lib/ocaml/xcp/xapi-client/constants.cmi
/usr/lib/ocaml/xcp/xapi-client/constants.cmx
/usr/lib/ocaml/xcp/xapi-client/datamodel_types.cmi
/usr/lib/ocaml/xcp/xapi-client/datamodel_types.cmx
/usr/lib/ocaml/xcp/xapi-client/event_helper.cmi
/usr/lib/ocaml/xcp/xapi-client/event_helper.cmx
/usr/lib/ocaml/xcp/xapi-client/event_types.cmi
/usr/lib/ocaml/xcp/xapi-client/event_types.cmx
/usr/lib/ocaml/xcp/xapi-client/features.cmi
/usr/lib/ocaml/xcp/xapi-client/features.cmx
/usr/lib/ocaml/xcp/xapi-client/fhs.cmi
/usr/lib/ocaml/xcp/xapi-client/fhs.cmx
/usr/lib/ocaml/xcp/xapi-client/ref.cmi
/usr/lib/ocaml/xcp/xapi-client/ref.cmx
/usr/lib/ocaml/xcp/xapi-client/util_globs_inventory.cmi
/usr/lib/ocaml/xcp/xapi-client/util_globs_inventory.cmx
/usr/lib/ocaml/xcp/xapi-client/util_inventory.cmi
/usr/lib/ocaml/xcp/xapi-client/util_inventory.cmx
/usr/lib/ocaml/xcp/xapi-client/v6daemon.cmi
/usr/lib/ocaml/xcp/xapi-client/v6daemon.cmx
/usr/lib/ocaml/xcp/xapi-client/v6errors.cmi
/usr/lib/ocaml/xcp/xapi-client/v6errors.cmx
/usr/lib/ocaml/xcp/xapi-client/v6rpc.cmi
/usr/lib/ocaml/xcp/xapi-client/v6rpc.cmx
/usr/lib/ocaml/xcp/xapi-client/version.cmi
/usr/lib/ocaml/xcp/xapi-client/version.cmx
/usr/lib/ocaml/xcp/xapi-client/xapi_client.a
/usr/lib/ocaml/xcp/xapi-client/xapi_client.cmxa
/usr/lib/ocaml/xcp/xapi-client/xapi_fist.cmi
/usr/lib/ocaml/xcp/xapi-client/xapi_fist.cmx
/usr/lib/ocaml/xcp/xapi-client/xapi_globs.cmi
/usr/lib/ocaml/xcp/xapi-client/xapi_globs.cmx
/usr/lib/ocaml/xcp/xapi-client/xapi_inventory.cmi
/usr/lib/ocaml/xcp/xapi-client/xapi_inventory.cmx
/usr/lib/ocaml/xcp/xapi-datamodel/META
/usr/lib/ocaml/xcp/xapi-datamodel/api_messages.cmi
/usr/lib/ocaml/xcp/xapi-datamodel/datamodel.a
/usr/lib/ocaml/xcp/xapi-datamodel/datamodel.cmi
/usr/lib/ocaml/xcp/xapi-datamodel/datamodel.cmxa
/usr/lib/ocaml/xcp/xapi-datamodel/datamodel_types.cmi
/usr/lib/ocaml/xcp/xapi-datamodel/datamodel_utils.cmi
/usr/lib/ocaml/xcp/xapi-datamodel/dm_api.cmi
/usr/share/doc/libxenapi-ocaml-dev/changelog.Debian.gz
/usr/share/doc/libxenapi-ocaml-dev/copyright
/var/lib/ocaml/lintian/libxenapi-ocaml-dev.info
/var/lib/ocaml/md5sums/libxenapi-ocaml-dev.md5sums

Changelog

2013-03-23 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-15) unstable; urgency=low
* Fixes xe pif-reconfigure-ip with a netmask smaller than /24, thanks to
Marc Lebel & Daniel Pocock for reporting (Closes: #695221).
* Lots of fixes in the README.Debian (Closes: #702337).
2012-12-27 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-14) unstable; urgency=low
* Fixes: if apt-get was used to install xcp-networkd instead of dpkg -i, then
debconf value selected for network-type wasn't respected (Closes: #696810).
2012-11-03 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-13) unstable; urgency=low
* Fixes: wait_for_xapi() function in init.d script doesn't work on slave
hosts (Closes: #681343), thanks to George Shuklin <george.shuklin@gmail.com>
for the report and patch.
* Fixes: scripts/set-hostname was designed for CentOS, this has been patched
to fix this (Closes: #688961).
2012-10-24 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-12) unstable; urgency=low
* Fixes bashism in install-debian-pv.sh (Closes: #690612).
* Fixes bashism in interface-visualise (Closes: #690710).
* The /etc/init.d/xcp-squeezed script now depends on /etc/init.d/xen since it
has been renamed like this from xend. For this reason, xcp-squeezed now
depends on xen-utils-common (>= 4.1.3-3) (Closes: #682202).
* Downgrades openvswitch dependencies to Recommends: (Closes: #686779).
* Few corrections in the README.Debian (Closes: #682122, #682120).
2012-08-22 - Mike McClurg <mike.mcclurg@citrix.com>
xen-api (1.3.2-11) unstable; urgency=high
* Fix PAM settings to only allow root to issue remote commands (LP: #1033899)
2012-07-25 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-10) unstable; urgency=high
* Fixes access rights: any user on the server could use xe to control xapi.
- Adds a xapi group.
- Configure PAM to only grant access to root and xapi groups.
2012-07-07 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-9) unstable; urgency=low
* xcp-xapi init script now Should-Start: xcp-networkd (Closes: #680588).
* Fixes host-disable and host-reboot make host disable forever by adding the
'-onsystemboot' parameter when starting the xcp-xapi daemon. Thanks to
George Shuklin <george.shuklin@gmail.com>for the report (Closes: #678923).
* Checks if $1 = configure in debian/xcp-networkd.postinst, which as a side
effect is also repairing debconf choice (openvswitch was used no mater what).
* Added upstream fix for the firstboot.d folder problem (Closes: #680102).
2012-07-05 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-8) unstable; urgency=low
* Typo on debian/DEBIAN.Readme.
* Quilt refresh patches.
* Applied upstream fix for lack of /local/domain/0/vm in xenstore prevents
vbd/vif plug bug (Closes: #674161).
2012-06-29 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-7) unstable; urgency=low
* Added xe-edit-bootloader.patch to fix incompatible with new /dev/sm
(Closes: #675055, #675050), thanks to George Shuklin
<george.shuklin@gmail.com> for reporting.
* Fixes "xe pif-configure-ip does not remove old ip from interface",
thanks to George Shuklin <george.shuklin@gmail.com> for reporting
(Closes: #677395).
* Fixed debian/README.Debian to tell about the MANAGEMENT_INTERFACE in the
/etc/xcp/inventory file (Closes: #655303).
* debian/README.Debian now advises correctly to use xapi as TOOLSTACK and not
xe anymore (Closes: #674132).
2012-05-21 - Thomas Goirand <zigo@debian.org>
xen-api (1.3.2-6) unstable; urgency=low
[Martin Pitt <martin.pitt@ubuntu.com>]
* debian/control, debian/README.Debian: Move from smbfs (which is not built
any more) to cifs-utils.

See Also

Package Description
libxenomai-dev_2.6.0-2_amd64.deb Headers and static libs for Xenomai
libxenomai1_2.6.0-2_amd64.deb Shared libraries for Xenomai
libxenstore3.0_4.1.4-3+deb7u9_amd64.deb Xenstore communications library for Xen
libxerces-c-dev_3.1.1-3+deb7u2_amd64.deb validating XML parser library for C++ (development files)
libxerces-c-doc_3.1.1-3+deb7u2_all.deb validating XML parser library for C++ (documentation)
libxerces-c-samples_3.1.1-3+deb7u2_amd64.deb validating XML parser library for C++ (compiled samples)
libxerces-c2-dev_2.8.0+deb1-3_amd64.deb validating XML parser library for C++ (development files)
libxerces-c2-doc_2.8.0+deb1-3_all.deb validating XML parser library for C++ (documentation)
libxerces-c28_2.8.0+deb1-3_amd64.deb validating XML parser library for C++
libxerces-c3.1_3.1.1-3+deb7u2_amd64.deb validating XML parser library for C++
libxerces2-java-doc_2.11.0-6_all.deb Validating XML parser for Java -- Documentation and examples
libxerces2-java-gcj_2.11.0-6_amd64.deb Validating XML parser for Java with DOM level 3 support (native code)
libxerces2-java_2.11.0-6_all.deb Validating XML parser for Java with DOM level 3 support
libxext-dev_1.3.1-2+deb7u1_amd64.deb X11 miscellaneous extensions library (development headers)
libxext-doc_1.3.1-2+deb7u1_all.deb X11 miscellaneous extensions library (documentation)
Advertisement
Advertisement