libwxgtk2.8-dev_2.8.12.1-12_amd64.deb


Advertisement

Description

libwxgtk2.8-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libwxgtk2.8-dev
Package version 2.8.12.1
Package release 12
Package architecture amd64
Package type deb
Installed size 169 B
Download size 104.52 KB
Official Mirror ftp.br.debian.org
wxWidgets (formerly known as wxWindows) is a class library for C++ providing
GUI components and other facilities on several popular platforms (and some
unpopular ones as well).
This package provides files needed to compile wxWidgets programs.  If you
want to compile apps using the (optional) glcanvas library you will need
to have Mesa or OpenGL installed too.
This package also provides the wx-config script.

Alternatives

Package Version Architecture Repository
libwxgtk2.8-dev_2.8.12.1-12_i386.deb 2.8.12.1 i386 Debian Main
libwxgtk2.8-dev - - -

Requires

Name Value
libwxbase2.8-dev = 2.8.12.1-12
libwxgtk2.8-0 = 2.8.12.1-12
wx-common -
wx2.8-headers = 2.8.12.1-12

Download

Type URL
Binary Package libwxgtk2.8-dev_2.8.12.1-12_amd64.deb
Source Package wxwidgets2.8

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwxgtk2.8-dev deb package:
    # sudo apt-get install libwxgtk2.8-dev

Files

Path
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_adv-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_aui-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_fl-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_gizmos-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_gizmos_xrc-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_gl-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_html-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_ogl-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_plot-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_qa-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_richtext-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_stc-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_svg-2.8.so
/usr/lib/x86_64-linux-gnu/libwx_gtk2u_xrc-2.8.so
/usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-release-2.8
/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8/wx/setup.h
/usr/share/doc/libwxgtk2.8-dev/changelog.Debian.gz
/usr/share/doc/libwxgtk2.8-dev/changelog.gz
/usr/share/doc/libwxgtk2.8-dev/copyright

Changelog

2012-09-19 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-12) unstable; urgency=low
* Make python-wxversion conflict with python-wxgtk2.8 (<< 2.8.12.1-1~) to
guarantee upgrade ordering when moving from pycentral to dh_python2.
(Closes: #684150)
2012-06-01 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-11) unstable; urgency=low
* It looks like upstream may not make another 2.8 release, and if they do
it's unlikely to happen before the freeze, so backport several simple but
useful patches from upstream's 2.8 SVN branch:
+ ico-saving-buffer-overrun.patch
+ richtextxml-fix.patch
+ slider-label-update.patch
+ wxclipboard-getdata.patch
+ wxvlistboxcombopopup-wxcbsort.patch
+ wxstatictext-rtl-alignright.patch
+ improve-bmp-decoding.patch
+ fix-aui-dock-crash.patch
+ wxdatetime-chained.patch (Closes: #242737)
+ Update Italian and Hungarian i18n.
+ Add Tamil and Arabic i18n.
* Fix typo in package descriptions.
2012-05-28 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-10) unstable; urgency=low
* Build-depends on libpng-dev instead of libpng12-dev.  (Closes: #662553)
* Add patch bp-menubar-fix.patch to fix sizing of new menubar.  
* Drop build-dependency on quilt, no longer used since -9.
* New patch desktop-files.patch which updates .desktop files to match the
current specification.
2012-04-26 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-9) unstable; urgency=low
* Switch to "3.0 (quilt)" to fix issues with patches not getting applied at
the right time, fixing FTBFS on buildds since they started to use
build-arch.  (Closes: #670447)
2012-04-25 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-8) unstable; urgency=low
* New patch handle-positional-printf-arguments.patch.  (Closes: #631696)
* debian/patches/remove-refs-to-FPB_DEFAULT_STYLE.patch: Strip CR.
* New patch debian/patches/de.po.patch.  (Closes: #663488)
* Standards-Version: 3.9.3 (no changes required).
2012-01-09 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-7) unstable; urgency=low
* Fix path to one of the bogus executable files in wx2.8-examples so it gets 
made non-executable as intended, really fixing the final lintian warning.
* Add patch remove-refs-to-FPB_DEFAULT_STYLE.patch to fix warning upon
refresh in XRCed.  (Closes: #654990)
* Fix syntax of "Bug-Debian" header in fix-wxcmdline-segv.patch.
* Add patch fix-more-typos.patch which fixes an assortment of typos in
documentation, documentation comments, and docstrings.
* "debian/rules clean" now removes wxPython/build-options.cache.
2011-12-21 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-6) unstable; urgency=low
* Install the files needed to wrap wx-using projects with SWIG.
(Closes: #627728)
* Fix files in wx2.8-examples which were executable for no good reason, which
fixes the remaining 9 lintian warnings.
2011-12-07 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-5) unstable; urgency=low
* Remove references to CVS and cvs.wxwidgets.org (which no longer works).
* Add DEP3 headers to more patches.
* Drop patch fix-config-scripts and instead copy them from /usr/share/misc
so we get up-to-date versions.
* debian/wx-config.1: Clarify text about debug builds.
* debian/control.in: Add missing ${misc:Depends} and ${misc:Pre-Depends}.
* debian/rules: Get rid of empty /usr/share/lintian/overrides directory
in python-wxtools.
2011-12-06 - Olly Betts <olly@survex.com>
wxwidgets2.8 (2.8.12.1-4) unstable; urgency=low
* Add support for multiarch same by applying patch from Gregory Hainaut.
(Closes: #645411)
* Tighten dependency from wxgtk2.8-dev to wx-common from "Suggests" to
"Depends" to ensure that the wx-config man page will be installed if
wx-config is. (Closes: #585986)
* debian/wxrc-tools.1: "2.6" -> "2.8"; "wxWindows -> wxWidgets".
* debian/wx-config.1: Fix typos.

See Also

Package Description
libwxsmithlib-dev_10.05-2.1_amd64.deb wxSmith development files (Code::Blocks plugin for RAD GUI editing)
libwxsmithlib0-dev_10.05-2.1_amd64.deb dummy transitional package for wxSmith development files
libwxsmithlib0_10.05-2.1_amd64.deb wxSmith shared library (Code::Blocks plugin for RAD GUI editing)
libwxsqlite3-2.8-0_3.0.0.1~dfsg0-2_amd64.deb SQLite3 C++ wrapper for use in programs based on the wxWidgets
libwxsqlite3-2.8-dev_3.0.0.1~dfsg0-2_amd64.deb Development files for wxSQLite3
libwxsvg-dev_1.1.8~dfsg0-2_amd64.deb Development files for wxSVG
libwxsvg0_1.1.8~dfsg0-2_amd64.deb SVG library for the wxWidgets toolkit
libx11-6_1.5.0-1+deb7u2_amd64.deb X11 client-side library
libx11-data_1.5.0-1+deb7u2_all.deb X11 client-side library
libx11-dev_1.5.0-1+deb7u2_amd64.deb X11 client-side library (development headers)
libx11-doc_1.5.0-1+deb7u2_all.deb X11 client-side library (development documentation)
libx11-freedesktop-desktopentry-perl_0.04-3_all.deb perl interface to Freedesktop.org .desktop files
libx11-guitest-perl_0.25-2_amd64.deb collection of functions for X11 GUI testing/interaction
libx11-protocol-perl_0.56-4_all.deb Perl module for the X Window System Protocol, version 11
libx11-xcb-dev_1.5.0-1+deb7u2_amd64.deb Xlib/XCB interface library (development headers)
Advertisement
Advertisement