libwine-gecko-dbg-1.4_1.4+dfsg1-3_all.deb


Advertisement

Description

libwine-gecko-dbg-1.4 - Windows API implementation - web browser debug build

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libwine-gecko-dbg-1.4
Package version 1.4+dfsg1
Package release 3
Package architecture all
Package type deb
Installed size 166.94 KB
Download size 166.06 MB
Official Mirror ftp.br.debian.org
Wine is a free MS-Windows API implementation.
This is still a work in progress and many applications may still not work.
This package contains a HTML renderer based on the Mozilla engine, Gecko,
with debugging symbols.

Alternatives

Package Version Architecture Repository
libwine-gecko-dbg-1.4_1.4+dfsg1-3_all.deb 1.4+dfsg1 all Debian Main
libwine-gecko-dbg-1.4 - - -

Download

Type URL
Binary Package libwine-gecko-dbg-1.4_1.4+dfsg1-3_all.deb
Source Package wine-gecko-1.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwine-gecko-dbg-1.4 deb package:
    # sudo apt-get install libwine-gecko-dbg-1.4

Files

Path
/usr/share/doc/libwine-gecko-dbg-1.4/changelog.Debian.gz
/usr/share/doc/libwine-gecko-dbg-1.4/copyright
/usr/share/wine-gecko/wine_gecko-1.4-x86-dbg.tar.bz2

Changelog

2012-09-23 - Stephen Kitt <steve@sk2.org>
wine-gecko-1.4 (1.4+dfsg1-3) unstable; urgency=low
* Revert to "Architecture: all".
* Add missing uuid-runtime build-dependency (for uuidgen).
* Upload to unstable.
2012-08-29 - Stephen Kitt <steve@sk2.org>
wine-gecko-1.4 (1.4+dfsg1-2) experimental; urgency=low
* Disable parallel builds (hopefully fixes kfreebsd-i386 FTBFS).
2012-08-24 - Stephen Kitt <steve@sk2.org>
wine-gecko-1.4 (1.4+dfsg1-1) experimental; urgency=low
* Filter out the remaining Windows binaries.
* Make the package "Architecture: any" so it only builds on
architectures with wine-bin (closes: #684844).
2012-06-15 - Stephen Kitt <steve@sk2.org>
wine-gecko-1.4 (1.4+dfsg-2) unstable; urgency=low
* Add Ubuntu alternative to the wine build-dependency (although the
binfmt-support conflict prevents building for now).
* Add yasm build-dependency which ends up being required on Ubuntu.
* Add Debian Wine party VCS URLs.
* Stop making the MSIs and debugging archives executable.
* Disable the 64-bit debug build until we can use 64-bit buildds to
build the package (either via multiarch or 64-bit wine-bin).
* Avoid ignoring errors in the debian/rules build-clean target.
* wrap-and-sort debian/control and debian/copyright.
* Drop unused lcab build-dependency.
* Use multiarch paths for wineserver.
* Clarify LPPL-1.3 paragraphs in debian/copyright.
2012-05-20 - Stephen Kitt <steve@sk2.org>
wine-gecko-1.4 (1.4+dfsg-1) unstable; urgency=low
* New upstream version, as required by Wine versions 1.3.33 to 1.4.
* Build-depend on wine or wine-unstable, now required to package wine-
gecko.
* Update patches:
- config: reworked to account for the new configuration layout;
- bashism: updated, wine/make_package already specifies /bin/bash;
- uintptr-redefinition, mno-cygwin-removed, gcc-4.6-temporary-varible:
removed, no longer relevant.
* Ship propvarutil.h from wine 1.4 (it's required for the build and
isn't yet part of mingw-w64).
* Build using wine/make_package with no separate configuration stage.
* Build 64-bit wine-gecko as well as 32-bit. (The 64-bit debug package
requires a 64-bit host platform to link the final DLL; a 32-bit
platform doesn't allow enough address space.)
2012-05-19 - Stephen Kitt <steve@sk2.org>
wine-gecko-1.1.0 (1.1.0+dfsg-2) unstable; urgency=low
* Mark binary packages "Multi-Arch: foreign" (closes: #673524).
* The full text of the MPL and NPL is in debian/copyright, no need to
ship it separately.

See Also

Package Description
libwings-dev_0.95.3-2_amd64.deb Window Maker's own widget set
libwings2_0.95.3-2_amd64.deb Window Maker's own widget set - runtime library
libwirble-ruby-doc_0.1.3-4_all.deb Transitional package for ruby-wirble
libwirble-ruby1.8_0.1.3-4_all.deb Transitional package for ruby-wirble
libwirble-ruby1.9.1_0.1.3-4_all.deb Transitional package for ruby-wirble
libwirble-ruby_0.1.3-4_all.deb Transitional package for ruby-wirble
libwireshark-data_1.8.2-5wheezy18_all.deb network packet dissection library -- data files
libwireshark-dev_1.8.2-5wheezy18_amd64.deb network packet dissection library -- development files
libwireshark2_1.8.2-5wheezy18_amd64.deb network packet dissection library -- shared library
libwiretap-dev_1.8.2-5wheezy18_amd64.deb network packet capture library -- development files
libwiretap2_1.8.2-5wheezy18_amd64.deb network packet capture library -- shared library
libwmf-bin_0.2.8.4-10.3+deb7u1_amd64.deb Windows metafile conversion tools
libwmf-dev_0.2.8.4-10.3+deb7u1_amd64.deb Windows metafile conversion development
libwmf-doc_0.2.8.4-10.3+deb7u1_all.deb Windows metafile documentation
libwmf0.2-7_0.2.8.4-10.3+deb7u1_amd64.deb Windows metafile conversion library
Advertisement
Advertisement