libwebauth6_4.1.1-2_amd64.deb


Advertisement

Description

libwebauth6 - Shared libraries for WebAuth authentication

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libwebauth6
Package version 4.1.1
Package release 2
Package architecture amd64
Package type deb
Installed size 157 B
Download size 71.94 KB
Official Mirror ftp.br.debian.org
WebAuth is a cookie-based web authentication system built on top of
Kerberos.  It relies on a central authentication server that handles all
user authentication for a domain and creates user authentication
credentials for any web server that needs strong authentication.
This package contains the shared library used by the WebAuth modules,
Perl bindings, and command-line utilities.  It does token encoding and
decoding and other lower-level parts of the WebAuth protocol.

Alternatives

Package Version Architecture Repository
libwebauth6_4.1.1-2_i386.deb 4.1.1 i386 Debian Main
libwebauth6 - - -

Requires

Name Value
libapr1 >= 1.2.7
libaprutil1 >= 1.2.7+dfsg
libc6 >= 2.3
libcomerr2 >= 1.01
libkrb5-3 >= 1.10+dfsg~
libremctl1 >= 3.1
libssl1.0.0 >= 1.0.0

Download

Type URL
Binary Package libwebauth6_4.1.1-2_amd64.deb
Source Package webauth

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwebauth6 deb package:
    # sudo apt-get install libwebauth6

Files

Path
/usr/lib/libwebauth.so.6
/usr/lib/libwebauth.so.6.0.0
/usr/share/doc/libwebauth6/changelog.Debian.gz
/usr/share/doc/libwebauth6/changelog.gz
/usr/share/doc/libwebauth6/copyright

Changelog

2012-11-04 - Russ Allbery <rra@debian.org>
webauth (4.1.1-2) unstable; urgency=low
* Add Breaks of libwebkdc-perl and webauth-weblogin << 4.0.0 to
libwebauth-perl and of webauth-weblogin << 4.0.0 to libwebkdc-perl.
The API of the Perl modules changed in 4.0.0.  Thanks, Dameon Wagner.
(Closes: #691878)
2012-04-25 - Russ Allbery <rra@debian.org>
webauth (4.1.1-1) unstable; urgency=low
* New upstream release (no Apache 2.4 support yet; that's next).
- Fix webauth_user_info bug in interpreting login history timestamps.
- Fix login history timestamp handling in sample confirm template.
- Suppress history and token rights in sample confirm template when
those data elements are empty.  (Closes: #664735)
- Add explicit HTML filters to all sample template variable
interpolations as an additional security measure.
- Update the mod_webkdc manual for changes in 4.1.0.
* If Apache is running and has the module loaded, restart Apache on
configure of libapache2-webauth or libapache2-webkdc.
* Remove the conditional around the postinst actions for
libapache2-webauth and libapache2-webkdc and just always configure the
package.  This is at least arguably more correct for the various abort
cases, is simpler, and shouldn't hurt.
2012-03-15 - Russ Allbery <rra@debian.org>
webauth (4.1.0-1) unstable; urgency=low
* New upstream release.
- New mod_webkdc WebKdcUserInfoTimeout option to set a network timeout
for user information service queries.  The new default is 30
seconds.
- New mod_webkdc WebKdcUserInfoIgnoreFail error to allow users to
authenticate with password and use pre-existing single sign-on
cookies even if the user information service is down.  Be aware that
this can allow bypassing a centrally-mandated multifactor
requirement.
- Use remctl_set_ccache instead of setting KRB5CCNAME when available
to avoid memory leaks on calling the user information service and to
not leak settings across threads.
- Fix WebLogin error handling when the password field is left blank.
- Fix WebLogin error handling of empty usernames.
- Drop library support for base64-encoded token attributes (which was
never used by WebAuth).
- Drop webauth_info_{build,version} library APIs.
- Document Apache/Tomcat security interaction around URL parsing in
the mod_webauth manual.  This affects any Apache security mechanism
used in conjunction with Tomcat.
* Bump libremctl-dev build dependency to >= 3.1 for consistent builds.
* Add Build-Depends-Package to the symbols file for better dependency
handling.
* Update standards version to 3.9.3 (no changes required).
2011-12-02 - Russ Allbery <rra@debian.org>
webauth (4.0.2-1) unstable; urgency=low
* New upstream release.
- Fix setting of the REMOTE_USER preference cookie in WebLogin.
- Ignore undefined cookies in WebLogin to reduce error logs.
- Document factor codes in the mod_webauth manual.
* Remove ${shlibs:Depends} from libwebauth-dev dependencies to remove a
warning.  This package won't contain compiled binaries.
2011-09-23 - Russ Allbery <rra@debian.org>
webauth (4.0.1-1) unstable; urgency=low
* New upstream release.
- Change user information service and WebKDC to WebLogin protocols for
conveying suspicious login information to use the IP address as the
CDATA and put the hostname in an attribute.
- Display suspicious logins in WebLogin, forcing a confirmation page.
- Log the return URL of authentication requests to the WebKDC.
- Reduce mod_webauth log level when retrieving credentials.
2011-09-03 - Russ Allbery <rra@debian.org>
webauth (4.0.0-2) unstable; urgency=low
* Fix a variety of uninitialized variables and memory leaks in the
libwebauth library and the test suite.  Thanks, Christoph Egger and
Aaron M. Ucko.  (Closes: #640259)
* Don't attempt to chown files in libwebkdc-perl when doing a
binary-only build.  Thanks, Aaron M. Ucko.  (Closes: #640268)

See Also

Package Description
libwebcam0-dev_0.2.2-1_amd64.deb Webcam Library - Development files
libwebcam0_0.2.2-1_amd64.deb Webcam Library
libwebinject-perl_1.74-1_all.deb Perl Module for testing web services
libwebkdc-perl_4.1.1-2_all.deb Perl libraries for WebAuth central login server
libwebkit-cil-dev_0.3-6_all.deb CLI binding for the WebKit library - development package
libwebkit-dev_1.8.1-3.4_amd64.deb Transitional package for the development files of WebKitGTK+
libwebkit1.1-cil_0.3-6_all.deb CLI binding for the WebKit library
libwebkitgtk-1.0-0_1.8.1-3.4_amd64.deb Web content engine library for GTK+
libwebkitgtk-1.0-common_1.8.1-3.4_all.deb Web content engine library for GTK+ - data files
libwebkitgtk-3.0-0_1.8.1-3.4_amd64.deb Web content engine library for GTK+
libwebkitgtk-3.0-common_1.8.1-3.4_all.deb Web content engine library for GTK+ - data files
libwebkitgtk-3.0-dev_1.8.1-3.4_amd64.deb Web content engine library for GTK+ - Development files
libwebkitgtk-dev_1.8.1-3.4_amd64.deb Web content engine library for GTK+ - Development files
libwebp-dev_0.1.3-3+nmu1_amd64.deb Lossy compression of digital photographic images
libwebp2_0.1.3-3+nmu1_amd64.deb Lossy compression of digital photographic images
Advertisement
Advertisement