libslp1_1.2.1-9+deb7u1_amd64.deb


Advertisement

Description

libslp1 - OpenSLP libraries

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libslp1
Package version 1.2.1
Package release 9+deb7u1
Package architecture amd64
Package type deb
Installed size 120 B
Download size 49.06 KB
Official Mirror ftp.br.debian.org
Service Location Protocol is an IETF standard protocol that is used to
discover/advertise services on the network. You can use SLP for anything
from locating a suitable printer on your floor to discovering what LDAP
directories are available in your organization.  This package provides
the OpenSLP run-time library package that is linked to SLP aware
applications. This library implements RFC 2614 - An API for Service
Location. Unless there is a SLP DA in the network, you must install the
slpd package to be able to advertise the services.

Alternatives

Package Version Architecture Repository
libslp1_1.2.1-9+deb7u2_amd64.deb 1.2.1 amd64 Debian Security Updates Main
libslp1_1.2.1-9+deb7u2_i386.deb 1.2.1 i386 Debian Security Updates Main
libslp1_1.2.1-9+deb7u1_i386.deb 1.2.1 i386 Debian Main
libslp1 - - -

Requires

Name Value
debconf -
debconf-2.0 -
libc6 >= 2.3

Download

Type URL
Binary Package libslp1_1.2.1-9+deb7u1_amd64.deb
Source Package openslp-dfsg

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libslp1 deb package:
    # sudo apt-get install libslp1

Files

Path
/usr/lib/libslp.so.1
/usr/lib/libslp.so.1.0.1
/usr/share/doc/libslp1/AUTHORS
/usr/share/doc/libslp1/NEWS.gz
/usr/share/doc/libslp1/README
/usr/share/doc/libslp1/THANKS
/usr/share/doc/libslp1/changelog.Debian.gz
/usr/share/doc/libslp1/changelog.gz
/usr/share/doc/libslp1/copyright

Changelog

2015-09-04 - Alessandro Ghedini <ghedo@debian.org>
openslp-dfsg (1.2.1-9+deb7u1) wheezy-security; urgency=high
* QA upload from the Security Team
* Fix double free as per CVE-2015-5177
2012-02-06 - Regis Boudin <regis@debian.org>
openslp-dfsg (1.2.1-9) unstable; urgency=low
* QA upload.
* Drop 99_auroreconf patch, use dh-autoreconf instead. Ajust build-depends
accordingly.
* Bump Standards-Version to 3.9.2.
* Drop duplicate Section and Priority fields from debian/control.
* Move to dh_install instead of dh_movefiles.
* Switch to format 3.0 (quilt).
* Call make disclean in clean target, stop finishing the cleanup manually.
* Enable building of the static lib, and ship it in libslp1-dev.
* Stop shipping the .la file.
* Bump debhelper compat version to 8. Ajust build-depends accordingly.
* Drop build-depends on debconf.
* Remove manual calls to ldconfig, debhelper adds them for us.
* Stop the debconf abuse, ship a README.Debian with libslp1 instead.
Closes: #613472.
* Drop now unneeded BSD-specific tricks from debian/rules.
2011-12-19 - Moritz Muehlenhoff <jmm@debian.org>
openslp-dfsg (1.2.1-8) unstable; urgency=low
* Orphan the package, setting maintainer to Debian QA group
* Fix CVE-2010-3609 (Closes: #623551, Closes: #621030)
2010-07-31 - Christian Perrier <bubulle@debian.org>
openslp-dfsg (1.2.1-7.8) unstable; urgency=low
* Non-maintainer upload.
* Bump debhelper compatibility to 7
* As a consequence of the former, replace deprecated "dh_clean -k"
by dh_prep
* Fix pending l10n issues. Debconf translations:
- Danish (Joe Hansen).  Closes: #581056
2010-04-06 - Petter Reinholdtsen <pere@debian.org>
openslp-dfsg (1.2.1-7.7) unstable; urgency=low
* Non-maintainer upload to solve release goal.
* Correct init.d script dependencies to make sure slpd
starts before slapd (Closes: #279297).
* Add homepage link in control file.
* Add 'set -e' to libslp1 postrm and postinst, to make sure
errors are not ignored.  Thanks, lintian, for the warning.
* Add ${misc:Depends} as dependency for all binary packages.
Thanks, lintian, for the warning.
2009-06-25 - Andreas Henriksson <andreas@fatal.se>
openslp-dfsg (1.2.1-7.6) unstable; urgency=low
* Non-maintainer upload.
* debian/libslp1.config, debian/control:
Comment out dead code to avoid needing netstat, add a warning about
needing pre-depends when/if uncommenting code, and drop depends on
net-tools (Closes: #455447, #528739, #534567)
* debian/po/de.po:
Avoid sexual ambiguity in german translation (Closes: #506107)
* debian/patches/*, debian/control, debian/rules:
Add debian/patches/01_have_net_if_arp.diff, add quilt patch system,
and dump autoreconf results into debian/patches/99_autoreconf.diff
(Closes: #394388)
* debian/po/es.po: Add updated spanish translation (Closes: #507444)
* debian/rules: make clean remove config.{guess,sub} to avoid cluttering
the package.diff.gz.
2008-11-05 - Christian Perrier <bubulle@debian.org>
openslp-dfsg (1.2.1-7.5) unstable; urgency=low
* Non-maintainer upload.
* Fix pending l10n issues. Debconf translations:
- Dutch. Closes: #501377
2008-08-19 - Christian Perrier <bubulle@debian.org>
openslp-dfsg (1.2.1-7.4) unstable; urgency=low
* Non-maintainer upload to fix some other pending l10n issues.
* Debconf translations:
- Swedish. Closes: #483435
- Japanese. Closes: #495231

See Also

Package Description
libslurm-dev_2.3.4-2+b1_amd64.deb SLURM development files
libslurm-perl_2.3.4-2+b1_amd64.deb Perl API for SLURM
libslurm23_2.3.4-2+b1_amd64.deb Runtime library files for SLURM
libslurmdb-dev_2.3.4-2+b1_amd64.deb SLURM DataBase Daemon development files
libslurmdb-perl_2.3.4-2+b1_amd64.deb Perl API for the SLURM database
libslurmdb23_2.3.4-2+b1_amd64.deb Runtime library files for the SLURM DataBase Daemon
libslv2-9_0.6.6+dfsg1-2_amd64.deb library for simple use of LV2 plugins
libslv2-dev_0.6.6+dfsg1-2_amd64.deb Development files (headers) for SLV2 library
libsm-dev_1.2.1-2_amd64.deb X11 Session Management library (development headers)
libsm-doc_1.2.1-2_all.deb documentation for the X Session Management protocol and library
libsm6_1.2.1-2_amd64.deb X11 Session Management library
libsmart-comments-perl_1.0.4-1_all.deb Perl module for comments that do more than just sit there
libsmbclient-dev_3.6.6-6+deb7u7_amd64.deb development files for libsmbclient
libsmbclient-raw-dev_4.0.0~beta2+dfsg1-3.2+deb7u2_amd64.deb SMB client library - development files
libsmbclient-raw0_4.0.0~beta2+dfsg1-3.2+deb7u2_amd64.deb SMB client library
Advertisement
Advertisement