libpkcs11-helper1_1.09-1_amd64.deb


Advertisement

Description

libpkcs11-helper1 - library that simplifies the interaction with PKCS#11

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libpkcs11-helper1
Package version: 1.09
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 188 B
Download size: 48.99 KB
Official Mirror: ftp.br.debian.org
libpkcs11-helper is a library that simplifies the interaction with PKCS#11 providers for end-user applications. libpkcs11-helper allows using multiple PKCS#11 providers at the same time, enumerating available token certificates, or selecting a certificate directly by serialized id, handling card removal and card insert events, handling card re-insert to a different slot, supporting session expiration and much more all using a simple API. libpkcs11-helper is not designed to manage card content, since object attributes are usually vendor specific, and 99% of application need to access existing objects in order to perform signature and decryption.

Alternatives

    Download

    Source package: pkcs11-helper

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpkcs11-helper1 deb package:
      # sudo apt-get install libpkcs11-helper1

    Files

    • /usr/lib/x86_64-linux-gnu/libpkcs11-helper.so.1
    • /usr/lib/x86_64-linux-gnu/libpkcs11-helper.so.1.0.0
    • /usr/share/doc/libpkcs11-helper1/AUTHORS
    • /usr/share/doc/libpkcs11-helper1/README
    • /usr/share/doc/libpkcs11-helper1/THANKS
    • /usr/share/doc/libpkcs11-helper1/changelog.Debian.gz
    • /usr/share/doc/libpkcs11-helper1/changelog.gz
    • /usr/share/doc/libpkcs11-helper1/copyright
    • /usr/share/man/man8/pkcs11-helper-1.8.gz

    Changelog

    2011-09-11 - Eric Dorland <eric@debian.org> pkcs11-helper (1.09-1) unstable; urgency=low * New upstream release. * debian/control: Standards-Version to 3.9.2. * debian/control, debian/compat, debian/libpkcs11-helper1.install, debian/libpkcs11-helper1-dev.install: Make package multiarch aware, and use debhelper level 9. * debian/copyright: Include full BSD license to quell lintian warning.

    2011-04-03 - Eric Dorland <eric@debian.org> pkcs11-helper (1.08-1) unstable; urgency=low * New upstream release. * debian/source/format: Switch to v3 quilt format. * debian/control, debian/compat, debian/rules: Switch to dh and compact level 8. * debian/control: Upgrade Standards-Version to 3.9.1.0

    2009-03-08 - Eric Dorland <eric@debian.org> pkcs11-helper (1.07-1) unstable; urgency=low * New upstream release. * debian/libpkcs11-helper1.symbols: Add symbols file. * debian/control: - Add ${misc:Depends} to libpkcs11-helper1-dev. - Bump Standards-Version to 3.8.0. - Loosen cdbs build dependency slightly

    2007-11-29 - Eric Dorland <eric@debian.org> pkcs11-helper (1.05-1) unstable; urgency=low * Take over maintenance, based on Sandro packaging. * debian/control: - Change Source package name to pkcs11-helper. - Make the priority optional. - Use binary:Version instead of Source-Version. * debian/copyright: Cleanup and remove unnecessary licenses. * debian/Makefile.am, debian/Makefile.in, debian/README.build, debian/copyright.m4: Remove.

    2007-04-23 - Sandro Wefel (testlaeufer) <sandro.wefel@informatik.uni-halle.de> libpkcs11-helper1 (1.03-0) unstable; urgency=low * New maintainer * New upstream release * renamed to libpkcs11-helper1 (lintian check) * removed *.la * size_t printf 64bit fixups (debug). * Certificate session period fixup, thank to Leo Pohl for reporting.

    2007-02-16 - Sandro Wefel (testlaeufer) <sandro.wefel@informatik.uni-halle.de> pkcs11-helper (1.02-99.0saw0) unstable; urgency=low * Non-maintainer upload. * upgrade to version 1.03 beta 1 - use --with-apidocdir for the path to the api docs

    2007-02-11 - Sandro Wefel (testlaeufer) <sandro.wefel@informatik.uni-halle.de> pkcs11-helper (1.02-1.0saw1) unstable; urgency=low * Non-maintainer upload. * api docs added to pkcs11-helper-dev * license information updated * fix dependencies

    2007-01-29 - Sandro Wefel (testlaeufer) <sandro.wefel@informatik.uni-halle.de> pkcs11-helper (1.02-1.0saw0) unstable; urgency=low * Initial release - based on version 1.02 from 2007-10-05

    Advertisement
    Advertisement