libpixman-1-dev_0.26.0-4+deb7u2_amd64.deb


Advertisement

Description

libpixman-1-dev - pixel-manipulation library for X and cairo (development files)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libpixman-1-dev
Package version 0.26.0
Package release 4+deb7u2
Package architecture amd64
Package type deb
Installed size 955 B
Download size 446.30 KB
Official Mirror ftp.br.debian.org
Development libraries, header files and documentation needed by
programs that want to compile with the Cairo/X pixman library.

Alternatives

Package Version Architecture Repository
libpixman-1-dev_0.26.0-4+deb7u2_amd64.deb 0.26.0 amd64 Debian Security Updates Main
libpixman-1-dev_0.26.0-4+deb7u2_i386.deb 0.26.0 i386 Debian Security Updates Main
libpixman-1-dev_0.26.0-4+deb7u2_i386.deb 0.26.0 i386 Debian Main
libpixman-1-dev - - -

Requires

Name Value
libpixman-1-0 = 0.26.0-4+deb7u2

Download

Type URL
Binary Package libpixman-1-dev_0.26.0-4+deb7u2_amd64.deb
Source Package pixman

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpixman-1-dev deb package:
    # sudo apt-get install libpixman-1-dev

Files

Path
/usr/include/pixman-1/pixman-version.h
/usr/include/pixman-1/pixman.h
/usr/lib/x86_64-linux-gnu/libpixman-1.a
/usr/lib/x86_64-linux-gnu/libpixman-1.so
/usr/lib/x86_64-linux-gnu/pkgconfig/pixman-1.pc
/usr/share/doc/libpixman-1-dev/changelog.Debian.gz
/usr/share/doc/libpixman-1-dev/changelog.gz
/usr/share/doc/libpixman-1-dev/copyright

Changelog

2016-03-19 - Salvatore Bonaccorso <carnil@debian.org>
pixman (0.26.0-4+deb7u2) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* CVE-2014-9766: integer overflow in create_bits function
2013-12-16 - Julien Cristau <jcristau@debian.org>
pixman (0.26.0-4+deb7u1) wheezy-security; urgency=high
* pixman_trapezoid_valid(): Fix underflow when bottom is close to MIN_INT
Addresses CVE-2013-6425
2013-02-18 - Julien Cristau <jcristau@debian.org>
pixman (0.26.0-4) sid; urgency=high
* Fix for CVE-2013-1591 (stack-based buffer overflow), cherry-picked from
0.27.4 (closes: #700308).
2012-06-27 - Cyril Brulebois <kibi@debian.org>
pixman (0.26.0-3) unstable; urgency=low
* Pass LS_CFLAGS=" " to configure to prevent -march=loongson2f from
being passed to gcc, which would break on loongson2e (see fdo bug
#51451). This fixes the test suite failures on mipsel, and should
avoid any crashes depending on user systems.
2012-06-15 - Cyril Brulebois <kibi@debian.org>
pixman (0.26.0-2) unstable; urgency=low
* Cherry-pick from upstream master branch to fix FTBFS on *i386:
- da6193b1fc “mmx: add missing _mm_empty calls”
2012-06-15 - Cyril Brulebois <kibi@debian.org>
pixman (0.26.0-1) unstable; urgency=low
* New upstream release.
2012-05-20 - Cyril Brulebois <kibi@debian.org>
pixman (0.25.6-1) experimental; urgency=low
* New upstream release candidate.
* Remove demos/parrot.jpg before building the source package to avoid
“binary file contents changed” until it's shipped in the upstream
tarball.
2012-03-09 - Cyril Brulebois <kibi@debian.org>
pixman (0.25.2-1) experimental; urgency=low
* New upstream release candidate.
* Add new symbols and bump shlibs accordingly:
- pixman_region32_clear
- pixman_region_clear
2012-02-09 - Julien Cristau <jcristau@debian.org>
pixman (0.24.4-1) unstable; urgency=low
* New upstream release
- Revert "Reject trapezoids where top (botttom) is above (below) the
edges" (closes: #656682)
2012-01-19 - Cyril Brulebois <kibi@debian.org>
pixman (0.24.2-1) unstable; urgency=low
* New upstream release:
- Stable bug fix release from the 0.24 branch.

See Also

Package Description
libpkcs11-helper1-dev_1.09-1_amd64.deb library that simplifies the interaction with PKCS#11
libpkcs11-helper1_1.09-1_amd64.deb library that simplifies the interaction with PKCS#11
libplack-middleware-crossorigin-perl_0.007-1_all.deb Plack middleware adding headers to allow CORS
libplack-middleware-deflater-perl_0.08-1_all.deb middleware to compress response body with gzip or deflate
libplack-middleware-expires-perl_0.03-1_all.deb mod_expires for plack
libplack-middleware-file-sass-perl_0.03-2_all.deb Sass and SCSS support for all Plack-based PSGI frameworks
libplack-middleware-reverseproxy-perl_0.14-1_all.deb module supporting apps to run as a reverse proxy backend
libplack-middleware-session-perl_0.14-1_all.deb Perl module for Plack middleware session management
libplack-middleware-status-perl_1.101150-1_all.deb Perl module for Plack middleware mapping URLs to status codes
libplack-perl_0.9989-1+deb7u1_all.deb interface between web servers and Perl web applications
libplack-test-externalserver-perl_0.01-1_all.deb module for running HTTP tests on external live servers
libplasma-geolocation-interface4_4.8.4-6_amd64.deb library for the Plasma geolocation
libplasma-ruby1.8_4.8.4-1_all.deb transitional package for ruby-plasma
libplasma-ruby_4.8.4-1_all.deb transitional package for ruby-plasma
libplasma3_4.8.4-4+deb7u1_amd64.deb Plasma Library for the KDE Platform
Advertisement
Advertisement