libpion-net-dev_4.0.7+dfsg-3.1_amd64.deb


Advertisement

Description

libpion-net-dev - lightweight HTTP interface library - development files

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libpion-net-dev
Package version 4.0.7+dfsg
Package release 3.1
Package architecture amd64
Package type deb
Installed size 594 B
Download size 154.50 KB
Official Mirror ftp.br.debian.org
pion-net is not intended to implement yet another web server, but to
provide HTTP(S) functionality to new or existing C++ applications. If
you're looking for a full-featured server application, check out Apache
or lighttpd. If you're working on a Boost C++ application and would just
like to use HTTP to provide a simple user interface or interact with
run-time data, then pion-net is a clean and simple solution.
Pion Network Library uses the Boost and asio libraries for multi-threading
and asynchronous I/O. This allows servers implemented using pion-net to
handle many thousands of connections simultaneously with a single physical
server.
pion-net also supports server-side SSL & TLS encryption when built with
the OpenSSL library (which the Debian package is).
This package includes the pion-net development files.

Alternatives

Package Version Architecture Repository
libpion-net-dev_4.0.7+dfsg-3.1_i386.deb 4.0.7+dfsg i386 Debian Main
libpion-net-dev - - -

Requires

Name Value
libboost-date-time1.49.0 >= 1.49.0-1
libboost-filesystem1.49.0 >= 1.49.0-1
libboost-iostreams1.49.0 >= 1.49.0-1
libboost-regex1.49.0 >= 1.49.0-1
libboost-signals1.49.0 >= 1.49.0-1
libboost-system1.49.0 >= 1.49.0-1
libboost-thread1.49.0 >= 1.49.0-1
libbz2-1.0 -
libc6 >= 2.8
libgcc1 >= 1:4.1.1
libicu48 >= 4.8-1
liblog4cpp5 -
libpion-common-4.0 -
libpion-common-dev -
libpion-net-4.0 = 4.0.7+dfsg-3.1
libssl1.0.0 >= 1.0.0
libstdc++6 >= 4.6
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package libpion-net-dev_4.0.7+dfsg-3.1_amd64.deb
Source Package pion-net

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpion-net-dev deb package:
    # sudo apt-get install libpion-net-dev

Files

Path
/usr/bin/PionHelloServer
/usr/bin/PionWebServer
/usr/include/pion/net/HTTPAuth.hpp
/usr/include/pion/net/HTTPBasicAuth.hpp
/usr/include/pion/net/HTTPCookieAuth.hpp
/usr/include/pion/net/HTTPMessage.hpp
/usr/include/pion/net/HTTPParser.hpp
/usr/include/pion/net/HTTPReader.hpp
/usr/include/pion/net/HTTPRequest.hpp
/usr/include/pion/net/HTTPRequestReader.hpp
/usr/include/pion/net/HTTPRequestWriter.hpp
/usr/include/pion/net/HTTPResponse.hpp
/usr/include/pion/net/HTTPResponseReader.hpp
/usr/include/pion/net/HTTPResponseWriter.hpp
/usr/include/pion/net/HTTPServer.hpp
/usr/include/pion/net/HTTPTypes.hpp
/usr/include/pion/net/HTTPWriter.hpp
/usr/include/pion/net/PionUser.hpp
/usr/include/pion/net/TCPConnection.hpp
/usr/include/pion/net/TCPServer.hpp
/usr/include/pion/net/TCPStream.hpp
/usr/include/pion/net/TCPTimer.hpp
/usr/include/pion/net/WebServer.hpp
/usr/include/pion/net/WebService.hpp
/usr/lib/libpion-net.so
/usr/lib/pkgconfig/pion-net.pc
/usr/share/doc/libpion-net-dev/NEWS.gz
/usr/share/doc/libpion-net-dev/README
/usr/share/doc/libpion-net-dev/TODO
/usr/share/doc/libpion-net-dev/changelog.Debian.gz
/usr/share/doc/libpion-net-dev/changelog.gz
/usr/share/doc/libpion-net-dev/copyright
/usr/share/lintian/overrides/libpion-net-dev

Changelog

2012-05-10 - Matthias Klose <doko@debian.org>
pion-net (4.0.7+dfsg-3.1) unstable; urgency=low
* Non maintainer upload
* Fix build failure with GCC 4.7. Closes: #672036.
2012-01-09 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (4.0.7+dfsg-3) unstable; urgency=low
* Remove call to deprecated io_service() (Closes: #653787)
2011-11-25 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (4.0.7+dfsg-2) unstable; urgency=low
* Add patch for aclocal.m4, thanks to Jakub Willk (Closes: #649124)
2011-09-30 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (4.0.7+dfsg-1) unstable; urgency=low
* New upstream release
2011-07-02 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (4.0.5+dfsg-1) unstable; urgency=low
* New upstream release (Closes: 632455)
* Switch from ostream for logging to log4cpp
* Update to Standards-Version 3.9.2 (no changes)
2011-03-12 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (4.0.1+dfsg-2) unstable; urgency=low
* Stop shipping debug symbols for PionWebServer and PionHelloServer to
prevent file conflicts when SONAME changes (Closes: #617933)
2011-03-10 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (4.0.1+dfsg-1) unstable; urgency=low
* New upstream release
* Rename packages:
+ libpion-net-3.0 -> libpion-net-4.0
+ libpion-common-3.0 -> libpion-common-4.0
* Update copyright years in debian/copyright
2011-01-27 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (3.0.21+dfsg-1) unstable; urgency=low
* New upstream release (Closes: #565061)
* Update to Standards-Version 3.9.1 (no changes)
* Version the -dbg packages to track the versioned runtime packages
2010-05-01 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (3.0.9+dfsg-1) unstable; urgency=low
* New upstream release
2010-04-13 - Roberto C. Sanchez <roberto@connexer.com>
pion-net (3.0.7+dfsg-1) unstable; urgency=low
* New upstream release

See Also

Package Description
libpion-net-doc_4.0.7+dfsg-3.1_all.deb lightweight HTTP interface library - documentation
libpion-net-plugins_4.0.7+dfsg-3.1_amd64.deb lightweight HTTP interface library - plugins
libpipeline-dev_1.2.1-1_amd64.deb pipeline manipulation library (development files)
libpipeline1_1.2.1-1_amd64.deb pipeline manipulation library
libpisock-dev_0.12.5-5_amd64.deb development files for communicating with a PalmOS PDA
libpisock9_0.12.5-5_amd64.deb library for communicating with a PalmOS PDA
libpisync1_0.12.5-5_amd64.deb synchronization library for PalmOS devices
libpixels-java_2.1.3+svn.42-2_all.deb manipulation and filtering of images in Java
libpixie-java_1.1.6-3_all.deb Java Vector Format Viewer Library
libpixman-1-0_0.26.0-4+deb7u2_amd64.deb pixel-manipulation library for X and cairo
libpixman-1-dev_0.26.0-4+deb7u2_amd64.deb pixel-manipulation library for X and cairo (development files)
libpkcs11-helper1-dev_1.09-1_amd64.deb library that simplifies the interaction with PKCS#11
libpkcs11-helper1_1.09-1_amd64.deb library that simplifies the interaction with PKCS#11
libplack-middleware-crossorigin-perl_0.007-1_all.deb Plack middleware adding headers to allow CORS
libplack-middleware-deflater-perl_0.08-1_all.deb middleware to compress response body with gzip or deflate
Advertisement
Advertisement