libpgocaml-ocaml_1.5-2_amd64.deb


Advertisement

Description

libpgocaml-ocaml - OCaml type-safe bindings for PostgreSQL (runtime)

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libpgocaml-ocaml
Package version: 1.5
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 407 B
Download size: 140.96 KB
Official Mirror: ftp.br.debian.org
PG'OCaml provides an interface to PostgreSQL databases for OCaml applications. It uses Camlp4 to extend the OCaml syntax, enabling one to directly embed SQL statements inside the OCaml code. Moreover, it uses the describe feature of PostgreSQL to obtain type information about the database. This allows PG'OCaml to check at compile-time if the program is indeed consistent with the database structure. This type-safe database access is the primary advantage that PG'OCaml has over other PostgreSQL bindings for OCaml. This package contains dynamically loadable plugins for PG'OCaml.

Alternatives

Provides

  • libpgocaml-ocaml-whlu5

Replaces

  • libpgocaml-ocaml-dev << 1.3-3

    Download

    Source package: pgocaml

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpgocaml-ocaml deb package:
      # sudo apt-get install libpgocaml-ocaml

    Files

    • /usr/lib/ocaml/pgocaml/META
    • /usr/lib/ocaml/pgocaml/pgocaml.cma
    • /usr/lib/ocaml/pgocaml/pgocaml.cmxs
    • /usr/share/doc/libpgocaml-ocaml/changelog.Debian.gz
    • /usr/share/doc/libpgocaml-ocaml/changelog.gz
    • /usr/share/doc/libpgocaml-ocaml/copyright

    Changelog

    2012-06-06 - Mehdi Dogguy <mehdi@debian.org> pgocaml (1.5-2) unstable; urgency=low * Use USE_BATTERIES=yes for bytecode architectures too.

    2012-06-06 - Mehdi Dogguy <mehdi@debian.org> pgocaml (1.5-1) unstable; urgency=low [ Sylvain Le Gall ] * New upstream version. * Use batteries to replace extlib (Closes: #670474) * Drop patch 05_support_hex_format, applied upstream. [ Mehdi Dogguy ] * Bump Standards-Version to 3.9.3, no changes needed. * Findlib is needed to link pgocaml provided binaries - add libfindlib-ocaml-dev to Build-Depends - add patch 05_makefile_findlib * Update packages list needed to generate the documentation - update list in libpgocaml-ocaml-dev.ocamldoc

    2012-01-04 - Mehdi Dogguy <mehdi@debian.org> pgocaml (1.4-2) unstable; urgency=low * PG'OCaml moved to forge.ocamlcore.org - update Homepage field - update debian/watch file * Bump Standards-Version to 3.9.2, no changes needed. * Add support for hex format introduced in Postgresql 9.0 (Closes: #640134) by cherry-picking a patch from upstream's subversion repository. * Turn a Conflicts into a Break to fix conflicts-with-version * Fix duplicate-short-description libpgocaml-ocaml-dev libpgocaml-ocaml * Convert to 3.0 (quilt) source format

    2010-02-22 - Guillaume Yziquel <guillaume.yziquel@citycable.ch> pgocaml (1.4-1) unstable; urgency=low * New upstream release. * Switched patch system from dpatch to quilt. * Adapted patches to new upstream. * Removed the .cmx and .cmi files of the profiler from the package. * Bumped Standards Version to 3.8.4.

    2009-11-16 - Mehdi Dogguy <mehdi@debian.org> pgocaml (1.3-3) unstable; urgency=low * Do not install META and pgocaml.cma in libpgocaml-ocaml-dev (Closes: #556419). * Make libpgocaml-ocaml Conflicts/Replaces with libpgocaml-ocaml-dev to be sure that the conflicting files get removed before installing libpgocaml-ocaml.

    2009-11-13 - Mehdi Dogguy <mehdi@debian.org> pgocaml (1.3-2) unstable; urgency=low [ Sylvain Le Gall ] * Update to dh-ocaml 0.9 * Use CDBS rules (Closes: #549151) * Use dh_ocamldoc * Use depends/provides * Non-ocamlopt archs excluded - yziquel (Closes: #541682) [ Mehdi Dogguy ] * Add myself to uploaders

    2009-06-07 - Guillaume Yziquel <guillaume.yziquel@citycable.ch> pgocaml (1.3-1) unstable; urgency=low * Initial release (Closes: #516629)

    Advertisement
    Advertisement