libpetsc3.2_3.2.dfsg-6_amd64.deb


Advertisement

Description

libpetsc3.2 - Shared libraries for version 3.2 of PETSc

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libpetsc3.2
Package version: 3.2.dfsg
Package release: 6
Package architecture: amd64
Package type: deb
Installed size: 7.09 KB
Download size: 2.65 MB
Official Mirror: ftp.br.debian.org
PETSc is the "Portable Extensible Toolkit for Scientific Computation", a suite of data structures and routines for the scalable (parallel) solution of scientific applications modeled by partial differential equations. It employs the MPI standard for all message-passing communication. Several sample scientific applications, as well as various papers and talks, demonstrate the features of the PETSc libraries.

Alternatives

    Download

    Source package: petsc

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpetsc3.2 deb package:
      # sudo apt-get install libpetsc3.2

    Files

    • /usr/lib/libpetsc.so.3.2
    • /usr/share/doc/libpetsc3.2/changelog.Debian.gz
    • /usr/share/doc/libpetsc3.2/copyright
    • /usr/share/lintian/overrides/libpetsc3.2

    Changelog

    2012-11-11 - S├ębastien Villemot <sebastien@debian.org> petsc (3.2.dfsg-6) unstable; urgency=low * Team upload. * Fix PETSC_CHECKS m4 macro so that it also detects static petsc library - petsc.m4: add -lhdf5 and -lstdc++ to PETSC_EXTERNAL_LIBS - d/rules: add g++ to petsc-compilers Thanks to Anton Gladky for a first version of the patch. (Closes: #691307)

    2012-01-26 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.2.dfsg-5) unstable; urgency=low * Rebuild with newest version of HDF5, and force >= 1.8.8.

    2012-01-26 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.2.dfsg-4) unstable; urgency=low * Added lam4-dev to Build-Conflicts (closes: #656189). * Added alpha and lpia to architecture list (closes: #655940). * Added CHOLMOD support (closes: #642439). * Test building with HDF5 on all arches.

    2012-01-16 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.2.dfsg-3) unstable; urgency=low * Reinstated s390x arch since an external error prevents it from building (no s390x support in PVM -> no ScaLAPACK). * Changed libscotch-dev to libptscotch-dev in libpetsc3.2-dev Build-Depends. * Added cmake to Build-Conflicts because it causes setting of PETSC_BUILD_USING_CMAKE and breaks SLEPc build.

    2012-01-11 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.2.dfsg-2) unstable; urgency=low * Fixed MUMPS support to work with PTScotch (thanks: Satish Balay). * Removed doc link to non-free PDF file. * Added mpich2 case to debian/rules (closes: #652307). * Restrict architectures to exclude armel because of an unknown python bug (closes: #651453), kfreebsd-* because of a FORTRAN test problem, and s390x because of dependency issues (missing architecture in PVM).

    2011-12-30 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.2.dfsg-1) unstable; urgency=low * New upstream (closes: #652101). * Removed bin/win32fe/win32fe.exe and win32feutils.dll, docs/developers.pdf, docs/manual.pdf, src/tops/twopager.pdf and the share and xcode directories from upstream due to lack of source. * Forward-ported patches, splitting ld.patch into hypre.patch and nocleanup.patch. * Changed arch-dependent packages to "any" -- let's test all arches. * Reinstated patch/unpatch in build-arch, build-indep and clean targets. * Re-added quilt to Build-Depends, lintian complains otherwise. * PETSc dropped support for Scotch, need to disable MUMPS as well for now (but keeping both in dependencies). * Requires newer SuiteSparse than version 3.4.0 in Debian, kludged it to compile properly but runtime behavior is unpredictable at best. * Lintian overrides for false positives on copyright and petsc-dev. * Using MPI selection from mpi-default-dev.

    2011-11-15 - Didier Raboud <odyx@debian.org> petsc (3.1.dfsg-11.1) unstable; urgency=low * Non-maintainer upload. * Don't mix source format 3.0 (quilt) and manual usage of quilt: - Drop manual quilt calls from debian/rules; - Drop superfluous quilt Build-Depends. Closes: #643488

    2011-04-07 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.1.dfsg-11) unstable; urgency=low [ Adam C. Powell, IV ] * Use HDF5 only on openmpi architectures (closes: #602660, #605294). * Bump Standards-Version, no changes needed. * Update to upstream patch level 8 (closes: #621609). * Clean target update. * Fix stamps to prevent double-building. [ Matthias Klose ] * Patch PETSc build system to link properly to hypre libs, and change BLACS lib order in rules, to make binutils-gold work (closes: #608902). * Explicitly set PETSC_BUILD_GNU_SYSTEM in rules.

    2010-11-23 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.1.dfsg-10) unstable; urgency=low * Fixed mpi-default-dev implementation selection (closes: #604549).

    2010-11-22 - "Adam C. Powell, IV" <hazelsct@debian.org> petsc (3.1.dfsg-9) unstable; urgency=low * Choose MPI implementation based on mpi-default-dev (closes: #604549).

    Advertisement
    Advertisement