libperl4caml-ocaml_0.9.5-4+b4_amd64.deb


Advertisement

Description

libperl4caml-ocaml - Use Perl code in OCaml programs, runtime library

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libperl4caml-ocaml
Package version: 0.9.5
Package release: 4+b4
Package architecture: amd64
Package type: deb
Installed size: 44 B
Download size: 16.91 KB
Official Mirror: ftp.br.debian.org
perl4caml allows you to use Perl code within Objective CAML (OCaml), thus neatly side-stepping the old problem with OCaml which was that it lacked a comprehensive set of libraries. Well now you can use any part of CPAN in your OCaml code. This package provides the runtime dynamic library necessary to use this in bytecode OCaml programs.

Alternatives

Provides

  • libperl4caml-ocaml-11om0

    Download

    Source package: perl4caml

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libperl4caml-ocaml deb package:
      # sudo apt-get install libperl4caml-ocaml

    Files

    • /usr/lib/ocaml/stublibs/dllperl4caml.so
    • /usr/share/doc/libperl4caml-ocaml/changelog.Debian.gz
    • /usr/share/doc/libperl4caml-ocaml/copyright

    Changelog

    2010-06-04 - Stéphane Glondu <glondu@debian.org> perl4caml (0.9.5-4) unstable; urgency=low * Add 0003-Fix-for-Perl-5.12-SVt_RV-missing.patch (Closes: #578800) * Switch source package format to 3.0 (quilt) * debian/control: - libperl4caml-ocaml-dev: add ocaml-findlib to Recommends - bump Standards-Version to 3.8.4 (no changes)

    2009-10-09 - Stéphane Glondu <glondu@debian.org> perl4caml (0.9.5-3) unstable; urgency=low * Switch patches to quilt * Switch packaging to dh-ocaml 0.9 and simplify debian/rules * Drop dependency to libnet-google-perl (Closes: #550329) - add Disable-libnet-google-perl-wrappers.patch * debian/control: - update my e-mail address and remove DMUA - remove dependencies to perl; keep only libperl-dev - move to section ocaml - update Standards-Version to 3.8.3

    2009-02-24 - Stephane Glondu <steph@glondu.net> perl4caml (0.9.5-2) unstable; urgency=low * Fix 10_Makefile.dpatch to handle tests on bytecode-only architectures (fixes FTBFS) * Bump ocaml build-dep to (>= 3.11) to entail proper dep-waits

    2009-02-23 - Stephane Glondu <steph@glondu.net> perl4caml (0.9.5-1) unstable; urgency=low * Acknowledge NMU * New Upstream Version - remove 11_Makefile.config.dpatch (not relevant anymore) * Switch packaging to git, add Vcs-* fields * Set Maintainer to d-o-m, add Mike and me to Uploaders, add DMUA * Major changes in the packaging: - switch to debhelper 7 and use ocamlinit.mk - add ${misc:Depends} dependencies (as complained by Lintian) - add Homepage field, README.source and watch files - switch copyright to machine-parsable format - switch doc-base section to Programming/OCaml - merge two doc-base Format sections to Get rid of Lintian error * Bump Standards-Version to 3.8.0

    2008-05-09 - Marc 'HE' Brockschmidt <he@debian.org> perl4caml (0.9.3-8.1) unstable; urgency=low * Non-maintainer upload to help perl5.10 transition along * debian/patches/11_Makefile.config.dpatch: Added patch from Niko Tyni to let perl4caml build against other perl version than 5.8.X. (Closes: #466770)

    2007-09-07 - Mike Furr <mfurr@debian.org> perl4caml (0.9.3-8) unstable; urgency=low * Rebuild for 3.10.0

    2007-01-01 - Mike Furr <mfurr@debian.org> perl4caml (0.9.3-7) unstable; urgency=medium * Fixed bad dependency in debian/rules which erroneously did not generate the *.files and therefore produced an empty package. (Closes: 405136)

    2006-09-13 - Mike Furr <mfurr@debian.org> perl4caml (0.9.3-6) unstable; urgency=low * Corrected "libdata-calc-perl" -> "libdate-calc-perl" and moved it from a Suggests to a Depends. Thanks to Jean-Baptiste Rouquier for noticing. * Upgraded policy to 3.7.2 (no changes needed) * Package is now svn-buildpackage compatible * Dropped control.in per new OCaml policy

    2006-01-07 - Mike Furr <mfurr@debian.org> perl4caml (0.9.3-5) unstable; urgency=low * Remove hard-coded ABI strings * Rebuild with 3.09.1

    2005-11-08 - Mike Furr <mfurr@debian.org> perl4caml (0.9.3-4) unstable; urgency=low * Rebuild with 3.09

    Advertisement
    Advertisement