libpcscada0.7.1_0.7.1-4_amd64.deb


Advertisement

Description

libpcscada0.7.1 - Ada bindings to PC/SC middleware

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libpcscada0.7.1
Package version: 0.7.1
Package release: 4
Package architecture: amd64
Package type: deb
Installed size: 440 B
Download size: 127.68 KB
Official Mirror: ftp.br.debian.org
PCSC/Ada provides thin- and thick-bindings to PC/SC-middleware for the Ada programming language. The library allows applications written in Ada to communicate with smart cards using the SCard API.

Alternatives

    Download

    Source package: pcscada

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpcscada0.7.1 deb package:
      # sudo apt-get install libpcscada0.7.1

    Files

    • /usr/lib/libpcscada.so.0.7.1
    • /usr/share/doc/libpcscada0.7.1/changelog.Debian.gz
    • /usr/share/doc/libpcscada0.7.1/changelog.gz
    • /usr/share/doc/libpcscada0.7.1/copyright
    • /usr/share/lintian/overrides/libpcscada0.7.1

    Changelog

    2013-01-30 - Reto Buerki <reet@codelabs.ch> pcscada (0.7.1-4) unstable; urgency=low * Update copyright information * Break and replace libpcscada1-dev (Closes: #699194)

    2012-03-28 - Reto Buerki <reet@codelabs.ch> pcscada (0.7.1-3) unstable; urgency=low * Also depend on gnat package (Closes: #664722) * Add project specific git-buildpackage configuration * Add patch to build dynamic/static libs in separate dirs. This avoids position-independent code (PIC) in the static library. * libpcscada2-dev: Build and install static library * Update to Standards-Version 3.9.3 (no changes)

    2012-02-20 - Reto Buerki <reet@codelabs.ch> pcscada (0.7.1-2) unstable; urgency=low * Drop unneeded debian/README.source * Update comment header in GNAT project file * Drop incorrect libpcscada.0 symlink (Closes: #657417)

    2011-11-26 - Reto Buerki <reet@codelabs.ch> pcscada (0.7.1-1) unstable; urgency=low * Merge upstream version 0.7.1 * Migrate to gnat-4.6 * Build-Depend on libahven3-dev (Closes: #647796) * Switch to 3.0 (quilt) source package format * Drop disable-stack-check.patch * Rename libpcscada0.6 package to libpcscada0.7.1 * Bump dev package aliversion to 2 * Unapply patches from source * Update to debhelper 8 * Switch to minimal debian/rules syntax * Update to Standards-Version 3.9.2 (no changes) * Enable DM upload * Update copyright time period * Update project URLs (now hosted at codelabs.ch) * Add asciidoc and source-highlight to Build-Depends * libpcscada2-dev: Build and install html doc

    2010-02-03 - Reto Buerki <reet@codelabs.ch> pcscada (0.6-2) unstable; urgency=low * Add aliversion to dev package. * Declare conflict with libpcscada-dev. * Declare conflict with libpcscada0 (Closes: #566096). * Update to Standards-Version 3.8.4 (no changes). * Disable stack overflow checking (Closes: #520434).

    2010-01-18 - Reto Buerki <reet@codelabs.ch> pcscada (0.6-1) unstable; urgency=low * Update to Standards-Version 3.8.3 (no changes). * Update debian/rules. * Migrate to gnat-4.4 (Closes: #555100). * Update libahven Build-Depends (Closes: #560603). * Merge upstream version 0.6. * Change soname from 0 to 0.6. * Fix debhelper-but-no-misc-depends lintian warning.

    2009-06-17 - Reto Buerki <reet@codelabs.ch> pcscada (0.5-4) unstable; urgency=low * Fix wrong-section-according-to-package-name warning. - pcscada-dbg: devel -> debug. * Remove unused pcscada-dbg lintian override. * Remove "section" field from libpcscada0 package. * libpcscada-dev: Add dependency to gnat-4.3 (Closes: #533157). * Don't dh_compress .ads and .adb files. * Update to Standards-Version 3.8.2 (no changes).

    2009-01-22 - Reto Buerki <reet@codelabs.ch> pcscada (0.5-3) unstable; urgency=low * Link libpcscada (dynamic) against pcsclite. * Remove manually added libpcsclite1 shlibs:Depends.

    2009-01-21 - Reto Buerki <reet@codelabs.ch> pcscada (0.5-2) unstable; urgency=low * Fix typo in manually added libpcsclite1 shlibs:Depends.

    2008-12-16 - Reto Buerki <reet@codelabs.ch> pcscada (0.5-1) unstable; urgency=low * Initial release (Closes: #508846).

    Advertisement
    Advertisement