libpangomm-1.4-1_2.28.4-1_amd64.deb


Advertisement

Description

libpangomm-1.4-1 - C++ Wrapper for pango (shared libraries)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libpangomm-1.4-1
Package version 2.28.4
Package release 1
Package architecture amd64
Package type deb
Installed size 228 B
Download size 66.93 KB
Official Mirror ftp.br.debian.org
Pangomm is a C++ wrapper for the pango library. Originally part of
gtkmm, pangomm provides convenient C++ interfaces for handling both
the layout and internationalization of text in graphical applications.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libpangomm-1.4-1_2.28.4-1_i386.deb 2.28.4 i386 Debian Main
libpangomm-1.4-1 - - -

Requires

Name Value
libc6 >= 2.2.5
libcairo2 >= 1.2.4
libcairomm-1.0-1 >= 1.6.4
libgcc1 >= 1:4.1.1
libglib2.0-0 >= 2.24.0
libglibmm-2.4-1c2a >= 2.28.0
libpango1.0-0 >= 1.23.0
libsigc++-2.0-0c2a >= 2.0.2
libstdc++6 >= 4.1.1

Conflicts

Name Value
libgtkmm-2.4-1c2a << 1:2.13

Replaces

Name Value
libgtkmm-2.4-1c2a << 1:2.13

Download

Type URL
Binary Package libpangomm-1.4-1_2.28.4-1_amd64.deb
Source Package pangomm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpangomm-1.4-1 deb package:
    # sudo apt-get install libpangomm-1.4-1

Files

Path
/usr/lib/libpangomm-1.4.so.1
/usr/lib/libpangomm-1.4.so.1.0.30
/usr/share/doc/libpangomm-1.4-1/AUTHORS
/usr/share/doc/libpangomm-1.4-1/NEWS.gz
/usr/share/doc/libpangomm-1.4-1/README
/usr/share/doc/libpangomm-1.4-1/changelog.Debian.gz
/usr/share/doc/libpangomm-1.4-1/changelog.gz
/usr/share/doc/libpangomm-1.4-1/copyright

Changelog

2011-11-17 - Michael Biebl <biebl@debian.org>
pangomm (2.28.4-1) unstable; urgency=low
* New upstream release.
* debian/watch:
- Track .xz tarballs.
* Bump debhelper compatibility level to 8.
* debian/control.in:
- Bump Standards-Version to 3.9.2. No further changes.
- Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* Stop installing libtool .la files.
2011-09-28 - Martin Pitt <mpitt@debian.org>
pangomm (2.28.3-1) unstable; urgency=low
[ Deng Xiyue ]
* debian/watch:
+ Fix RegEx to work again.
[ Martin Pitt ]
* New upstream release:
- Ship convert_pangomm.m4 in tarballs.
- Don't use obsolete autotools macros.
2011-04-17 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
pangomm (2.28.2-1) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/control.in,
debian/rules:
+ Remove the chrpath hack, it's been fixed in libtool.
[ Krzysztof Klimonda ]
* New upstream release. 
[ Deng Xiyue ]
* New upstream bugfix release.
+ debian/control.in:
+ Add mm-common >= 0.9.5 as builddep as per configure.ac.
+ debian/rules:
+ Update SHVER to 2.27.1 due to new API.
* Convert to source format 3.0 (quilt)
+ debian/rules:
+ Drop simple-patchsys.mk.
+ debian/watch:
+ Track *.tar.bz2 instead of *.tar.gz
* debian/control.in:
+ Update Standards-Version to 3.9.1.
2010-05-04 - Sebastian Dröge <slomo@debian.org>
pangomm (2.26.2-1) unstable; urgency=low
* New upstream bugfix release.
2010-04-16 - Sebastian Dröge <slomo@debian.org>
pangomm (2.26.1-1) unstable; urgency=low
* New upstream bugfix release.
* debian/control.in:
+ Update Standards-Version to 3.8.4.
2009-10-04 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
pangomm (2.26.0-1) unstable; urgency=low
* New upstream release.
+ Bump shlibs version to 2.26.0.
+ Bump build-depends libglibmm-2.4-dev >= 2.22.1-2 for gmmprocdir support,
but leave depends unchanged, as new glibmm version is only needed for
building documentation.
+ Adjust doc path according to new location in new release.
* Update Standard-Version to 3.8.3.  No changes needed.
2009-07-14 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
pangomm (2.24.0-3) unstable; urgency=high
* Update debian/copyright to conform to latest DEP 5.
+ Point to versioned license files.
* Add missing ',' in control file to fix FTBFS against new dpkg.  Thanks
KiBi for the report and patch.  (Closes: #536785)
+ RC bug, hence urgency high.
* Drop strict bdep on libglib2.0-dev and libcairo2-dev added to help
experimental buildd, which are not needed now.
* Update Standard-Version to 3.8.2.
2009-04-03 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
pangomm (2.24.0-2) unstable; urgency=low
* Upload to unstable.
+ Drop check-dist.mk.
+ Track unstable branch in Vcs-*.
* Change -dbg package to section debug.
2009-03-29 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
pangomm (2.24.0-1) experimental; urgency=low
* New upstream release.
+ Update SHVER to 2.24.0 for new API addition.
+ Update build-depends on libpango1.0-dev to >= 1.23.0 as per configure.in.
* Don't define GNOME_MODULE, the default matches.
* Upload to experimental, add check-dist.mk accordingly.
* Update Standard-Version to 3.8.1.  No change needed.
2009-02-19 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
pangomm (2.14.1-2) unstable; urgency=low
* Upload to unstable.  Drop check-dist.mk.
* Use viewsvn instead of wsvn in debian/control*.
* Remove comments in debian/watch.

See Also

Package Description
libpangomm-1.4-dev_2.28.4-1_amd64.deb C++ Wrapper for pango (development files)
libpangomm-1.4-doc_2.28.4-1_all.deb C++ Wrapper for pango (documentation)
libpano13-2_2.9.18+dfsg-5_amd64.deb panorama tools library
libpano13-bin_2.9.18+dfsg-5_amd64.deb panorama tools utilities
libpano13-dev_2.9.18+dfsg-5_amd64.deb panorama tools library development files
libpantomime1.2-dev_1.2.0~pre3+snap20071004+dfsg-4+b1_amd64.deb GNUstep framework for mail handling (development files)
libpantomime1.2_1.2.0~pre3+snap20071004+dfsg-4+b1_amd64.deb GNUstep framework for mail handling (runtime library)
libpaper-dev_1.1.24+nmu2_amd64.deb library for handling paper characteristics (development files)
libpaper-utils_1.1.24+nmu2_amd64.deb library for handling paper characteristics (utilities)
libpaper1_1.1.24+nmu2_amd64.deb library for handling paper characteristics
libpaperclips-java-doc_1.0.4-1_all.deb Documentation for libpaperclips-java
libpaperclips-java_1.0.4-1_all.deb Simplified Java Printing Support for SWT
libpaps-dev_0.6.8-6_amd64.deb Development files for libpaps
libpaps0_0.6.8-6_amd64.deb UTF-8 to PostScript converter library using Pango
libpaq-dev_1.0.4-3+b1_amd64.deb library for parsing and querying RDF data (header files)
Advertisement
Advertisement