libpam-shield_0.9.2-3.3_amd64.deb


Advertisement

Description

libpam-shield - locks out remote attackers trying password guessing

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libpam-shield
Package version: 0.9.2
Package release: 3.3
Package architecture: amd64
Package type: deb
Installed size: 130 B
Download size: 23.44 KB
Official Mirror: ftp.br.debian.org
In certain situations it is not possible to use host based authentication and here pam-shield comes in use. It locks out brute-force password crackers using null-route or iptables rules.

Alternatives

    Download

    Source package: pam-shield

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpam-shield deb package:
      # sudo apt-get install libpam-shield

    Files

    • /etc/cron.daily/pam_shield.cron
    • /etc/pam.d/libpam-shield
    • /etc/security/shield.conf
    • /lib/security/pam_shield.so
    • /usr/sbin/shield-purge
    • /usr/sbin/shield-trigger
    • /usr/sbin/shield-trigger-iptables
    • /usr/share/doc/libpam-shield/INSTALL
    • /usr/share/doc/libpam-shield/README
    • /usr/share/doc/libpam-shield/README.Debian
    • /usr/share/doc/libpam-shield/changelog.Debian.gz
    • /usr/share/doc/libpam-shield/copyright
    • /usr/share/man/man8/shield-purge.8.gz
    • /usr/share/man/man8/shield-trigger-iptables.8.gz
    • /usr/share/man/man8/shield-trigger.8.gz

    Changelog

    2012-02-26 - Jonathan Niehof <jtniehof@gmail.com> pam-shield (0.9.2-3.3) unstable; urgency=high * Non-maintainer upload. * Fix CVE-2012-2350: block IPs when allow_missing_dns is no (Closes: #658830).

    2009-10-09 - Barry deFreese <bdefreese@debian.org> pam-shield (0.9.2-3.2) unstable; urgency=low * Non-maintainer upload. * Update build-deps and patch to use automake-1.11. (Closes: #543024). * Install INSTALL file. (Closes: #517050). * Add install-sh to clean target in rules. * Remove paths from commands in maintainer scripts. * Add README.source for quilt patch system. * Add Homepage field. * Bump Standards Version to 3.8.3. (No changes needed).

    2008-05-01 - Filippo Giunchedi <filippo@debian.org> pam-shield (0.9.2-3.1) unstable; urgency=low * Non-maintainer upload. * Check for executable in cron file (Closes: #461574)

    2007-12-19 - Mateusz Kaduk <mateusz@kaduk.net> pam-shield (0.9.2-3) unstable; urgency=low * Checked against new debian-policy and changed to 3.7.3 * Fixed differnce between documentation and installed files (Closes: #456759) * Fixed suboptimal description wording (Closes: #456814) * Fixed typo in the short description (Closes: #457043)

    2007-12-05 - Mateusz Kaduk <mateusz@kaduk.net> pam-shield (0.9.2-2) unstable; urgency=low * Added checking rhost for null pointer, as it caused segmentation fault.

    2007-12-02 - Mateusz Kaduk <mateusz@kaduk.net> pam-shield (0.9.2-1) unstable; urgency=low * Initial release

    Advertisement
    Advertisement