libpam-ldap_184-8.6_amd64.deb


Advertisement

Description

libpam-ldap - Pluggable Authentication Module for LDAP

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libpam-ldap
Package version 184
Package release 8.6
Package architecture amd64
Package type deb
Installed size 205 B
Download size 91.95 KB
Official Mirror ftp.br.debian.org
This package provides an interface between an LDAP server and the PAM
user authentication system. Using it along with libnss-ldapd or libnss-ldap
allows LDAP to entirely replace other lookup methods (such as NIS or
flat-file) for system account tables.

Alternatives

Package Version Architecture Repository
libpam-ldap_184-8.6_i386.deb 184 i386 Debian Main
libpam-ldap - - -

Requires

Name Value
debconf >= 0.5
debconf-2.0 -
libc6 >= 2.4
libldap-2.4-2 >= 2.4.7
libpam-runtime >= 1.0.1-6
libpam0g >= 1.1.3-2

Download

Type URL
Binary Package libpam-ldap_184-8.6_amd64.deb
Source Package libpam-ldap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-ldap deb package:
    # sudo apt-get install libpam-ldap

Files

Path
/lib/x86_64-linux-gnu/security/pam_ldap.so
/usr/share/doc/libpam-ldap/AUTHORS
/usr/share/doc/libpam-ldap/LDAP-Permissions.txt
/usr/share/doc/libpam-ldap/README.Debian
/usr/share/doc/libpam-ldap/README.gz
/usr/share/doc/libpam-ldap/changelog.Debian.gz
/usr/share/doc/libpam-ldap/changelog.gz
/usr/share/doc/libpam-ldap/copyright
/usr/share/doc/libpam-ldap/ldapns.schema
/usr/share/doc/libpam-ldap/examples/chfn
/usr/share/doc/libpam-ldap/examples/chsh
/usr/share/doc/libpam-ldap/examples/pam.conf
/usr/share/doc/libpam-ldap/examples/pam.d/chfn
/usr/share/doc/libpam-ldap/examples/pam.d/chsh
/usr/share/doc/libpam-ldap/examples/pam.d/ftp
/usr/share/doc/libpam-ldap/examples/pam.d/gdm
/usr/share/doc/libpam-ldap/examples/pam.d/halt
/usr/share/doc/libpam-ldap/examples/pam.d/imap
/usr/share/doc/libpam-ldap/examples/pam.d/kde
/usr/share/doc/libpam-ldap/examples/pam.d/linuxconf
/usr/share/doc/libpam-ldap/examples/pam.d/linuxconf-pair
/usr/share/doc/libpam-ldap/examples/pam.d/login
/usr/share/doc/libpam-ldap/examples/pam.d/mcserv
/usr/share/doc/libpam-ldap/examples/pam.d/other
/usr/share/doc/libpam-ldap/examples/pam.d/passwd
/usr/share/doc/libpam-ldap/examples/pam.d/pop
/usr/share/doc/libpam-ldap/examples/pam.d/poweroff
/usr/share/doc/libpam-ldap/examples/pam.d/ppp
/usr/share/doc/libpam-ldap/examples/pam.d/reboot
/usr/share/doc/libpam-ldap/examples/pam.d/rexec
/usr/share/doc/libpam-ldap/examples/pam.d/rlogin
/usr/share/doc/libpam-ldap/examples/pam.d/rsh
/usr/share/doc/libpam-ldap/examples/pam.d/samba
/usr/share/doc/libpam-ldap/examples/pam.d/shutdown
/usr/share/doc/libpam-ldap/examples/pam.d/ssh
/usr/share/doc/libpam-ldap/examples/pam.d/su
/usr/share/doc/libpam-ldap/examples/pam.d/vlock
/usr/share/doc/libpam-ldap/examples/pam.d/xdm
/usr/share/doc/libpam-ldap/examples/pam.d/xlock
/usr/share/doc/libpam-ldap/examples/pam.d/xscreensaver
/usr/share/doc/libpam-ldap/examples/pam.d/xserver
/usr/share/libpam-ldap/ldap.conf
/usr/share/man/man5/pam_ldap.conf.5.gz
/usr/share/pam-configs/ldap

Changelog

2012-03-27 - Christian Perrier <bubulle@debian.org>
libpam-ldap (184-8.6) unstable; urgency=low
* Non-maintainer upload.
* Support multiarch. Closes: #653681, #654163
* Fix pending l10n issues. Debconf translations:
- Dutch; (Jeroen Schot).  Closes: #655320
- Polish (Michał Kułach).  Closes: #664650
2010-07-17 - Christian Perrier <bubulle@debian.org>
libpam-ldap (184-8.5) unstable; urgency=low
* Non-maintainer upload.
* Fix pending l10n issues. Debconf translations:
- Spanish (Francisco Javier Cuadrado).  Closes: #579510
2010-05-23 - gregor herrmann <gregoa@debian.org>
libpam-ldap (184-8.4) unstable; urgency=low
* Non-maintainer upload.
* Fix "needs versioned dependency on libpam-runtime", thanks to Arthur de
Jong for providing the info in the bug report (closes: #578638).
2010-01-06 - Christian Perrier <bubulle@debian.org>
libpam-ldap (184-8.3) unstable; urgency=low
* Non-maintainer upload.
* Fix pending l10n issues. Debconf translations:
- Vietnamese (Clytie Siddall).  Closes: #548000
- Galician (Marce Villarino).  Closes: #537422
- Norwegian Bokmål (Bjørn Steensrud).  Closes: #563361
- Simplified Chinese (Ji ZhengYu).  Closes: #563615
2009-12-04 - Steve Langasek <vorlon@debian.org>
libpam-ldap (184-8.2) unstable; urgency=low
* Non-maintainer upload.
* Restore the libsasl2-dev build-dependency, the libnss-ldapd suggests,
and the libpam-runtime dependency, casualties of the previous NMU.
2009-09-13 - Christian Perrier <bubulle@debian.org>
libpam-ldap (184-8.1) unstable; urgency=low
* Non-maintainer upload.
* Add quilt to build dependencies (fix FTBFS)
* Add decent copyright and licence information in debian/copyright
* Add ${misc:Depends} to the binary package dependencies to cover
dependencies induced by debhelper utilities. Drop debconf
dependencies that are covered by this
* Versioned build dependency on debhelper >5
* Debconf templates and debian/control reviewed by the debian-l10n-
english team as part of the Smith review project. Closes: #531557
* [Debconf translation updates]
- Brazilian Portuguese. Closes: #532470
- Czech. Closes: #532476
- Finnish. Closes: #532506
- Japanese. Closes: #532621
- Slovak. Closes: #532962
- Portuguese. Closes: #533243
- Traditional Chinese. Closes: #533732
- Italian. Closes: #533756
- Russian. Closes: #533877
- Swedish. Closes: #534245
- German. Closes: #534336
- French. Closes: #534390
- Basque. Closes: #534438
* Danish (Frank Damgaard).  Closes: #546300
2009-03-04 - Richard A Nelson (Rick) <cowboy@debian.org>
libpam-ldap (184-8) unstable; urgency=low
* debian/libpam-ldap.{pam-auth-update,install,postinst,prerm},
debian/rules: enable pam_ldap by default using the new
pam-auth-update support.
* debian/control: depend on libpam-runtime (>= 1.0.1-6) for the
above.
* The above two should fix the upgrade issue Closes: #517971
* Pickup the lost pieces of the 184-4.2 NMU cleanups
Mea culpa -- and thanks to Christian Perrier !
* Set libnss-ldapd as the preferred alternative (over libnss-ldap)
2009-03-01 - Richard A Nelson (Rick) <cowboy@debian.org>
libpam-ldap (184-7) unstable; urgency=low
* Build-Depend on quilt
2009-02-28 - Richard A Nelson (Rick) <cowboy@debian.org>
libpam-ldap (184-6) unstable; urgency=low
* Use quilt for patches
* Updated vi.po (thanks Clytie Siddall)     Closes: #513360
2007-07-03 - Richard A Nelson (Rick) <cowboy@debian.org>
libpam-ldap (184-5) unstable; urgency=low
* build-depend on libsasl2-dev              Closes: #351176
so that sasl mechs can be used (was used on my builds, but not buildd)

See Also

Package Description
libpam-ldapd_0.8.10-4_amd64.deb PAM module for using LDAP as an authentication service
libpam-mklocaluser_0.8~deb7u1_all.deb Configure PAM to create a local user if it do not exist already
libpam-modules-bin_1.1.3-7.1_amd64.deb Pluggable Authentication Modules for PAM - helper binaries
libpam-modules_1.1.3-7.1_amd64.deb Pluggable Authentication Modules for PAM
libpam-mount_2.14~git+d1d6f871-1_amd64.deb PAM module that can mount volumes for a user session
libpam-mysql_0.7~RC1-4+b3_amd64.deb PAM module allowing authentication from a MySQL server
libpam-ncp_2.2.6-9_amd64.deb PAM module allowing authentication from a NetWare server
libpam-nufw_2.4.3-2.2_amd64.deb The authenticating firewall [PAM module]
libpam-oath_1.12.4-1_amd64.deb OATH Toolkit libpam_oath PAM module
libpam-ocaml-dev_1.1-4+b3_amd64.deb OCaml bindings for the PAM library (development files)
libpam-ocaml_1.1-4+b3_amd64.deb OCaml bindings for the PAM library (runtime)
libpam-openafs-kaserver_1.6.1-3+deb7u5_amd64.deb AFS distributed filesystem kaserver PAM module
libpam-otpw_1.3-2_amd64.deb Use OTPW for PAM authentication
libpam-p11_0.1.5-2_amd64.deb PAM module for using PKCS#11 smart cards
libpam-passwdqc_1.2.0-1_amd64.deb PAM module for password strength policy enforcement
Advertisement
Advertisement