libosgi-core-java_4.3.0-3_all.deb


Advertisement

Description

libosgi-core-java - Java OSGi API - Core module

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libosgi-core-java
Package version: 4.3.0
Package release: 3
Package architecture: all
Package type: deb
Installed size: 209 B
Download size: 178.06 KB
Official Mirror: ftp.br.debian.org
OSGi, for Open Services Gateway initiative framework, is a module system and service platform for the Java programming language. This package contains OSGi Core for Release 4. Two main provided packages are org.osgi.service and org.osgi.framework.

Alternatives

    Download

    Source package: osgi-core

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libosgi-core-java deb package:
      # sudo apt-get install libosgi-core-java

    Files

    • /usr/share/doc/libosgi-core-java/changelog.Debian.gz
    • /usr/share/doc/libosgi-core-java/copyright
    • /usr/share/java/osgi.core-4.3.0.jar
    • /usr/share/java/osgi.core.jar
    • /usr/share/maven-repo/org/osgi/org.osgi.core/4.3.0/org.osgi.core-4.3.0.jar
    • /usr/share/maven-repo/org/osgi/org.osgi.core/4.3.0/org.osgi.core-4.3.0.pom
    • /usr/share/maven-repo/org/osgi/org.osgi.core/debian/org.osgi.core-debian.jar
    • /usr/share/maven-repo/org/osgi/org.osgi.core/debian/org.osgi.core-debian.pom

    Changelog

    2012-06-24 - Niels Thykier <niels@thykier.net> osgi-core (4.3.0-3) unstable; urgency=low * Team upload. * Rebuild with javahelper/0.43 to ensure backwards compatible byte code is generated. (Closes: #678758)

    2012-06-18 - Niels Thykier <niels@thykier.net> osgi-core (4.3.0-2) unstable; urgency=low * Team upload. * Pass encoding flags to javac and javadoc to fix FTBFS with openjdk-7. (LP: #888992) * Add missing versioned dependency on maven-repo-helper. * Remove duplicated field in d/copyright.

    2011-11-09 - Damien Raude-Morvan <drazzib@debian.org> osgi-core (4.3.0-1) unstable; urgency=low * New upstream release. * d/watch: Use new bndtools project on github.

    2011-10-02 - Damien Raude-Morvan <drazzib@debian.org> osgi-core (4.2.0-1) unstable; urgency=low * Initial release. (Closes: #643981).

    Advertisement
    Advertisement