liborlite-mirror-perl_1.23-2_all.deb


Advertisement

Description

liborlite-mirror-perl - ORLite extension to use remote SQLite databases

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: liborlite-mirror-perl
Package version: 1.23
Package release: 2
Package architecture: all
Package type: deb
Installed size: 84 B
Download size: 14.23 KB
Official Mirror: ftp.br.debian.org
ORLite::Mirror provides a simple mechanism for opening a read-only SQLite database from anywhere on the web. In a method analogous to using ORLite to work with a local read-only SQLite database, you can use ORLite::Mirror to open a SQLite database at an arbitrary URI. If the remote file has a "gz" or "bz2" extension, then ORLite::Mirror will decompress the file before opening.

Alternatives

    Download

    Source package: liborlite-mirror-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liborlite-mirror-perl deb package:
      # sudo apt-get install liborlite-mirror-perl

    Files

    • /usr/share/doc/liborlite-mirror-perl/changelog.Debian.gz
    • /usr/share/doc/liborlite-mirror-perl/changelog.gz
    • /usr/share/doc/liborlite-mirror-perl/copyright
    • /usr/share/doc/liborlite-mirror-perl/examples/cpants.pl
    • /usr/share/man/man3/ORLite::Mirror.3pm.gz
    • /usr/share/perl5/ORLite/Mirror.pm
    • /usr/share/perl5/auto/share/module/ORLite-Mirror-Test/stub.db

    Changelog

    2012-03-22 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.23-2) unstable; urgency=low * Set temporary $HOME for test suite. (Closes: #665246) * debian/copyright: update to Copyright-Format 1.0. * Bump Standards-Version to 3.9.3 (no changes).

    2012-02-07 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.23-1) unstable; urgency=low * New upstream release. * Update years of packaging and upstream copyright.

    2011-08-28 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.22-1) unstable; urgency=low [ Fabrizio Regalli ] * New upstream release 1.21 * Bump to 3.9.2 Standard-Version. * Switch d/compat to 8. * Build-Depends: switch to debhelper (>= 8). * Add myself to Uploaders and Copyright. * Removed AUTOMATED_TESTING=1 in d/rules * Removed libtest-cpan-meta-perl, libtest-minimumversion-perl, libtest-pod-perl from dependencies [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL. [ gregor herrmann ] * New upstream release 1.22. * Update years of packaging copyright. * Remove some unneeded versions from build/runtime dependencies.

    2010-04-28 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.20-2) unstable; urgency=low * debian/rules: explicitly set HOME for test suite to avoid a FTBFS due to a missing or un-writable directory (closes: #579292). * Convert to source format 3.0 (quilt).

    2010-01-29 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.20-1) unstable; urgency=low * New upstream release: + Switching to use array => 1 by default + Upgrading ORLite dependency to 1.37 to get array support + Changed the "no transactions" test from begin to commit (closes: #566502) * Set Standards-Version to 3.8.4 (no changes). * debian/copyright: update some years of copyright.

    2010-01-03 - Jonathan Yu <jawnsy@cpan.org> liborlite-mirror-perl (1.18-1) unstable; urgency=low * New upstream release * Requires ORLite 1.30 per upstream * Pod::Simple 3.07 is satisfied by Perl 5.10.1 * Refresh copyright to new DEP5 format

    2009-09-27 - Jonathan Yu <jawnsy@cpan.org> liborlite-mirror-perl (1.17-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release + Now requires ORLite 1.28 for prune [ Ryan Niebur ] * Update jawnsy's email address

    2009-08-21 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.16-3) unstable; urgency=low * Add "perl (>= 5.10.1)" also to libio-compress-zlib-perl (cf. #542691).

    2009-08-21 - gregor herrmann <gregoa@debian.org> liborlite-mirror-perl (1.16-2) unstable; urgency=low [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ gregor herrmann ] * Update (build) dependency to "perl (>= 5.10.1) | libio-compress-bzip2-perl (>= 2.008)" as a preparation for the Perl 5.10.1 transition (closes: #542704). * Add /me to Uploaders. * Set Standards-Version to 3.8.3 (no further changes). * Bump versioned debhelper build dependency for the override_* feature.

    2009-07-16 - Jonathan Yu <frequency@cpan.org> liborlite-mirror-perl (1.16-1) unstable; urgency=low * Initial Release (Closes: #537287)

    Advertisement
    Advertisement