libopus-dev_0.9.14+20120615-1+nmu1_amd64.deb


Advertisement

Description

libopus-dev - Opus codec library development files

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libopus-dev
Package version: 0.9.14+20120615
Package release: 1+nmu1
Package architecture: amd64
Package type: deb
Installed size: 612 B
Download size: 195.21 KB
Official Mirror: ftp.br.debian.org
The Opus codec is designed for interactive speech and audio transmission over the Internet. It is designed by the IETF Codec Working Group and incorporates technology from Skype's SILK codec and Xiph.Org's CELT codec. It is intended to suit a wide range of interactive audio applications, including Voice over IP, videoconferencing, in-game chat, and even remote live music performances. It can scale from low bit-rate narrowband speech to very high quality stereo music. The current features are: Bit-rates from 6 kb/s 510 kb/s Sampling rates from 8 to 48 kHz Frame sizes from 2.5 ms to 60 ms Support for both constant bit-rate (CBR) and variable bit-rate (VBR) Audio bandwidth from narrowband to full-band Support for speech and music Support for mono and stereo Support for up to 255 channels (multistream frames) Dynamically adjustable bitrate, audio bandwidth, and frame size Good loss robustness and packet loss concealment (PLC) Floating point and fixed-point implementation This package provides the Opus library headers and development files.

Alternatives

    Download

    Source package: opus

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libopus-dev deb package:
      # sudo apt-get install libopus-dev

    Files

    • /usr/include/opus/opus.h
    • /usr/include/opus/opus_defines.h
    • /usr/include/opus/opus_multistream.h
    • /usr/include/opus/opus_types.h
    • /usr/lib/libopus.a
    • /usr/lib/libopus.so
    • /usr/lib/pkgconfig/opus.pc
    • /usr/share/doc/libopus-dev/changelog.Debian.gz
    • /usr/share/doc/libopus-dev/copyright

    Changelog

    2013-04-12 - Michael Gilbert <mgilbert@debian.org> opus (0.9.14+20120615-1+nmu1) unstable; urgency=medium * Non-maintainer upload. * Fix cve-2013-0899: integer overflow in src/opus_decoder.c (closes: #704870).

    2012-06-15 - Ron Lee <ron@debian.org> opus (0.9.14+20120615-1) unstable; urgency=low * Add extern "C" protection to opus_multistream.h. * Warn about unused returns and NULL arguments for functions where that would always be an error in the calling code. * Clearly mark fixed point builds in the internal versioning. * Better documentation. * Suggest opus-tools.

    2012-05-23 - Ron Lee <ron@debian.org> opus (0.9.14+20120521-2) unstable; urgency=low * Build the fixed point version for arm(el) and mips(el). Fixes the unit test timeout seen on the mips buildd. * Add some extra 'hardening' flags to those upstream uses already.

    2012-05-21 - Ron Lee <ron@debian.org> opus (0.9.14+20120521-1) unstable; urgency=low * Opus draft-14 release testing. * This one's for Sid. Closes: #610980

    2011-11-02 - Ron Lee <ron@debian.org> opus (0.9.8-1) experimental; urgency=low * Opus draft-10 release testing.

    2011-04-30 - Ron Lee <ron@debian.org> opus (0.9.4-1) experimental; urgency=low * Initial (re)release as Opus. Closes: #610980

    2010-01-20 - Ron Lee <ron@debian.org> celt (0.7.1-1) unstable; urgency=low * The "correlation does not imply causation" release. To celebrate the first release of celt that is actually compatible with a a previously distributed version, we've renamed the library! * libcelt is now libcelt0. The intent from upstream being to make it clear that one of the above was an accident, and unlikely to be repeated soon. On the bright side, this means we should be getting proper soname bumps from now on when the code ABI changes. The bitstream format still remains entirely fluid though, applications which communicate with a peer _must_ check that the formats are compatible at runtime. It may, and indeed is very likely to, continue changing with every release. * By some small miracle, this should be an entirely painless transition though. The new package doesn't conflict with the existing one, and all rdeps except mumble will switch to the new package with a binNMU, but not be broken in the meantime. They use the .pc file provided, and have been build tested. The mumble package is waiting on this one before it can work properly anyway, so a fix for that is just waiting for this to get through the NEW queue first now. * The new PLC is reported to be working Really Well.

    2009-11-07 - Ron Lee <ron@debian.org> celt (0.7.0-1) unstable; urgency=low * Another day, another bitstream format. Closes: #554559 * Drop the IETF drafts for now. Better to leave worrying about the paperwork for this until we have some documents that aren't actually supposed to expire in less than the life of a distro release. Closes: #538990 for now. If you really need to reference them, then you should probably be tracking git anyhow, as they should be changing while the codec evolves too.

    2009-07-26 - Ron Lee <ron@debian.org> celt (0.6.1-1) unstable; urgency=low * New upstream release. Closes: #511163

    2008-07-26 - Ron Lee <ron@debian.org> celt (0.4.0-1) unstable; urgency=low * New upstream release.

    Advertisement
    Advertisement