libopenvrml-dev_0.18.9-5+deb7u1_amd64.deb


Advertisement

Description

libopenvrml-dev - developer libraries for openvrml

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: libopenvrml-dev
Package version: 0.18.9
Package release: 5+deb7u1
Package architecture: amd64
Package type: deb
Installed size: 374.59 KB
Download size: 65.77 MB
Official Mirror: ftp.br.debian.org
VRML (Virtual Reality Modeling Language) is a scene description language that describes the geometry and behavior of a 3D scene or "world". It is used for 3D multimedia and shared virtual worlds on the Internet. OpenVRML gives you a library with a set of function written for VRML rendering with java and javascript support. This package contains the header files and static library needed to compile applications that use libopenvrml.

Alternatives

Conflicts

  • libopenvrml0-dev
  • libopenvrml3-dev
  • libopenvrml4-dev
  • libopenvrml5-dev

    Download

    Source package: openvrml

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libopenvrml-dev deb package:
      # sudo apt-get install libopenvrml-dev

    Files

    • /usr/include/openvrml/openvrml-common.h
    • /usr/include/openvrml/openvrml-config.h
    • /usr/include/openvrml/openvrml-gl-common.h
    • /usr/include/openvrml/openvrml-gl-config.h
    • /usr/include/openvrml/openvrml/bad_url.h
    • /usr/include/openvrml/openvrml/basetypes.h
    • /usr/include/openvrml/openvrml/bounding_volume.h
    • /usr/include/openvrml/openvrml/browser.h
    • /usr/include/openvrml/openvrml/event.h
    • /usr/include/openvrml/openvrml/exposedfield.h
    • /usr/include/openvrml/openvrml/field_value.h
    • /usr/include/openvrml/openvrml/frustum.h
    • /usr/include/openvrml/openvrml/node.h
    • /usr/include/openvrml/openvrml/node_impl_util.h
    • /usr/include/openvrml/openvrml/rendering_context.h
    • /usr/include/openvrml/openvrml/scene.h
    • /usr/include/openvrml/openvrml/scope.h
    • /usr/include/openvrml/openvrml/script.h
    • /usr/include/openvrml/openvrml/viewer.h
    • /usr/include/openvrml/openvrml/vrml97_grammar.h
    • /usr/include/openvrml/openvrml/x3d_vrml_grammar.h
    • /usr/include/openvrml/openvrml/gl/viewer.h
    • /usr/lib/x86_64-linux-gnu/libopenvrml-gl.a
    • /usr/lib/x86_64-linux-gnu/libopenvrml-gl.so
    • /usr/lib/x86_64-linux-gnu/libopenvrml.a
    • /usr/lib/x86_64-linux-gnu/libopenvrml.so
    • /usr/lib/x86_64-linux-gnu/openvrml/node/vrml97.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-cad-geometry.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-core.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-dis.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-environmental-effects.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-event-utilities.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-geometry2d.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-geospatial.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-grouping.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-h-anim.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-interpolation.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-key-device-sensor.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-networking.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-nurbs.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-rendering.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-shape.a
    • /usr/lib/x86_64-linux-gnu/openvrml/node/x3d-texturing.a
    • /usr/lib/x86_64-linux-gnu/openvrml/script/java.a
    • /usr/lib/x86_64-linux-gnu/pkgconfig/openvrml-gl.pc
    • /usr/lib/x86_64-linux-gnu/pkgconfig/openvrml.pc
    • /usr/share/doc/libopenvrml-dev/changelog.Debian.gz
    • /usr/share/doc/libopenvrml-dev/changelog.gz
    • /usr/share/doc/libopenvrml-dev/copyright

    Changelog

    2013-08-17 - Ansgar Burchardt <ansgar@debian.org> openvrml (0.18.9-5+deb7u1) wheezy; urgency=low * Disable JavaScript support as newer versions of Mozilla's JS engine are not supported by openvrml. (Closes: #710616)

    2012-11-28 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.9-5) unstable; urgency=low * Move example directory in libopenvrml9 to libopenvrml-doc. * Add "Multi-Arch: same" to libopenvrml9 and libopenvrml-dev. * Change Architecture to linux-any.

    2012-09-26 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.9-4) unstable; urgency=low * Add mips to Architecture field for libopenvrml9.

    2012-08-11 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.9-3) unstable; urgency=low * Update debian/rules. Change dh_clean to dh_prep in install target. (Closes: #683482) Thanks to Niels Thykier. * Revert changing from libpng12-dev to libpng-dev in Build-Depends and Depends.

    2012-07-27 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.9-2) unstable; urgency=low * Update debian/control. - Remove multiarch support for libopenvrml9 as it contains Makefile with arch-specific contents (Closes: #674489). - Change from libpng12-dev to libpng-dev in Build-Depends and Depends. (Closes: #662456) * Update debian/rules. - Remove -k option from dh_clean. - Enable hardening. * Fix FTBFS with -Werror=format-security option. Add patches/050_fix_ftbfs_with_format_security.diff.

    2012-05-06 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.9-1) unstable; urgency=low * New upstream release. * Bump Standards Version to 3.9.3. * Add build-arch and build-indep targets. * Add support Multi-Arch. * Fix FTBFS with boost 1.48. (Closes: #652790) - Thanks to Tobias Frost <tobi@coldtobi.de>. * Move usr/bin/openvrml-player to usr/bin/openvrml-player package.

    2011-11-21 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.8-5) unstable; urgency=low * Fix FTBFS with xulrunner 8.0. (Closes: #649411) Add patches/050_xulrunner_8.0.patch. * Add version of libmozjs-dev (>= 8.0).

    2011-06-13 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.8-4) unstable; urgency=low * Replace from libjpeg62-dev to libjpeg-dev (Closes: #629973).

    2011-05-29 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.8-3) unstable; urgency=low * Update debian/control. Drop mips, hurd-i386, kfreebsd-amd64 and kfreebsd-i386 from Architecture. These architecture have some problem in other packages.

    2011-05-27 - Nobuhiro Iwamatsu <iwamatsu@debian.org> openvrml (0.18.8-2) unstable; urgency=low * Update debian/control. Replace doxygen and texlive-* build dependencies with doxygen-latex. (Closes: #616274). * Update debian/libopenvrml-dev.install. Remove *.la file from libopenvrml-dev package (Closes: #622549).

    Advertisement
    Advertisement