libmysqlclient18_5.5.47-0+deb7u1_amd64.deb


Advertisement

Description

libmysqlclient18 - MySQL database client library

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name libmysqlclient18
Package version 5.5.47
Package release 0+deb7u1
Package architecture amd64
Package type deb
Installed size 3.40 KB
Download size 669.73 KB
Official Mirror ftp.br.debian.org
MySQL is a fast, stable and true multi-user, multi-threaded SQL database
server. SQL (Structured Query Language) is the most popular database query
language in the world. The main goals of MySQL are speed, robustness and
ease of use.
This package includes the client library.

Alternatives

Package Version Architecture Repository
libmysqlclient18_5.6.39-1~dotdeb+7.1_amd64.deb 5.6.39 amd64 Dotdeb
libmysqlclient18_5.6.39-1~dotdeb+7.1_i386.deb 5.6.39 i386 Dotdeb
libmysqlclient18_5.6.38-1~dotdeb+7.1_amd64.deb 5.6.38 amd64 Dotdeb
libmysqlclient18_5.6.38-1~dotdeb+7.1_i386.deb 5.6.38 i386 Dotdeb
libmysqlclient18_5.6.37-1~dotdeb+7.1_amd64.deb 5.6.37 amd64 Dotdeb
libmysqlclient18_5.6.37-1~dotdeb+7.1_i386.deb 5.6.37 i386 Dotdeb
libmysqlclient18_5.6.36-1~dotdeb+7.1_amd64.deb 5.6.36 amd64 Dotdeb
libmysqlclient18_5.6.36-1~dotdeb+7.1_i386.deb 5.6.36 i386 Dotdeb
libmysqlclient18_5.6.35-1~dotdeb+7.1_amd64.deb 5.6.35 amd64 Dotdeb
libmysqlclient18_5.6.35-1~dotdeb+7.1_i386.deb 5.6.35 i386 Dotdeb
libmysqlclient18_5.6.34-1~dotdeb+7.2_amd64.deb 5.6.34 amd64 Dotdeb
libmysqlclient18_5.6.34-1~dotdeb+7.2_i386.deb 5.6.34 i386 Dotdeb
libmysqlclient18_5.6.33-1~dotdeb+7.1_amd64.deb 5.6.33 amd64 Dotdeb
libmysqlclient18_5.6.33-1~dotdeb+7.1_i386.deb 5.6.33 i386 Dotdeb
libmysqlclient18_5.6.32-1~dotdeb+7.1_amd64.deb 5.6.32 amd64 Dotdeb
libmysqlclient18_5.6.32-1~dotdeb+7.1_i386.deb 5.6.32 i386 Dotdeb
libmysqlclient18_5.6.29-1~dotdeb+7.1_amd64.deb 5.6.29 amd64 Dotdeb
libmysqlclient18_5.6.29-1~dotdeb+7.1_i386.deb 5.6.29 i386 Dotdeb
libmysqlclient18_5.6.25-1~dotdeb+7.1_amd64.deb 5.6.25 amd64 Dotdeb
libmysqlclient18_5.6.25-1~dotdeb+7.1_i386.deb 5.6.25 i386 Dotdeb
libmysqlclient18_5.5.60-0+deb7u1_amd64.deb 5.5.60 amd64 Debian Security Updates Main
libmysqlclient18_5.5.60-0+deb7u1_i386.deb 5.5.60 i386 Debian Security Updates Main
libmysqlclient18_5.5.47-0+deb7u1_i386.deb 5.5.47 i386 Debian Main
libmysqlclient18 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.1.1
multiarch-support -
mysql-common >= 5.5.47-0+deb7u1
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package libmysqlclient18_5.5.47-0+deb7u1_amd64.deb
Source Package mysql-5.5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmysqlclient18 deb package:
    # sudo apt-get install libmysqlclient18

Files

Path
/usr/lib/x86_64-linux-gnu/libmysqlclient.so.18
/usr/lib/x86_64-linux-gnu/libmysqlclient.so.18.0.0
/usr/lib/x86_64-linux-gnu/libmysqlclient_r.so.18
/usr/lib/x86_64-linux-gnu/libmysqlclient_r.so.18.0.0
/usr/share/doc/libmysqlclient18/NEWS.Debian.gz
/usr/share/doc/libmysqlclient18/changelog.Debian.gz
/usr/share/doc/libmysqlclient18/changelog.gz
/usr/share/doc/libmysqlclient18/copyright

Changelog

2016-01-13 - Lars Tangvald <lars.tangvald@oracle.com>
mysql-5.5 (5.5.47-0+deb7u1) wheezy-security; urgency=high
* Imported Upstream version 5.5.47 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html
- CVE-2016-0546 CVE-2016-0505 CVE-2016-0596 CVE-2016-0597 CVE-2016-0616
CVE-2016-0598 CVE-2016-0600 CVE-2016-0606 CVE-2016-0608 CVE-2016-0609
(Closes: #811428)
* fix-test-suite-failure-caused-by-arbitrary-date-in-the-future-patch is no
longer needed, as bug is fixed in new Upstream version
2015-10-23 - Salvatore Bonaccorso <carnil@debian.org>
mysql-5.5 (5.5.46-0+deb7u1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 5.5.46 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpuoct2015-2367953.html
- CVE-2015-4792 CVE-2015-4802 CVE-2015-4815 CVE-2015-4816 CVE-2015-4819
CVE-2015-4826 CVE-2015-4830 CVE-2015-4836 CVE-2015-4858 CVE-2015-4861
CVE-2015-4870 CVE-2015-4879 CVE-2015-4913
(Closes: #802564)
* Add fix-test-suite-failure-caused-by-arbitrary-date-in-the-future.patch.
Fix test suite failure caused by arbitrary date in the future.
Thanks to Marc Deslauriers <marc.deslauriers@canonical.com>
* Add revert-to-_sync_lock_test_and_set.patch.
Fixes FTBFS on arm and powerpw by reverting to __sync_lock_test_and_set.
The gcc version in wheezy is too old to have __atomic_*.
Thanks to Marc Deslauriers <marc.deslauriers@canonical.com> for the patch.
2015-07-15 - Salvatore Bonaccorso <carnil@debian.org>
mysql-5.5 (5.5.44-0+deb7u1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 5.5.44 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html
- CVE-2015-4752 CVE-2015-4737 CVE-2015-2648 CVE-2015-2643 CVE-2015-2620
CVE-2015-2582
(Closes: #792445)
2015-04-17 - Salvatore Bonaccorso <carnil@debian.org>
mysql-5.5 (5.5.43-0+deb7u1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 5.5.43 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html
- CVE-2015-0433 CVE-2015-0441 CVE-2015-0499 CVE-2015-0501 CVE-2015-0505
CVE-2015-2568 CVE-2015-2571 CVE-2015-2573
(Closes: #782645)
* Update copyright years for upstream files
2015-01-21 - Salvatore Bonaccorso <carnil@debian.org>
mysql-5.5 (5.5.41-0+wheezy1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 5.5.41 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpujan2015-1972971.html
- CVE-2014-6568, CVE-2015-0374, CVE-2015-0381, CVE-2015-0382,
CVE-2015-0411, CVE-2015-0432
(Closes: #775881)
2014-10-18 - Salvatore Bonaccorso <carnil@debian.org>
mysql-5.5 (5.5.40-0+wheezy1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 5.5.40 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpuoct2014-1972960.html
- CVE-2012-5615, CVE-2014-4274, CVE-2014-4287, CVE-2014-6463,
CVE-2014-6464, CVE-2014-6469, CVE-2014-6478, CVE-2014-6484,
CVE-2014-6491, CVE-2014-6494, CVE-2014-6495, CVE-2014-6496,
CVE-2014-6500, CVE-2014-6505, CVE-2014-6507, CVE-2014-6520,
CVE-2014-6530, CVE-2014-6551, CVE-2014-6555, CVE-2014-6559
(Closes: #765663)
2014-07-19 - Salvatore Bonaccorso <carnil@debian.org>
mysql-5.5 (5.5.38-0+wheezy1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 5.5.38 to fix security issues:
- http://www.oracle.com/technetwork/topics/security/cpujul2014-1972956.html
- CVE-2014-2494
- CVE-2014-4207
- CVE-2014-4258
- CVE-2014-4260
(Closes: #754941)
* Update copyright years for upstream files

See Also

Package Description
libmysqlcppconn-dev_1.1.0-4+b1_amd64.deb MySQL Connector for C++ (development files)
libmysqlcppconn5_1.1.0-4+b1_amd64.deb MySQL Connector for C++ (library)
libmysqld-dev_5.5.47-0+deb7u1_amd64.deb MySQL embedded database development files
libmysqld-pic_5.5.47-0+deb7u1_amd64.deb PIC version of MySQL embedded server development files
libmythes-1.2-0_1.2.2-1_amd64.deb simple thesaurus library
libmythes-dev_1.2.2-1_amd64.deb simple thesaurus library (development files)
libnabrit-dev_0.4.1-1_amd64.deb LV2 bridging helper library (development files)
libnabrit3_0.4.1-1_amd64.deb LV2 bridging helper library
libnacl-dev_20110221-4_amd64.deb High-speed software library for network communication
libnacore-dev_0.4.0-3_amd64.deb NASPRO core library (development files)
libnacore-doc_0.4.0-3_all.deb NASPRO core library (documentation)
libnacore5_0.4.0-3_amd64.deb NASPRO core library
libnaga-java_2.1-3_all.deb Simplified Java NIO asynchronous sockets
libnagios-object-perl_0.21.16-1_all.deb module to parse and represent Nagios configuration as objects
libnagios-plugin-perl_0.36-1_all.deb family of perl modules to streamline writing Nagios
Advertisement
Advertisement