libfglrx-amdxvba1_15.9-4~deb8u1~bpo70+1_amd64.deb


Advertisement

Description

libfglrx-amdxvba1 - AMD XvBA (X-Video Bitstream Acceleration) backend for VA API

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Backports Nonfree amd64
Package filename libfglrx-amdxvba1_15.9-4~deb8u1~bpo70+1_amd64.deb
Package name libfglrx-amdxvba1
Package version 15.9
Package release 4~deb8u1~bpo70+1
Package architecture amd64
Package type deb
Homepage -
License -
Maintainer -
Download size 5.18 MB
Installed size 12.72 KB
X-Video Bitstream Acceleration (XvBA), designed by AMD for its (ATI) Radeon GPU
and Fusion APU, is an arbitrary extension of the X video extension (Xv) for the
X Window System on Linux operating-systems. XvBA API allows video programs to
offload portions of the video decoding process to the GPU video-hardware.
Currently, the portions designed to be offloaded by XvBA onto the GPU are
motion compensation (MC) and inverse discrete cosine transform (IDCT), and
variable-length decoding (VLD) for MPEG-2, MPEG-4 AVC (H.264) and VC-1 encoded
video.
This package contains the runtime libraries and VA API backend.

Alternatives

Package Version Architecture Repository
libfglrx-amdxvba1_15.9-4~deb8u1~bpo70+1_i386.deb 15.9 i386 Debian Backports Nonfree
libfglrx-amdxvba1_12-6+point-3_amd64.deb 12 amd64 Debian Nonfree
libfglrx-amdxvba1_12-6+point-3_i386.deb 12 i386 Debian Nonfree
libfglrx-amdxvba1 - - -

Requires

Name Value
libc6 >= 2.3.2
libgl1 -
libgl1-fglrx-glx = 1:15.9-4~deb8u1~bpo70+1
libgl1-mesa-glx -
multiarch-support -

Provides

Name Value
libxvbaw1 -
va-driver -
xvba-va-driver -

Conflicts

Name Value
libxvbaw1 -

Replaces

Name Value
libxvbaw1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libfglrx-amdxvba1_15.9-4~deb8u1~bpo70+1_amd64.deb
Source Package fglrx-driver

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-backports non-free
  2. Update the package index:
    # sudo apt-get update
  3. Install libfglrx-amdxvba1 deb package:
    # sudo apt-get install libfglrx-amdxvba1

Files

Path
/usr/lib/AMDXvBAx64.cap
/usr/lib/x86_64-linux-gnu/libAMDXvBA.so.1
/usr/lib/x86_64-linux-gnu/libAMDXvBA.so.1.0
/usr/lib/x86_64-linux-gnu/libXvBAW.so.1
/usr/lib/x86_64-linux-gnu/libXvBAW.so.1.0
/usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so
/usr/lib/x86_64-linux-gnu/dri/xvba_drv_video.so
/usr/share/bug/libfglrx-amdxvba1/control
/usr/share/bug/libfglrx-amdxvba1/script
/usr/share/doc/libfglrx-amdxvba1/changelog.Debian.gz
/usr/share/doc/libfglrx-amdxvba1/copyright
/usr/share/lintian/overrides/libfglrx-amdxvba1

Changelog

2016-01-30 - Andreas Beckmann <anbe@debian.org>
fglrx-driver (1:15.9-4~deb8u1~bpo70+1) wheezy-backports; urgency=medium
* Rebuild for wheezy-backports.
* Replace 'dpkg-parsechangelog --show-field=Date' with a sed expression.
2016-01-16 - Andreas Beckmann <anbe@debian.org>
fglrx-driver (1:15.9-4~deb8u1) jessie; urgency=medium
* Rebuild for jessie.
* Reinstate the libxvbaw-dev package.
* Remove Conflicts/Replaces: xvba-va-driver.
* Revert patches 12-4.3.0-build and 13-4.4.0-build, the patched kernel
module does not work on Linux 4.3. (See #809638 for details.)
2016-01-14 - Patrick Matthäi <pmatthaei@debian.org>
fglrx-driver (1:15.9-4) unstable; urgency=medium
* Fix spelling error in long description.
* Add patch 06-spelling-error-manpage to fix a spelling error in atieventsd
manpage.
* Add patch 13-4.4.0-build from Ubuntu to fix a FTBFS with Linux 4.4.
2015-12-31 - Patrick Matthäi <pmatthaei@debian.org>
fglrx-driver (1:15.9-3) unstable; urgency=high
[ Andreas Beckmann ]
* d/rules: Move tar option --no-recursion before the list of files.
* fglrx-atieventsd.init: Fix 'stop' and implement 'status', thanks to
D. Leggett.  (Closes: #803494)
* Reinstate breaks between fglrx-driver and libgl1-fglrx-glx.
* Update lintian overrides.
[ Patrick Matthäi ]
* Add Ubuntu patch 12-4.3.0-build.
Closes: #807965
2015-10-04 - Andreas Beckmann <anbe@debian.org>
fglrx-driver (1:15.9-2) unstable; urgency=medium
* amd-opencl-icd: Ship libamdocl12cl{32,64}.so.  (Closes: #793488)
2015-09-27 - Patrick Matthäi <pmatthaei@debian.org>
fglrx-driver (1:15.9-1) unstable; urgency=medium
[ Andreas Beckmann ]
* New upstream release 15.9 (2015-09-15) (15.201.1151).  (Closes: #799439)
* Fixes CVE-2015-7724.  (Closes: #803517)
* Use signature from 15.7.
* Update watch file.
* Update lintian overrides.
[ Patrick Matthäi ]
* Refresh patch 04-3.17rc6-no_hotplug.
* Rewrite patch 05-4.0.0-build.
* Drop merged patch 06-4.0.0-build-2.
* Rewrite patch 07-4.1.0-build.
* Rewrite patch 08-4.2.0-build.
* Rewrite patch 09-4.2.0-build.fpregs_active.
* Rewrite patch 10-4.2.0-build.copy_xregs_to_kernel.
* Rewrite patch 11-4.1.0-gpl-only.
2015-09-01 - Patrick Matthäi <pmatthaei@debian.org>
fglrx-driver (1:15.7-3) unstable; urgency=high
* Add patch 11-4.1.0-gpl-only to finaly allow fglrx to build with Linux 4.1.
2015-09-01 - Patrick Matthäi <pmatthaei@debian.org>
fglrx-driver (1:15.7-2) unstable; urgency=high
[ Andreas Beckmann ]
* Drop libxvbaw-dev package.
* fglrx-driver, fglrx-kernel-*: Report in the package description the latest
tested Linux version that can build the kernel module.
[ Patrick Matthäi ]
* Add Ubuntu patch 06-4.0.0-build-2.
* Add Ubuntu patch 07-4.1.0-build to fix a FTBFS with Linux 4.1.
Closes: #795222, #795230
* Add Ubuntu patches 08-4.2.0-build, 09-4.2.0-build.fpregs_active and
10-4.2.0-build.copy_xregs_to_kernel so fglrx may work with Linux 4.2.
2015-07-09 - Patrick Matthäi <pmatthaei@debian.org>
fglrx-driver (1:15.7-1) unstable; urgency=medium
[ Andreas Beckmann ]
* libfglrx-amdxvba1: Can be used as a va-driver backend.
- Provides: va-driver since libXvBAW.so.1 now contains the required
entrypoints.
- Conflicts/Provides/Replaces: xvba-va-driver since that wrapper is no
longer needed.
- Ship dri/{xvba,fglrx}_drv_video.so symlinks.
* Update list of supported models.
* Create /usr/src/fglrx.tar.bz2 reproducibly.
[ Patrick Matthäi ]
* New upstream release 15.7 (2015-07-0?) (15.20.1046).
Closes: #791905
- Refresh hunky patch 04-3.17rc6-no_hotplug.
- Rewrite patch 05-4.0.0-build.
- Xorg 1.17 is supported now.
Closes: #784903
* Fixes CVE-2015-7723.
* Use signature from upstream package.
* Remove breaks between fglrx-driver and libgl1-fglrx-glx, since it confuses
dpkg.

See Also

Package Description
libfglrx-legacy-amdxvba1_8.97.100.7-3~bpo70+1_amd64.deb AMD XvBA (X-Video Bitstream Acceleration) runtime libraries (legacy)
libfglrx-legacy_8.97.100.7-3~bpo70+1_amd64.deb non-free ATI/AMD RadeonHD display driver (runtime libraries) (legacy)
libfglrx_15.9-4~deb8u1~bpo70+1_amd64.deb non-free ATI/AMD RadeonHD display driver (runtime libraries)
libgl1-fglrx-glx_15.9-4~deb8u1~bpo70+1_amd64.deb proprietary libGL for the non-free ATI/AMD RadeonHD display driver
libgl1-fglrx-legacy-glx_8.97.100.7-3~bpo70+1_amd64.deb proprietary libGL for the non-free ATI/AMD RadeonHD display driver (legacy)
libgl1-nvidia-glx_340.102-1~bpo70+1_amd64.deb NVIDIA binary OpenGL/GLX libraries
libgl1-nvidia-legacy-173xx-glx_173.14.39-2~bpo70+1_amd64.deb NVIDIA binary OpenGL libraries (173xx legacy version)
libgl1-nvidia-legacy-304xx-glx_304.135-1~bpo70+1_amd64.deb NVIDIA binary OpenGL/GLX libraries (304xx legacy version)
libgl1-nvidia-legacy-96xx-glx_96.43.23-7~bpo70+1_amd64.deb NVIDIA binary OpenGL libraries (96xx legacy version)
libgles1-nvidia_340.102-1~bpo70+1_amd64.deb NVIDIA binary OpenGL|ES 1.x library
libgles2-nvidia_340.102-1~bpo70+1_amd64.deb NVIDIA binary OpenGL|ES 2.x library
libnppc5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA Performance Primitives core runtime library
libnppi5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA Performance Primitives for image processing runtime library
libnpps5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA Performance Primitives for signal processing runtime library
libnvcuvid1_340.102-1~bpo70+1_amd64.deb NVIDIA CUDA Video Decoder runtime library
Advertisement
Advertisement