libcudart5.5_5.5.22-6~bpo70+2_amd64.deb


Advertisement

Description

libcudart5.5 - NVIDIA CUDA runtime library

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Backports Nonfree amd64
Package filename libcudart5.5_5.5.22-6~bpo70+2_amd64.deb
Package name libcudart5.5
Package version 5.5.22
Package release 6~bpo70+2
Package architecture amd64
Package type deb
Homepage -
License -
Maintainer -
Download size 124.29 KB
Installed size 399 B
The Compute Unified Device Architecture (CUDA) enables NVIDIA
graphics processing units (GPUs) to be used for massively parallel
general purpose computation.
This package contains the runtime library.

Alternatives

Package Version Architecture Repository
libcudart5.5_5.5.22-6~bpo70+2_i386.deb 5.5.22 i386 Debian Backports Nonfree
libcudart5.5 - - -

Requires

Name Value
libc6 >= 2.3.3
libstdc++6 >= 4.1.1
multiarch-support -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcudart5.5_5.5.22-6~bpo70+2_amd64.deb
Source Package nvidia-cuda-toolkit

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-backports non-free
  2. Update the package index:
    # sudo apt-get update
  3. Install libcudart5.5 deb package:
    # sudo apt-get install libcudart5.5

Files

Path
/usr/lib/x86_64-linux-gnu/libcudart.so.5.5
/usr/lib/x86_64-linux-gnu/libcudart.so.5.5.22
/usr/share/doc/libcudart5.5/changelog.Debian.gz
/usr/share/doc/libcudart5.5/copyright
/usr/share/lintian/overrides/libcudart5.5

Changelog

2014-11-16 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-6~bpo70+2) wheezy-backports; urgency=medium
* nvidia-opencl-dev: Bump Breaks/Replaces on nvidia-libopencl1 from
(<< 304.88-7~) to (<< 305~) to cover all versions containing libOpenCL.so
that could end up in wheezy. New upstream releases from the 304.xx series
fixing security bugs have been uploaded to wheezy.
2014-10-05 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-6~bpo70+1) wheezy-backports; urgency=medium
* Rebuild for wheezy-backports.
2014-09-28 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-6) unstable; urgency=medium
[ Andreas Beckmann ]
* Move libcuinj{32,64}-5.5 dependency from nvidia-visual-profiler to
nvidia-profiler.
* Move libcuinj{32,64}.so back to nvidia-cuda-dev, nvprof now dlopen()s the
proper soname.  (Closes: #763177)
* nvidia-cuda-dev: Upgrade libcuda.so dependency from Recommends to Depends.
* nvidia-cuda-doc: Remove tracking scripts and images.
* Update lintian overrides.
[ Graham Inggs]
* New package descriptions to satisfy lintian description-is-pkg-name.
2014-09-08 - Graham Inggs <graham@nerve.org.za>
nvidia-cuda-toolkit (5.5.22-5) unstable; urgency=medium
[ Andreas Beckmann ]
* Add Graham Inggs to Uploaders.
[ Graham Inggs ]
* Do not prevent the use of GCC 4.9.  (Closes: #757961)
* Add missing Breaks/Replaces to nvidia-opencl-dev for a clean takeover of
the libOpenCL.so symlink from {amd,nvidia,ocl-icd}-libopencl1.
(Closes: #760554)
2014-05-25 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-4) unstable; urgency=low
* Bump the alternate virtual libcuda dependency to libcuda-5.5-1.
* Remove alternate (Build-)Depends on nvidia-current.  (Closes: #745149)
* Add libopencl-1.1-1 as alternate virtual libopencl1 dependency.
* Update lintian overrides.
* Remove switch for non-multiarch builds.
2013-11-07 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-3) unstable; urgency=low
* Bump the alternate virtual B-D to libcuda-5.5-1.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Upload to unstable.
2013-10-22 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-2) experimental; urgency=low
* Add missing Breaks/Replaces to libcuinj{32,64}-5.5 for a clean takeover of
the libcuinj{32,64}.so symlink from libcuinj{32,64}-5.0.
* nvcc.profile: Add missing NVVMIR_LIBRARY_DIR setting.  (Closes: #725649)
* nvcc.profile: Add -L/usr/lib/<triplet> to make nvlink multiarch aware.
* Drop the gcc/g++ wrappers, all versions up to 4.8 are supported.
2013-09-22 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-1) experimental; urgency=low
* New upstream release 5.5 (July 2013).
* Upload to experimental.
* Update watch file.
* debian/copyright: Synchronize with reformatted and updated EULA.txt.
* SOVERSION bump: 5.0 => 5.5, rename all library packages.
* libnpp[cis]5.5: New packages replacing the split libnpp5.0 library.
* libnvtoolsext1: Renamed from libnvtoolsext5.0, upstream soname change.
* libnvvm2: New package for the NVCC runtime library.
* libcufftw5.5: New package for CUDA FFT library with FFTW interface.
* Ship new binaries and auxiliary files.
* Update symbols control files.
* Update lintian overrides.
2013-11-01 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.0.35-8~bpo70+1) wheezy-backports; urgency=low
* Rebuild for wheezy-backports.
2013-10-19 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.0.35-8) unstable; urgency=low
* Simplify renaming control files on SOVERSION change.
* Update lintian overrides.

See Also

Package Description
libcufft5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA FFT runtime library
libcufftw5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA FFTW runtime library
libcuinj64-5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA INJ runtime library (64-bit)
libcupti-dev_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA Profiler Tools Interface development files
libcupti-doc_5.5.22-6~bpo70+2_all.deb NVIDIA CUDA Profiler Tools Interface documentation
libcupti5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA Profiler Tools Interface runtime library
libcurand5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA Random Numbers Generation runtime library
libcusparse5.5_5.5.22-6~bpo70+2_amd64.deb NVIDIA CUDA Sparse Matrix runtime library
libegl1-nvidia_340.102-1~bpo70+1_amd64.deb NVIDIA binary EGL library
libfglrx-amdxvba1_15.9-4~deb8u1~bpo70+1_amd64.deb AMD XvBA (X-Video Bitstream Acceleration) backend for VA API
libfglrx-legacy-amdxvba1_8.97.100.7-3~bpo70+1_amd64.deb AMD XvBA (X-Video Bitstream Acceleration) runtime libraries (legacy)
libfglrx-legacy_8.97.100.7-3~bpo70+1_amd64.deb non-free ATI/AMD RadeonHD display driver (runtime libraries) (legacy)
libfglrx_15.9-4~deb8u1~bpo70+1_amd64.deb non-free ATI/AMD RadeonHD display driver (runtime libraries)
libgl1-fglrx-glx_15.9-4~deb8u1~bpo70+1_amd64.deb proprietary libGL for the non-free ATI/AMD RadeonHD display driver
libgl1-fglrx-legacy-glx_8.97.100.7-3~bpo70+1_amd64.deb proprietary libGL for the non-free ATI/AMD RadeonHD display driver (legacy)
Advertisement
Advertisement