ant-optional-gcj_1.9.4-3~bpo70+1_i386.deb


Advertisement

Description

ant-optional-gcj - Java based build tool like make - optional libraries (GCJ)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Backports Main i386
Package filename ant-optional-gcj_1.9.4-3~bpo70+1_i386.deb
Package name ant-optional-gcj
Package version 1.9.4
Package release 3~bpo70+1
Package architecture i386
Package type deb
Homepage -
License -
Maintainer -
Download size 356.92 KB
Installed size 1.10 KB
A system independent (i.e. not shell based) build tool that uses XML
files as "Makefiles". This package contains the optional tasks libraries
compiled natively.

Alternatives

Package Version Architecture Repository
ant-optional-gcj_1.9.4-3~bpo70+1_amd64.deb 1.9.4 amd64 Debian Backports Main
ant-optional-gcj_1.8.2-4_amd64.deb 1.8.2 amd64 Debian Main
ant-optional-gcj_1.8.2-4_i386.deb 1.8.2 i386 Debian Main
ant-optional-gcj - - -

Requires

Name Value
ant-optional -
libc6 >= 2.3.6-6~
libgcc1 >= 1:4.1.1
libgcj-bc >= 4.6.3-1~
libgcj-common >> 1:4.1.1-13
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ant-optional-gcj_1.9.4-3~bpo70+1_i386.deb
Source Package ant

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-backports main
  2. Update the package index:
    # sudo apt-get update
  3. Install ant-optional-gcj deb package:
    # sudo apt-get install ant-optional-gcj

Files

Path
/usr/lib/gcj/ant-antlr-1.9.4.jar.so
/usr/lib/gcj/ant-apache-bcel-1.9.4.jar.so
/usr/lib/gcj/ant-apache-bsf-1.9.4.jar.so
/usr/lib/gcj/ant-apache-log4j-1.9.4.jar.so
/usr/lib/gcj/ant-apache-oro-1.9.4.jar.so
/usr/lib/gcj/ant-apache-regexp-1.9.4.jar.so
/usr/lib/gcj/ant-apache-resolver-1.9.4.jar.so
/usr/lib/gcj/ant-apache-xalan2-1.9.4.jar.so
/usr/lib/gcj/ant-commons-logging-1.9.4.jar.so
/usr/lib/gcj/ant-commons-net-1.9.4.jar.so
/usr/lib/gcj/ant-javamail-1.9.4.jar.so
/usr/lib/gcj/ant-jdepend-1.9.4.jar.so
/usr/lib/gcj/ant-jmf-1.9.4.jar.so
/usr/lib/gcj/ant-jsch-1.9.4.jar.so
/usr/lib/gcj/ant-junit-1.9.4.jar.so
/usr/lib/gcj/ant-junit4-1.9.4.jar.so
/usr/lib/gcj/ant-swing-1.9.4.jar.so
/usr/lib/gcj/ant-testutil-1.9.4.jar.so
/usr/share/doc/ant-optional-gcj/README.gz
/usr/share/doc/ant-optional-gcj/changelog.Debian.gz
/usr/share/doc/ant-optional-gcj/copyright
/usr/share/gcj/classmap.d/ant-antlr-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-bcel-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-bsf-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-log4j-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-oro-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-regexp-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-resolver-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-apache-xalan2-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-commons-logging-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-commons-net-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-javamail-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-jdepend-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-jmf-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-jsch-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-junit-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-junit4-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-swing-1.9.4.jar.db
/usr/share/gcj/classmap.d/ant-testutil-1.9.4.jar.db

Changelog

2014-12-10 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.4-3~bpo70+1) wheezy-backports; urgency=low
* Rebuild for wheezy-backports.
- Depend on libgnumail-java instead of libmail-java
- Modified the tests to build with the version of junit in wheezy
2014-10-08 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.4-3) unstable; urgency=medium
* Removed the patch adding Xerces to the Ant classpath
(Closes: #552032, #764376, LP: #324899, LP: #490831, LP: #876091)
* Removed the dependency on libxerces2-java and libjaxp1.3-java
* debian/rules: Removed the unused compile.debug and compile.optimize
properties
* Refreshed the man page for build.xml
2014-09-30 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.4-2) unstable; urgency=medium
* Depend on libmail-java instead of libgnumail-java
* Standards-Version updated to 3.9.6 (no changes)
2014-05-09 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.4-1) unstable; urgency=medium
* New upstream release
- Refreshed the patches
- Removed the patch for #735786 (Fixed upstream)
2014-02-16 - Hideki Yamane <henrich@debian.org>
ant (1.9.3-2) unstable; urgency=medium
* Team upload
* debian/patches
- add 0009-fix-NullPointerException-when-no-destdir-was-set.patch:
pick up upstream fix for FTBFS <Closes: #735786>
2014-01-06 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.3-1) unstable; urgency=medium
* New upstream release
* Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
* Updated the description of 0008-junit4-replace-assumeFalse.patch
* debian/rules:
- Improved the clean target to allow rebuilds
- Remove the version's -SNAPSHOT suffix by setting the version explicitly
when calling mh_installjar instead of altering the original pom files
* Use XZ compression for the upstream tarball
* Documented the -silent flag in the man page (new in Ant 1.9.0)
* debian/copyright: Updated to the Copyright Format 1.0
2013-07-14 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.2-1) unstable; urgency=low
* New upstream release
* Use canonical URLs for the Vcs-* fields
2013-07-02 - James Page <james.page@ubuntu.com>
ant (1.9.1-2) unstable; urgency=low
* Team upload.
* d/maven.rules: Ensure that junit4 dependencies are mapped to 4.x
junit artefact (Closes: #713381).
2013-05-15 - Emmanuel Bourg <ebourg@apache.org>
ant (1.9.1-1) unstable; urgency=low
* New upstream release
- Refreshed the patches
- Removed patch 0001-detect-classpath-based-JVM (merged upstream)
* Enabled hardening for the -gcj packages
* Upload to unstable
2013-03-27 - tony mancill <tmancill@debian.org>
ant (1.9.0-1) experimental; urgency=low
* Team upload.
[ Ludovic Claude ]
* Add version constraint on libxml-commons-resolver1.1-java to
secure backport of Ant on Squeeze.
[ Tony Mancill ]
* Remove Michael Koch Uploaders (Closes: #653982)
* Bump Standards-Version to 3.9.4.
[ Emmanuel Bourg ]
* New upstream release.
- Refreshed the patches
- Upgrade source and target version to 1.5
- Adapted the build to the new documentation path in the upstream source
- Added a patch to build the package with junit4 4.10
* Removed the dependency on java2-runtime-headless
* Add java7-runtime-headless to list of satisfying JRE dependencies

See Also

Package Description
ant-optional_1.9.4-3~bpo70+1_all.deb Java based build tool like make - optional libraries
ant_1.9.4-3~bpo70+1_all.deb Java based build tool like make
apparmor-profiles-extra_1.2~bpo70+1_all.deb Extra profiles for AppArmor Security policies
approx_5.5-1~bpo70+1_i386.deb caching proxy server for Debian archive files
apt-cacher-ng_0.8.0-3~bpo70+2_i386.deb caching proxy server for software repositories
apt-dater-host_1.0.0-2~bpo70+1_all.deb host helper application for apt-dater
aqbanking-tools_5.4.3beta-1~bpo70+1_i386.deb basic command line homebanking utilities
asciidoctor-doc_0.1.3-1~bpo70+1_all.deb AsciiDoc to HTML rendering for Ruby (documentation)
asciidoctor_0.1.3-1~bpo70+1_all.deb AsciiDoc to HTML rendering for Ruby
asterisk-config_11.13.1~dfsg-2~bpo70+1_all.deb Configuration files for Asterisk
asterisk-dahdi_11.13.1~dfsg-2~bpo70+1_i386.deb DAHDI devices support for the Asterisk PBX
asterisk-dev_11.13.1~dfsg-2~bpo70+1_all.deb Development files for Asterisk
asterisk-doc_11.13.1~dfsg-2~bpo70+1_all.deb Source code documentation for Asterisk
asterisk-mobile_11.13.1~dfsg-2~bpo70+1_i386.deb Bluetooth phone support for the Asterisk PBX
asterisk-modules_11.13.1~dfsg-2~bpo70+1_i386.deb loadable modules for the Asterisk PBX
Advertisement
Advertisement