qt4-linguist-tools_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_amd64.deb


Advertisement

Description

qt4-linguist-tools - Qt 4 Linguist tools

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Backports Main amd64
Package filename qt4-linguist-tools_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_amd64.deb
Package name qt4-linguist-tools
Package version 4.8.6+git64
Package release g5dc8b2b+dfsg-3~bpo70+1
Package architecture amd64
Package type deb
Homepage -
License -
Maintainer -
Download size 841.28 KB
Installed size 2.62 KB
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
This package contains lupdate and lrelease. lupdate is a command line tool
that finds the translatable strings in the specified source, header and
Qt Designer interface files, and produces or updates .ts translation files.
lrelease is a command line tool that produces QM files out of TS files.

Alternatives

Package Version Architecture Repository
qt4-linguist-tools_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_i386.deb 4.8.6+git64 i386 Debian Backports Main
qt4-linguist-tools_4.8.2+dfsg-11_amd64.deb 4.8.2+dfsg amd64 Debian Main
qt4-linguist-tools_4.8.2+dfsg-11_i386.deb 4.8.2+dfsg i386 Debian Main
qt4-linguist-tools - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libqt4-xml = 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1
libqtcore4 = 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1
libstdc++6 >= 4.4.0
qtchooser -
zlib1g >= 1:1.1.4

Replaces

Name Value
libqt4-dev << 4:4.7.3-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package qt4-linguist-tools_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_amd64.deb
Source Package qt4-x11

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-backports main
  2. Update the package index:
    # sudo apt-get update
  3. Install qt4-linguist-tools deb package:
    # sudo apt-get install qt4-linguist-tools

Files

Path
/usr/bin/lrelease-qt4
/usr/bin/lupdate-qt4
/usr/lib/x86_64-linux-gnu/qt4/bin/lrelease
/usr/lib/x86_64-linux-gnu/qt4/bin/lupdate
/usr/share/doc/qt4-linguist-tools/LGPL_EXCEPTION.txt
/usr/share/doc/qt4-linguist-tools/changelog.Debian.gz
/usr/share/doc/qt4-linguist-tools/copyright
/usr/share/man/man1/lrelease-qt4.1.gz
/usr/share/man/man1/lupdate-qt4.1.gz
/usr/share/qt4/bin/lrelease
/usr/share/qt4/bin/lupdate

Changelog

2015-05-01 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1) wheezy-backports; urgency=medium
* Backport the final version in Jessie, which includes a CVE fix.
* Add fixes_crash_in_gif_image_decoder.patch and
fixes_crash_in_bmp_and_ico_image_decoder.patch to fix CVE-2015-1858,
CVE-2015-1859 and CVE-2015-1860 (Closes: #783133).
2015-03-02 - Dmitry Shachnev <mitya57@debian.org>
qt4-x11 (4:4.8.6+git64-g5dc8b2b+dfsg-3) unstable; urgency=medium
* Team upload.
* Fix CVE-2015-0295 (DoS vulnerability in BMP images handler).
Closes: #779550.
2014-09-04 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+git64-g5dc8b2b+dfsg-2) unstable; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Remove debian/NEWS, it's no longer accurate.
* Update symbols files with buildds' logs.
[ Adam Majer ]
* Add xmlpatterns_stack_overflow_fix.diff which changes a recursive call
into iteration fixing stack overflow in XmlPatterns.
2014-08-23 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+git64-g5dc8b2b+dfsg-1) unstable; urgency=medium
* New upstream snapshot.
* Disable the use of system proxies by default. It seems that if http_proxy
is setted then all protocols try to use the proxy.
* Add support for arm64 (Closes: #735488).
- Make arm64 use linux-g++ as platform_arg.
- Fix arch detection.
- Add qatomic support. This patch is known to not be the most correct way
to implement them, as it seems to be possible to do it in a faster way,
but should work non the less until we can provide something better.
- Add arm64's mkspecs.
* Add support for ppc64el (Closes: #749743).
- Add ppc64el to 07_trust_dpkg-arch_over_uname-m.diff, as the uname output
differs from the arch name.
- Add symbols changes for ppc64el. Thanks Mauricio Faria de Oliveira!
- Add ppc64el_configure_support.patch to properly detect ppc64* in
configure. Patch from Ubuntu's William Grant. Thanks William!
2014-07-25 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+git49-gbc62005+dfsg-1) unstable; urgency=medium
* New upstream GIT snapshot.
* Update 07_trust_dpkg-arch_over_uname-m.diff and debian/rules in order to
let mips64[el] build (Closes: #719763). Thanks Yunqiang Su for the patch.
* Enable using system network proxies by default.
- Add this information to debian/NEWS to inform our users.
* Update symbols files with buildd's logs.
* Refresh patches.
* Update install files due to the fix of QTBUG-16838.
2014-07-27 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+dfsg-2~bpo70+1) wheezy-backports; urgency=medium
[ Jean-Baptiste Rouault ]
* Rebuild for wheezy-backports.
[ Lisandro Damián Nicanor Pérez Meyer ]
* Fix symbols files.
2014-06-16 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+dfsg-2) unstable; urgency=medium
[ Dmitry Shachnev ]
* Add arm64 to no_pch_architectures.
[ Lisandro Damián Nicanor Pérez Meyer ]
* Use the standard compiler provided by build-essential (Closes: 747988).
* Update symbols files with buildd's and current logs.
* Add parisc-atomic.patch to improve atomic support on parisc
(Closes: #741190).
* Add ppc64el to the list of architectures that build without using pch,
partly solving #749743.
2014-04-24 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.6+dfsg-1) unstable; urgency=medium
* New upstream release.
* Also add ppc64 to the list of non-pch build archs. Thanks Hiroyuki Yamamoto
for the tip.
* Refresh patches.
* Update symbols files with buildd's logs and current build log.
* Apply upstream's dont_crash_on_broken_gif_images.patch to solve
CVE-2014-0190.
* Add lintian overrides for a bug a lintian which makes it think that HTML
pages listing RFCs' license are licensed under it.
* Remove sourceless doc/html/scripts/jquery.js from the original tarball.

See Also

Package Description
qt4-qmake_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_amd64.deb Qt 4 qmake Makefile generator tool
qt4-qmlviewer_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_amd64.deb Qt 4 QML viewer
qt4-qtconfig_4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1_amd64.deb Qt 4 configuration tool
qt5-default_5.3.2+dfsg-4+deb8u1~bpo70+1_amd64.deb Qt 5 development defaults package
qt5-doc-html_5.3.2-3~bpo70+1_all.deb Qt 5 API documentation (HTML format)
qt5-doc_5.3.2-3~bpo70+1_all.deb Qt 5 API Documentation
qt5-image-formats-plugins_5.3.2-2~bpo70+1_amd64.deb Qt 5 Image Formats module
qt5-qmake_5.3.2+dfsg-4+deb8u1~bpo70+1_amd64.deb Qt 5 qmake Makefile generator tool
qtbase5-dev-tools_5.3.2+dfsg-4+deb8u1~bpo70+1_amd64.deb Qt 5 base development programs
qtbase5-dev_5.3.2+dfsg-4+deb8u1~bpo70+1_amd64.deb Qt 5 base development files
qtbase5-doc-html_5.3.2+dfsg-4+deb8u1~bpo70+1_all.deb Qt 5 base HTML documentation
qtbase5-doc_5.3.2-3~bpo70+5_all.deb Qt 5 base documentation
qtbase5-examples_5.3.2+dfsg-4+deb8u1~bpo70+1_amd64.deb Qt 5 base examples
qtbase5-private-dev_5.3.2+dfsg-4+deb8u1~bpo70+1_amd64.deb Qt 5 base private development files
qtchooser_39-g4717841-3~bpo70+1_amd64.deb Wrapper to select between Qt development binary versions
Advertisement
Advertisement