qemu-user_2.1+dfsg-12+deb8u5a~bpo70+1_amd64.deb


Advertisement

Description

qemu-user - QEMU user mode emulation binaries

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Backports Main amd64
Package filename qemu-user_2.1+dfsg-12+deb8u5a~bpo70+1_amd64.deb
Package name qemu-user
Package version 2.1+dfsg
Package release 12+deb8u5a~bpo70+1
Package architecture amd64
Package type deb
Homepage -
License -
Maintainer -
Download size 13.65 MB
Installed size 48.54 KB
QEMU is a fast processor emulator: currently the package supports
ARM, CRIS, i386, M68k (ColdFire), MicroBlaze, MIPS, PowerPC, SH4,
SPARC and x86-64 emulation. By using dynamic translation it achieves
reasonable speed while being easy to port on new host CPUs.
This package provides the user mode emulation binaries. In this mode
QEMU can launch Linux processes compiled for one CPU on another CPU.
If qemu-user-binfmt package is also installed, it will register binary
format handlers from this qemu-user package with the kernel so it will
be possible to run foreign binaries directly.  However, this might not
be suitable for using inside foreign chroots, in which case it is
possible to use qemu-user-static package instead of qemu-user-binmft, --
qemu-user-static will register statically linked binfmt handlers instead.

Alternatives

Package Version Architecture Repository
qemu-user_2.1+dfsg-12+deb8u5a~bpo70+1_i386.deb 2.1+dfsg i386 Debian Backports Main
qemu-user_1.1.2+dfsg-6a+deb7u12_amd64.deb 1.1.2+dfsg amd64 Debian Main
qemu-user_1.1.2+dfsg-6a+deb7u12_i386.deb 1.1.2+dfsg i386 Debian Main
qemu-user_1.1.2+dfsg-6+deb7u25_i386.deb 1.1.2+dfsg i386 Debian Security Updates Main
qemu-user_1.1.2+dfsg-6+deb7u25_amd64.deb 1.1.2+dfsg amd64 Debian Security Updates Main
qemu-user - - -

Requires

Name Value
libc6 >= 2.11
libgcc1 >= 1:4.7
libglib2.0-0 >= 2.24.0
libstdc++6 >= 4.6
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package qemu-user_2.1+dfsg-12+deb8u5a~bpo70+1_amd64.deb
Source Package qemu

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-backports main
  2. Update the package index:
    # sudo apt-get update
  3. Install qemu-user deb package:
    # sudo apt-get install qemu-user

Files

Path
/usr/bin/qemu-aarch64
/usr/bin/qemu-alpha
/usr/bin/qemu-arm
/usr/bin/qemu-armeb
/usr/bin/qemu-cris
/usr/bin/qemu-i386
/usr/bin/qemu-m68k
/usr/bin/qemu-microblaze
/usr/bin/qemu-microblazeel
/usr/bin/qemu-mips
/usr/bin/qemu-mips64
/usr/bin/qemu-mips64el
/usr/bin/qemu-mipsel
/usr/bin/qemu-mipsn32
/usr/bin/qemu-mipsn32el
/usr/bin/qemu-or32
/usr/bin/qemu-ppc
/usr/bin/qemu-ppc64
/usr/bin/qemu-ppc64abi32
/usr/bin/qemu-ppc64le
/usr/bin/qemu-s390x
/usr/bin/qemu-sh4
/usr/bin/qemu-sh4eb
/usr/bin/qemu-sparc
/usr/bin/qemu-sparc32plus
/usr/bin/qemu-sparc64
/usr/bin/qemu-unicore32
/usr/bin/qemu-x86_64
/usr/share/doc/qemu-user/changelog.Debian.gz
/usr/share/doc/qemu-user/changelog.gz
/usr/share/doc/qemu-user/copyright
/usr/share/man/man1/qemu-aarch64.1.gz
/usr/share/man/man1/qemu-alpha.1.gz
/usr/share/man/man1/qemu-arm.1.gz
/usr/share/man/man1/qemu-armeb.1.gz
/usr/share/man/man1/qemu-cris.1.gz
/usr/share/man/man1/qemu-i386.1.gz
/usr/share/man/man1/qemu-m68k.1.gz
/usr/share/man/man1/qemu-microblaze.1.gz
/usr/share/man/man1/qemu-microblazeel.1.gz
/usr/share/man/man1/qemu-mips.1.gz
/usr/share/man/man1/qemu-mips64.1.gz
/usr/share/man/man1/qemu-mips64el.1.gz
/usr/share/man/man1/qemu-mipsel.1.gz
/usr/share/man/man1/qemu-mipsn32.1.gz
/usr/share/man/man1/qemu-mipsn32el.1.gz
/usr/share/man/man1/qemu-or32.1.gz
/usr/share/man/man1/qemu-ppc.1.gz
/usr/share/man/man1/qemu-ppc64.1.gz
/usr/share/man/man1/qemu-ppc64abi32.1.gz
/usr/share/man/man1/qemu-ppc64le.1.gz
/usr/share/man/man1/qemu-s390x.1.gz
/usr/share/man/man1/qemu-sh4.1.gz
/usr/share/man/man1/qemu-sh4eb.1.gz
/usr/share/man/man1/qemu-sparc.1.gz
/usr/share/man/man1/qemu-sparc32plus.1.gz
/usr/share/man/man1/qemu-sparc64.1.gz
/usr/share/man/man1/qemu-unicore32.1.gz
/usr/share/man/man1/qemu-user.1.gz
/usr/share/man/man1/qemu-x86_64.1.gz

Changelog

2016-02-14 - Michael Tokarev <mjt@tls.msk.ru>
qemu (1:2.1+dfsg-12+deb8u5a~bpo70+1) wheezy-backports; urgency=high
* Rebuild for wheezy-backports:
- disable seccomp (not in wheezy)
- build-depend on iasl|acpica-tools
- s/python:any/python/ in build-depends
2016-02-08 - Michael Tokarev <mjt@tls.msk.ru>
qemu (1:2.1+dfsg-12+deb8u5a) jessie-security; urgency=high
* applied 3 patches from upstream to fix virtio-net
possible remote DoS (Closes: #799452 CVE-2015-7295)
* pcnet-add-check-to-validate-receive-data-size-CVE-2015-7504.patch
(Closes: #806742, CVE-2015-7504)
* pcnet-fix-rx-buffer-overflow-CVE-2015-7512.patch
(Closes: #806741, CVE-2015-7512)
* msix-implement-pba-write-but-read-only-CVE-2015-7549.patch
(Closes: #808131, CVE-2015-7549)
* eepro100-prevent-two-endless-loops-CVE-2015-8345.patch
(Closes: #806373, CVE-2015-8345)
* vnc-avoid-floating-point-exception-CVE-2015-8504.patch
(Closes: #808130, CVE-2015-8504)
* ehci-make-idt-processing-more-robust-CVE-2015-8558.patch
(Closes: #808144, CVE-2015-8558)
* two upstream patches from xsa-155 fixing unsafe shared memory access in xen
(Closes: #809229, CVE-2015-8550)
* net-ne2000-fix-bounds-check-in-ioport-operations-CVE-2015-8743.patch
(Closes: #810519, CVE-2015-8743)
* net-vmxnet3-avoid-memory-leakage-in-activate_device-[...].patch
(Closes: #808145, CVE-2015-8567, CVE-2015-8568)
* scsi-initialise-info-object-with-appropriate-size-CVE-2015-8613.patch
(Closes: #809232, CVE-2015-8613)
* vmxnet3-refine-l2-header-validation-CVE-2015-8744.patch
(Closes: CVE-2015-8744)
* vmxnet3-support-reading-IMR-registers-on-bar0-CVE-2015-8745.patch
(Closes: CVE-2015-8745)
* ide-ahci-reset-ncq-object-to-unused-on-error-CVE-2016-1568.patch
(Closes: #810527, CVE-2016-1568)
* fw_cfg-add-check-to-validate-current-entry-value-CVE-2016-1714.patch
(Closes: CVE-2016-1714)
* i386-avoid-null-pointer-dereference-CVE-2016-1922.patch
(Closes: #811201, CVE-2016-1922)
* e1000-eliminate-infinite-loops-on-out-of-bounds-start-CVE-2016-1981.patch
(Closes: #812307, CVE-2016-1981)
* hmp-fix-sendkey-out-of-bounds-write-CVE-2015-8619.patch
(Closes: #809237, CVE-2015-8619)
2015-09-15 - Michael Tokarev <mjt@tls.msk.ru>
qemu (1:2.1+dfsg-12+deb8u4) jessie-security; urgency=high
* ne2000-add-checks-to-validate-ring-buffer-pointers-CVE-2015-5279.patch
fix for Heap overflow vulnerability in ne2000_receive() function
(Closes: #799074 CVE-2015-5279)
* ne2000-avoid-infinite-loop-when-receiving-packets-CVE-2015-5278.patch
(Closes: #799073 CVE-2015-5278) 
2015-09-07 - Michael Tokarev <mjt@tls.msk.ru>
qemu (1:2.1+dfsg-12+deb8u3) jessie-security; urgency=high
* Acknowlege the previous update.  Thank you Salvatore for the hard
work you did fixing so many security issues.
* rename last patches removing numeric prefixes, so that different series
wont intermix with each other, add Bug-Debian: headers.
* Add e1000-avoid-infinite-loop-in-transmit-CVE-2015-6815.patch.
CVE-2015-6815: net: e1000 infinite loop issue in processing transmit
descriptor.  (Closes: #798101 CVE-2015-6815)
* Add ide-fix-ATAPI-command-permissions-CVE-2015-6855.patch.
CVE-2015-6855: ide: qemu allows arbitrary commands to be sent to an ATAPI
device from guest, while illegal comands might have security impact,
f.e. WIN_READ_NATIVE_MAX results in divide by zero error.
(Closes: CVE-2015-6855)

See Also

Package Description
qemu-utils_2.1+dfsg-12+deb8u5a~bpo70+1_amd64.deb QEMU utilities
qemu_2.1+dfsg-12+deb8u5a~bpo70+1_amd64.deb fast processor emulator
qemubuilder_0.73~bpo7+1_amd64.deb pbuilder using QEMU as backend
qml-model-qtqml-models2_5.3.2-4~bpo70+4_all.deb transitional dummy package for qml-module-qtqml-models2
qml-module-enginio_5.3.2-2~bpo70+2_amd64.deb Qt 5 Enginio QML module
qml-module-qt-labs-folderlistmodel_5.3.2-4~bpo70+4_amd64.deb Qt 5 folderlistmodel QML module
qml-module-qt-labs-settings_5.3.2-4~bpo70+4_amd64.deb Qt 5 settings QML module
qml-module-qt-websockets_5.3.2-5~bpo70+1_amd64.deb Qt 5 Web Sockets QML module
qml-module-qtaudioengine_5.3.2-5~bpo70+1_amd64.deb Qt 5 AudioEngine QML module
qml-module-qtbluetooth_5.3.2-2~bpo70+1_amd64.deb Qt Connectivity module - Bluetooth QML module
qml-module-qtgraphicaleffects_5.3.2-2~bpo70+1_amd64.deb Qt 5 Graphical Effects module
qml-module-qtmultimedia_5.3.2-5~bpo70+1_amd64.deb Qt 5 Multimedia QML module
qml-module-qtnfc_5.3.2-2~bpo70+1_amd64.deb Qt Connectivity module - NFC QML module
qml-module-qtpositioning_5.3.2-2~bpo70+1_amd64.deb Qt Positioning QML module
qml-module-qtqml-models2_5.3.2-4~bpo70+4_amd64.deb Qt 5 Models2 QML module
Advertisement
Advertisement