createrepo_0.9.9-1~bpo7+1_all.deb


Advertisement

Description

createrepo - tool to generate the metadata for a yum repository

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Backports Main amd64
Package filename createrepo_0.9.9-1~bpo7+1_all.deb
Package name createrepo
Package version 0.9.9
Package release 1~bpo7+1
Package architecture all
Package type deb
Homepage -
License -
Maintainer -
Download size 47.94 KB
Installed size 227 B
The createrepo tool generates the repodata directory and XML metadata that
makes up a repository of RPM packages. This repository format is supported
by apt-rpm, red-carpet(zen), smartpm, up2date, yast, and yum.
This package is similar to the apt-ftparchive or reprepro commands, but for
working with RPM repositories.

Alternatives

Package Version Architecture Repository
createrepo_0.9.9-1~bpo7+1_all.deb 0.9.9 all Debian Backports Main
createrepo_0.4.11-1_all.deb 0.4.11 all Debian Main
createrepo_0.4.11-1_all.deb 0.4.11 all Debian Main
createrepo - - -

Requires

Name Value
deltarpm -
python >= 2.6.6-7~
python << 2.8
python-deltarpm -
python-libxml2 -
python-rpm -
python-sqlitecachec -
rpm >= 4.1.1
yum >= 3.2.29

Download

Type URL
Mirror ftp.br.debian.org
Binary Package createrepo_0.9.9-1~bpo7+1_all.deb
Source Package createrepo

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-backports main
  2. Update the package index:
    # sudo apt-get update
  3. Install createrepo deb package:
    # sudo apt-get install createrepo

Files

Path
/etc/bash_completion.d/createrepo
/usr/bin/createrepo
/usr/bin/mergerepo
/usr/bin/modifyrepo
/usr/lib/python2.6/dist-packages/createrepo/__init__.py
/usr/lib/python2.6/dist-packages/createrepo/deltarpms.py
/usr/lib/python2.6/dist-packages/createrepo/merge.py
/usr/lib/python2.6/dist-packages/createrepo/readMetadata.py
/usr/lib/python2.6/dist-packages/createrepo/utils.py
/usr/lib/python2.6/dist-packages/createrepo/yumbased.py
/usr/lib/python2.7/dist-packages/createrepo/__init__.py
/usr/lib/python2.7/dist-packages/createrepo/deltarpms.py
/usr/lib/python2.7/dist-packages/createrepo/merge.py
/usr/lib/python2.7/dist-packages/createrepo/readMetadata.py
/usr/lib/python2.7/dist-packages/createrepo/utils.py
/usr/lib/python2.7/dist-packages/createrepo/yumbased.py
/usr/share/createrepo/genpkgmetadata.py
/usr/share/createrepo/mergerepo.py
/usr/share/createrepo/modifyrepo.py
/usr/share/createrepo/worker.py
/usr/share/doc/createrepo/README
/usr/share/doc/createrepo/changelog.Debian.gz
/usr/share/doc/createrepo/changelog.gz
/usr/share/doc/createrepo/copyright
/usr/share/man/man1/mergerepo.1.gz
/usr/share/man/man1/modifyrepo.1.gz
/usr/share/man/man8/createrepo.8.gz
/usr/share/pyshared/createrepo/__init__.py
/usr/share/pyshared/createrepo/deltarpms.py
/usr/share/pyshared/createrepo/merge.py
/usr/share/pyshared/createrepo/readMetadata.py
/usr/share/pyshared/createrepo/utils.py
/usr/share/pyshared/createrepo/yumbased.py
/usr/share/python/runtime.d/createrepo.rtupdate

Changelog

2013-11-29 - Mike Gabriel <sunweaver@debian.org>
createrepo (0.9.9-1~bpo7+1) wheezy-backports; urgency=low
* Upload to wheezy-backports.
2013-08-19 - Mike Miller <mtmiller@ieee.org>
createrepo (0.9.9-1) unstable; urgency=low
* New upstream release. (Closes: #463571)
- createrepo --help now mentions --split option. (Closes: #682151)
- No longer use deprecated md5 and sha modules. (LP: #530015)
* New maintainer. (Closes: #673958) Thanks to Adam for his work.
* debian/patches/01_fix-man-page-options.patch: Escape dashes in
command-line options in man pages.
* Cherry-pick fixes from upstream git:
- debian/patches/02_drop-unused-imports.patch: Fix incorrect call of
function imported from createrepo.utils.
- debian/patches/03_fix-getting-YumAvailablePackage-local-path.patch: Fix
getting path from repository packages.
- debian/patches/04_fix-writing-additional-metadata.patch: Fix writing
metadata when merging repositories.
- debian/patches/05_fix-handling-remote-packages.patch: Fix handling
remote packages when writing repository metadata.
* debian/source/format: Update source format to 3.0 (quilt).
* Bump debhelper compatibility level to 9.
* Update packaging to current Python Policy recommendations:
- debian/rules: Switch to using dh --with python2.
- Add Build-Depends on python-all (>= 2.6.6-3~) for switch to building
with dh_python2.
- Drop Build-Depends on python-all-dev, package is not building Python
extensions.
- Drop Build-Depends on deprecated python-support, now using dh_python2.
- Add X-Python-Version control field.
- Drop obsolete debian/pyversions.
* Install bash completion support:
- Add Build-Depends on bash-completion.
- Install createrepo.bash using dh_bash-completion.
* debian/rules: Install the createrepo python module for all supported
python versions.
* debian/control:
- Add Depends on ${misc:Depends}, deltarpm, python-deltarpm, and
yum (>= 3.2.29).
- Update package description.
- Update Homepage control field to correct upstream URL. (Closes: #682149)
- Set Priority to extra because Depends includes other extra packages.
- Add Vcs-Git and Vcs-Browser fields.
- Bump Standards-Version to 3.9.4. No further changes needed.
* debian/copyright: Convert to machine-readable format 1.0.
* debian/watch: Update to correct upstream URL.
2012-08-22 - Matthias Klose <doko@debian.org>
createrepo (0.4.11-1.1) unstable; urgency=low
* Non maintainer upload.
[ Scott Kitterman ]
* In genpkgmetadata.py/SplitMetaDataGenerator, add try/except around use of
urlparse.uses_fragment to avoid crash when running with a python version
that does not have uses_fragment (2.7.3) (Closes: #682150)
2007-12-17 - Adam Cécile (Le_Vert) <gandalf@le-vert.net>
createrepo (0.4.11-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.7.3.
* Move homepage to the new dpkg field.
2007-08-27 - Adam Cécile (Le_Vert) <gandalf@le-vert.net>
createrepo (0.4.10-1) unstable; urgency=low
* New upstream release.
* Update debian/copyright.
* Add runtime dependency on python-sqlitecachec.
2006-11-19 - Adam Cécile (Le_Vert) <gandalf@le-vert.net>
createrepo (0.4.6-3) unstable; urgency=low
* debian/control: Drop XB-Python-Version. 
2006-11-10 - Adam Cécile (Le_Vert) <gandalf@le-vert.net>
createrepo (0.4.6-2) unstable; urgency=low
* Update packaging to fit the last python policy draft. 
2006-09-11 - Adam Cécile (Le_Vert) <gandalf@le-vert.net>
createrepo (0.4.6-1) unstable; urgency=low
* Initial release (Closes: #386953).

See Also

Package Description
crunch_3.6-1~bpo70+1_amd64.deb tool for creating wordlist
cryptsetup-bin_1.6.4-4~bpo70+1_amd64.deb disk encryption support - command line tools
cryptsetup_1.6.4-4~bpo70+1_amd64.deb disk encryption support - startup scripts
csvimp_0.4.7-2~bpo70+1_amd64.deb CSV data import tool for xTuple applications
ctdb_2.5.4+debian0-4~bpo70+1_amd64.deb clustered database to store temporary data
cubemap_1.1.2-1~bpo70+1_amd64.deb scalable video reflector, designed to be used with VLC
cucumber_1.3.8-1~bpo70+1_all.deb acceptance testing framework
cython-doc_0.19.1+git34-gac3e3a2-1~bpo70+1_all.deb C-Extensions for Python - documentation
cython3_0.19.1+git34-gac3e3a2-1~bpo70+1_amd64.deb C-Extensions for Python 3
cython_0.19.1+git34-gac3e3a2-1~bpo70+1_amd64.deb C-Extensions for Python
darcs-monitor_0.4.2-3~bpo70+1_amd64.deb Darcs add-on that sends mail about newly pushed changes
darktable_1.4.2-1~bpo70+1_amd64.deb virtual lighttable and darkroom for photographers
debian-lan-config_0.13~bpo70+5_all.deb FAI config space for the Debian-LAN system
debian-security-support_2015.04.04~bpo70+1_all.deb Debian security support coverage checker
debomatic_0.13-1~bpo70+1_all.deb automatic build machine for Debian source packages
Advertisement
Advertisement