libcg_3.1.0013-5_i386.deb


Advertisement

Description

libcg - Nvidia Cg core runtime library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Nonfree i386
Package filename libcg_3.1.0013-5_i386.deb
Package name libcg
Package version 3.1.0013
Package release 5
Package architecture i386
Package type deb
Category non-free/libs role::shared-lib
Homepage https://developer.nvidia.com/cg-toolkit
License -
Maintainer Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Download size 1.77 MB
Installed size 11.33 MB
C for graphics (CG) is a high-level shading language developed by Nvidia in
close collaboration with Microsoft for programming vertex and pixel shaders.
This package contains the Cg core runtime library.

Alternatives

Package Version Architecture Repository
libcg_3.1.0013-5_amd64.deb 3.1.0013 amd64 Debian Nonfree
libcg - - -

Requires

Name Value
libc6 >= 2.3.6-6~

Replaces

Name Value
nvidia-cg-toolkit << 3.1.0013-5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcg_3.1.0013-5_i386.deb
Source Package nvidia-cg-toolkit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcg deb package:
    # sudo apt-get install libcg

Files

Path
/usr/lib/i386-linux-gnu/libCg.so
/usr/share/doc/libcg/changelog.Debian.gz
/usr/share/doc/libcg/copyright
/usr/share/lintian/overrides/libcg

Changelog

2019-01-28 - Andreas Beckmann <anbe@debian.org>
nvidia-cg-toolkit (3.1.0013-5) unstable; urgency=medium
* Switch to debhelper-compat (= 12).
* Bump Standards-Version to 4.3.0. No changes needed.
* Add Build-Depends-Package field to symbols files.
* Add debian/rules targets for archiving the tarballs in a separate
repository using git-lfs as storage backend.
* Update Lintian overrides.
2018-03-16 - Andreas Beckmann <anbe@debian.org>
nvidia-cg-toolkit (3.1.0013-4) unstable; urgency=medium
* Switch to debhelper compat level 11.
* Bump Standards-Version to 4.1.3. No changes needed.
* Switch Vcs-* URLs to salsa.debian.org.
* Update watch file.
* Fix new Lintian issues.
2017-11-17 - Andreas Beckmann <anbe@debian.org>
nvidia-cg-toolkit (3.1.0013-3) unstable; urgency=medium
[ Andreas Beckmann ]
* Add gbp.conf to enable overlay mode.
* Add get-tarball-dir target to checkout the tarball archive from SVN.
* Set Priority to optional.
* Bump Standards-Version to 4.1.1.
* Use https:// URLs where possible.
* Bump debhelper to (>= 10) and compat version to 10.
* Set Rules-Requires-Root: no.
* Enable more hardening.
* Use dpkg makefile snippets instead of manual changelog parsing.
* Remove maintainer scripts needed for upgrades from ancient version.
* Fix typo in manpage.
* Update Lintian overrides.
[ Russ Allbery ]
* Remove myself from Uploaders.
2014-10-18 - Andreas Beckmann <anbe@debian.org>
nvidia-cg-toolkit (3.1.0013-2) unstable; urgency=low
[ Miguel A. Colón Vélez ]
* debian/control:
- Build depend on libglu-dev instead of libglu1-dev.
[ Andreas Beckmann ]
* Use canonical Vcs-* URLs.
* Bump Standards-Version to 3.9.6. No changes needed.
* Fix manpage typos.
* Update Lintian overrides.
* Update my email address and drop DMUA.

See Also

Package Description
libcggl_3.1.0013-5_i386.deb Nvidia Cg Opengl runtime library
libclamunrar9_0.101.2-1_i386.deb anti-virus utility for Unix - unrar support
libcuda1-i386_410.104-3_i386.deb NVIDIA CUDA 32-bit runtime library
libcuda1_410.104-3_i386.deb NVIDIA CUDA Driver Library
libcuneiform-dev_1.1.0+dfsg-7_i386.deb multi-language OCR system (development)
libcuneiform0_1.1.0+dfsg-7_i386.deb multi-language OCR system (shared library)
libcupti-doc_9.2.148-7_all.deb NVIDIA CUDA Profiler Tools Interface documentation
libegl-nvidia-legacy-390xx0_390.116-1_i386.deb NVIDIA binary EGL library (390xx legacy version)
libegl-nvidia0_410.104-3_i386.deb NVIDIA binary EGL library
libegl1-nvidia-legacy-340xx_340.107-4_i386.deb NVIDIA binary EGL library (340xx legacy version)
libegl1-nvidia-legacy-390xx_390.116-1_i386.deb NVIDIA binary EGL library (non-GLVND variant) (390xx legacy version)
libegl1-nvidia_410.104-3_i386.deb NVIDIA binary EGL library (non-GLVND variant)
libfaac-dev_1.29.9.2-2_i386.deb AAC audio encoder (development)
libfaac0_1.29.9.2-2_i386.deb AAC audio encoder (library)
libfdk-aac-dev_0.1.6-1_i386.deb Fraunhofer FDK AAC Codec Library - development files
Advertisement
Advertisement