libmkl-gnu-thread_2019.2.187-1_amd64.deb


Advertisement

Description

libmkl-gnu-thread - Intel® MKL: OpenMP threading library for GNU Fortran/C compilers

Property Value
Distribution Debian 10 (Buster)
Repository Debian Nonfree amd64
Package filename libmkl-gnu-thread_2019.2.187-1_amd64.deb
Package name libmkl-gnu-thread
Package version 2019.2.187
Package release 1
Package architecture amd64
Package type deb
Category non-free/libs role::shared-lib
Homepage https://software.intel.com/en-us/mkl
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 3.68 MB
Installed size 23.68 MB
Intel® Math Kernel Library (Intel® MKL) is a computing math library of highly
optimized, extensively threaded routines for applications that require
maximum performance.
This package contains OpenMP threading library for the GNU Fortran/C compilers.
It belongs to the Threading Layer of MKL.

Alternatives

Package Version Architecture Repository
libmkl-gnu-thread_2019.2.187-1_i386.deb 2019.2.187 i386 Debian Nonfree
libmkl-gnu-thread - - -

Requires

Name Value
libc6 >= 2.2.5
libmkl-locale = 2019.2.187-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmkl-gnu-thread_2019.2.187-1_amd64.deb
Source Package intel-mkl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmkl-gnu-thread deb package:
    # sudo apt-get install libmkl-gnu-thread

Files

Path
/usr/lib/x86_64-linux-gnu/libmkl_gnu_thread.so
/usr/share/doc/libmkl-gnu-thread/changelog.Debian.gz
/usr/share/doc/libmkl-gnu-thread/copyright
/usr/share/lintian/overrides/libmkl-gnu-thread

Changelog

2019-02-17 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.2.187-1) unstable; urgency=medium
* New upstream release 2019.2.187
* Update md5 checksum for 2019.2.187 orig tarball.
2019-01-29 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.1.144-4) unstable; urgency=medium
* Make dependency on libomp-dev mandatory since iomp5 is the default
threading model used by libmkl-rt. Also make libmkl-rt depend on
devel packages instead of lib packages because libmkl-rt is calling
these libraries through libdl. (Closes: #920730)
* Update test scripts and Makefile in debian/tests.
* Replace embedded jquery in documentation/ja with symlink to libjs-jquery.
* Fix a spelling error in README.Debian.
2019-01-06 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.1.144-3) unstable; urgency=medium
* Overhaul README.Debian and make it concise.
* Rename mkl-rt*.pc to mkl-sdl*.pc, and remove -liomp5 from libs.
* Noop amd64-specific autopkgtest commands on i386.
* Bump Standards-Version to 4.3.0 (no change).
2019-01-05 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.1.144-2) unstable; urgency=medium
* Amend autopkgtest script:
(1) Link test program against gomp with -fopenmp
(2) Make ILP64 tests specific for amd64 architecture.
(3) Remove g++ argument "-m64" to fix failure on i386.
2019-01-04 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.1.144-1) unstable; urgency=medium
* New upstream release 2019.1.144
* Uscan: Monitor Tsinghua University's Anaconda mirror for MKL updates.
It looks like Intel has dropped the Pypi channel.
* Update checksum for intel-mkl.md5 and comments in rules.
* Autopkgtest: More test cases using abi-blas.c.
* Switch Depends on libiomp5.so (intel) as default threading library.
* Extend autopkgtest to 18 test cases.
* Help MKL find libgomp.so during autopkgtest.
2018-12-28 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.0.117-4) unstable; urgency=medium
* Revert the removal of slave link for cblas.h.
* Add slave link for cblas64.h for BLAS64.
2018-12-12 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.0.117-3) unstable; urgency=medium
* Misc update for README.Debian.
* Ease threading library dependency forlibmkl-rt and libmkl-dev.
Anyone of tbb, iomp and gomp would satisfy the dependency.
- Remove libomp-dev from autopkgtest depends.
* Update simple test programs.
* Provide libblas64 and liblapack64 alternatives.
+ libmkl-rt  Enhances libblas64.so.3, liblapack64.so.3
+ libmkl-dev Enhances libblas64.so,   liblapack64.so
+ libmkl-rt  provides libblas64.so.3, liblapack64.so.3 via alternatives.
+ libmkl-dev provides libblas64.so,   liblapack64.so   via alternatives.
* Only manipulate blas64/lapack64 alternatives on amd64.
* No longer provide slave links for cblas.h .
2018-09-26 - Mo Zhou <cdluminate@gmail.com>
intel-mkl (2019.0.117-2) unstable; urgency=medium
* Export HOME=/tmp/ to fix FTBFS due to the failure that rpm would
attempt to store GPG key used for verifying rpm packages under
/sbuild-nonexistent/.rpmdb directory without a proper HOME.

See Also

Package Description
libmkl-intel-ilp64_2019.2.187-1_amd64.deb Intel® MKL: ILP64 interface library for the Intel compilers
libmkl-intel-lp64_2019.2.187-1_amd64.deb Intel® MKL: LP64 interface library for the Intel compilers
libmkl-intel-thread_2019.2.187-1_amd64.deb Intel® MKL: OpenMP threading library for the Intel compilers
libmkl-interface-dev_2019.2.187-1_amd64.deb Static libs of intel-MKL: Interface Layer
libmkl-locale_2019.2.187-1_amd64.deb Intel MKL: Locale Files Used by All Shared Objects
libmkl-mc3_2019.2.187-1_amd64.deb Intel® MKL: Kernel library for Intel® SSE4.2 enabled processors
libmkl-mc_2019.2.187-1_amd64.deb Intel® MKL: Kernel library for Intel® SSSE3 enabled processors
libmkl-meta-cluster_2019.2.187-1_amd64.deb Metapackage for Intel-MKL: Shared Object for Cluster
libmkl-meta-computational_2019.2.187-1_amd64.deb Metapackage of intel-MKL: Shared Objects for Computaional Layer
libmkl-meta-interface_2019.2.187-1_amd64.deb Metapackage of intel-MKL: Shared Objects of Interface Layer
libmkl-meta-threading_2019.2.187-1_amd64.deb Metapackage of intel-MKL: Shared Objects of Threading Layer
libmkl-pgi-thread_2019.2.187-1_amd64.deb Intel® MKL: OpenMP threading library for the PGI compiler
libmkl-rt_2019.2.187-1_amd64.deb Intel® MKL: Single Dynamic Library (SDL)
libmkl-scalapack-ilp64_2019.2.187-1_amd64.deb Intel® MKL : ScaLAPACK routine library supporting ILP64 interface
libmkl-scalapack-lp64_2019.2.187-1_amd64.deb Intel® MKL : ScaLAPACK routine library supporting LP64 interface
Advertisement
Advertisement