yapra_0.1.2-7.1_all.deb


Advertisement

Description

yapra - Yet Another Pragger implementation

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename yapra_0.1.2-7.1_all.deb
Package name yapra
Package version 0.1.2
Package release 7.1
Package architecture all
Package type deb
Category implemented-in::ruby net role::program works-with-format::xml:rss
Homepage http://yapra.rubyforge.org/
License -
Maintainer Taku YASUI <tach@debian.org>
Download size 16.82 KB
Installed size 97.00 KB
Yapra is yet another Pragger implementation.  Pragger is a pluggable RSS/Atom
feed aggregator written in Ruby. It has following advantages
against Pragger.
* Class-based plugin mechanism
* Loadpath-based plugin searching/reading
* Import logger into system core
* Use "Yapra" namespace for Plugin class
* Support config file like Python habu

Alternatives

Package Version Architecture Repository
yapra_0.1.2-7.1_all.deb 0.1.2 all Debian Main
yapra - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package yapra_0.1.2-7.1_all.deb
Source Package yapra

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install yapra deb package:
    # sudo apt-get install yapra

Files

Path
/usr/bin/yapra
/usr/lib/ruby/vendor_ruby/yapra.rb
/usr/lib/ruby/vendor_ruby/yapra/config.rb
/usr/lib/ruby/vendor_ruby/yapra/inflector.rb
/usr/lib/ruby/vendor_ruby/yapra/legacy_plugin.rb
/usr/lib/ruby/vendor_ruby/yapra/pipeline.rb
/usr/lib/ruby/vendor_ruby/yapra/plugin.rb
/usr/lib/ruby/vendor_ruby/yapra/runtime.rb
/usr/lib/ruby/vendor_ruby/yapra/version.rb
/usr/lib/ruby/vendor_ruby/yapra/legacy_plugin/advance_mode_registry.rb
/usr/lib/ruby/vendor_ruby/yapra/legacy_plugin/base.rb
/usr/lib/ruby/vendor_ruby/yapra/legacy_plugin/compatible_mode_registry.rb
/usr/lib/ruby/vendor_ruby/yapra/legacy_plugin/registry_factory.rb
/usr/lib/ruby/vendor_ruby/yapra/plugin/base.rb
/usr/lib/ruby/vendor_ruby/yapra/plugin/context_aware.rb
/usr/lib/ruby/vendor_ruby/yapra/plugin/erb_applier.rb
/usr/lib/ruby/vendor_ruby/yapra/plugin/feed_item_operator.rb
/usr/lib/ruby/vendor_ruby/yapra/plugin/mechanize_base.rb
/usr/share/doc/yapra/History.txt
/usr/share/doc/yapra/README.txt
/usr/share/doc/yapra/changelog.Debian.gz
/usr/share/doc/yapra/copyright
/usr/share/man/man1/yapra.1.gz
/usr/share/yapra/lib-plugins/yapra/plugin/config/agent.rb
/usr/share/yapra/lib-plugins/yapra/plugin/config/basic_auth.rb
/usr/share/yapra/lib-plugins/yapra/plugin/config/web_post.rb
/usr/share/yapra/lib-plugins/yapra/plugin/feed/custom.rb
/usr/share/yapra/lib-plugins/yapra/plugin/feed/load.rb
/usr/share/yapra/lib-plugins/yapra/plugin/filter/apply_template.rb
/usr/share/yapra/lib-plugins/yapra/plugin/filter/deduped.rb
/usr/share/yapra/lib-plugins/yapra/plugin/filter/entry_full_text.rb
/usr/share/yapra/lib-plugins/yapra/plugin/publish/file_download.rb
/usr/share/yapra/lib-plugins/yapra/plugin/publish/gmail.rb
/usr/share/yapra/lib-plugins/yapra/plugin/publish/imap.rb
/usr/share/yapra/lib-plugins/yapra/plugin/publish/on_memory_download.rb
/usr/share/yapra/lib-plugins/yapra/plugin/test/append_entry.rb
/usr/share/yapra/lib-plugins/yapra/plugin/test/raise_error.rb
/usr/share/yapra/lib-plugins/yapra/plugin/test/test.rb
/usr/share/yapra/lib-plugins/yapra/plugin/test/test2.rb
/usr/share/yapra/plugins/Filter/deduped.rb
/usr/share/yapra/plugins/Filter/grep.rb
/usr/share/yapra/plugins/Filter/sort.rb
/usr/share/yapra/plugins/Filter/subs.rb

Changelog

2015-08-22 - Christian Hofstaedtler <zeha@debian.org>
yapra (0.1.2-7.1) unstable; urgency=medium
* Non-maintainer upload.
* Remove Recommends: ruby-twitter4r, which is no longer available,
and stop shipping the twitter plugin. (Closes: #733005)
* Remove Recommends: ruby-hpricot, which is obsolete, and stop
shipping the apply_text_html plugin. (Closes: #796496)
2012-04-15 - Taku YASUI <tach@debian.org>
yapra (0.1.2-7) unstable; urgency=low
* Enable using not only ruby-1.8 but ruby-1.9.1
- Add 40_for_ruby1.9 patch for fixing compatibility
2012-03-26 - Taku YASUI <tach@debian.org>
yapra (0.1.2-6) unstable; urgency=low
* Use quilt instead of dpatch
* Bump Standards-Version to 3.9.3
* Moved repository to svn.debian.org
- svn://svn.debian.org/svn/collab-maint/deb-maint/yapra
2011-09-11 - Taku YASUI <tach@debian.org>
yapra (0.1.2-5) unstable; urgency=low
* Use 'Mechanize' instead of deprecated 'WWW::Mechanize'.
2011-06-18 - Taku YASUI <tach@debian.org>
yapra (0.1.2-4) unstable; urgency=low
* Add ruby1.8 to Build-deps (closes: #630667)
- Use ruby1.8 command instead of ruby to fix version
2010-10-11 - Taku YASUI <tach@debian.org>
yapra (0.1.2-3) unstable; urgency=low
* Suppress warnings
2009-09-10 - Taku YASUI <tach@debian.org>
yapra (0.1.2-2) unstable; urgency=low
* Initial official release (closes: #544306)
* Fix debian/copyright
- Write correct copyright/license information
- Write disclaimer about difference of copyright holder name
2009-09-04 - Taku YASUI <tach@debian.org>
yapra (0.1.2-1) unstable; urgency=low
* Initial release
* Fix filter/deduped plugin
- Use twice directory hashing instead of flat directory

See Also

Package Description
yara-doc_3.9.0-1_all.deb HTML documentation for YARA
yara_3.9.0-1_i386.deb Pattern matching swiss knife for malware researchers
yard-doc_0.9.16-1_all.deb Ruby documentation tool - documentation
yard_0.9.16-1_all.deb Ruby documentation tool
yaret_2.1.0-5.1_all.deb console tool to turn CDs into encoded music
yarnpkg_1.13.0-1_all.deb Fast, reliable and secure npm alternative
yasat_848-1_all.deb simple stupid audit tool
yash_2.48-1_i386.deb yet another shell
yaskkserv_1.1.0-2_i386.deb small and fast SKK dictionary server intended for embedded use
yasm_1.3.0-2+b1_i386.deb modular assembler with multiple syntaxes support
yasnippet-snippets_0.9-1_all.deb transition package, yasnippet-snippets to elpa-yasnippet-snippets
yasnippet_0.13.0-2_all.deb transition Package, yasnippet to elpa-yasnippet
yasr_0.6.9-8_i386.deb General-purpose console screen reader
yasw_0.6-2_i386.deb Yet Another Scan Wizard
yatex_1.81-2_all.deb Yet Another TeX mode for Emacs
Advertisement
Advertisement