ruby-ruby2ruby_2.4.1-1_all.deb


Advertisement

Description

ruby-ruby2ruby - Generate pure ruby code easily from ParseTree's Sexps

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename ruby-ruby2ruby_2.4.1-1_all.deb
Package name ruby-ruby2ruby
Package version 2.4.1
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/seattlerb/ruby2ruby
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 12.33 KB
Installed size 52.00 KB
ruby2ruby provides a means of generating pure Ruby code easily from
ParseTree's Sexps. This makes making dynamic language processors much
easier in Ruby than ever before.

Alternatives

Package Version Architecture Repository
ruby-ruby2ruby_2.4.1-1_all.deb 2.4.1 all Debian Main
ruby-ruby2ruby - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-parser >= 3.11~
ruby-sexp-processor >= 4.11~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-ruby2ruby_2.4.1-1_all.deb
Source Package ruby-ruby2ruby

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ruby2ruby deb package:
    # sudo apt-get install ruby-ruby2ruby

Files

Path
/usr/bin/r2r_show
/usr/lib/ruby/vendor_ruby/ruby2ruby.rb
/usr/share/doc/ruby-ruby2ruby/README.rdoc
/usr/share/doc/ruby-ruby2ruby/changelog.Debian.gz
/usr/share/doc/ruby-ruby2ruby/copyright
/usr/share/rubygems-integration/all/specifications/ruby2ruby-2.4.1.gemspec

Changelog

2018-08-01 - Cédric Boutillier <boutil@debian.org>
ruby-ruby2ruby (2.4.1-1) unstable; urgency=medium
* Team upload
* New upstream version 2.4.1
* Use salsa.debian.org in Vcs-* fields
* Bump Standards-Version to 4.1.5 (no changes needed)
* Move debian/watch to gemwatch.debian.net
* Bump debhelper compatibility level to 11
* Refresh read_ruby2ruby.patch
* README is now rdoc
* bump versions in dependencies on ruby-parser and ruby-sexp-processor
2016-07-21 - Cédric Boutillier <boutil@debian.org>
ruby-ruby2ruby (2.3.0-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 2.3.0
* The gemspec file gets installed (Closes: #830931)
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.8 (no changes needed)
* Run wrap-and-sort on packaging files
* Drop dont_require_rubygems patch. Not needed any more
* Set Testsuite field to autopkgtest-pkg-ruby
* Set minimal version for ruby-sexp-processor dependency to 4.7
* Add read_ruby2ruby.patch
2013-12-27 - Cédric Boutillier <boutil@debian.org>
ruby-ruby2ruby (2.0.7-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 2.0.7
* debian/copyright:
use DEP5 copyright-format/1.0 official URL for Format field
* debian/control:
- bump Standards-Version to 3.9.5 (no changes needed)
- bump minimal version for dependency on ruby-sexp-processor/ruby-parser
- build-depend on gem2deb >= 0.5 to add Ruby 2.0 support and drop Ruby 1.8
(Closes: #730934)
- build-depend on ruby-minitest
- use canonical URI in Vcs-* fields
* Refresh debian/patches/dont_require_rubygems
* Drop transitional packages
2011-11-14 - Gunnar Wolf <gwolf@debian.org>
ruby-ruby2ruby (1.3.1-1) unstable; urgency=low
* New upstream release
* Repackaged using the new gem2deb way
* Added myself to uploaders
2010-02-21 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
libruby2ruby-ruby (1.2.4-4) unstable; urgency=low
* Remove Sebastien Delafond from maintainer. Many thanks for all the
past work!
2010-02-20 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
libruby2ruby-ruby (1.2.4-3) unstable; urgency=low
* Drop package for Ruby 1.9. libsexp-processor-ruby doesn't provide an 1.9
package anymore. Closes: #569877.
* Standards-Version -> 3.8.4. No changes needed.
* Add missing dep on libsexp-processor-ruby1.8.
2009-12-06 - Tobias Grimm <etobi@debian.org>
libruby2ruby-ruby (1.2.4-2) unstable; urgency=low
* Added 10_do_not_requiere_rubygems.dpatch
2009-10-12 - Sebastien Delafond <seb@debian.org>
libruby2ruby-ruby (1.2.4-1) unstable; urgency=low
* New upstream release.
* Moved to CDBS.
* Added debian/watch file.
* Various lintian cleanups.
2008-05-11 - Sebastien Delafond <seb@debian.org>
libruby2ruby-ruby (1.1.8-1) unstable; urgency=low
* Initial Release (Closes: #480697).

See Also

Package Description
ruby-rubymail-doc_1.1.3-2_all.deb MIME mail parsing and generation library (documentation)
ruby-rubymail_1.1.3-2_all.deb MIME mail parsing and generation library
ruby-rubypants_0.6.0-1_all.deb Ruby port of SmartyPants smart-quotes library
ruby-rubytorrent_0.3-5_all.deb BitTorrent library in Ruby
ruby-rubyvis_0.6.1+dfsg1-2_all.deb Ruby visualization toolkit
ruby-rufus-scheduler_3.4.2-1_all.deb job scheduler for Ruby
ruby-rugged_0.27.4+ds-1_i386.deb Ruby binding to the libgit2 library
ruby-rugments_1.0.0~beta8-1_all.deb pure-ruby syntax highlighter replacement for pygments
ruby-safe-yaml_1.0.4-2_all.deb safer YAML loader for Ruby
ruby-saml_1.7.2-1_all.deb SAML toolkit for Ruby on Rails
ruby-samuel_0.3.3-1_all.deb automatic logger for HTTP requests in Ruby
ruby-sanitize_4.6.6-2_all.deb whitelist-based HTML sanitizer
ruby-sasl_0.0.3.3-2_all.deb SASL client library for Ruby
ruby-sass-rails_5.0.6-2_all.deb Sass adapter for the Rails asset pipeline
ruby-sass_3.5.6-1_all.deb powerful but elegant CSS compiler that makes CSS fun again
Advertisement
Advertisement