ruby-recaptcha_4.11.1-2_all.deb


Advertisement

Description

ruby-recaptcha - Ruby helpers for the reCAPTCHA API

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename ruby-recaptcha_4.11.1-2_all.deb
Package name ruby-recaptcha
Package version 4.11.1
Package release 2
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/ambethia/recaptcha/
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 13.41 KB
Installed size 47.00 KB
This plugin gives a high-level interface for using reCAPTCHA authentication
methods in your ruby programs.
In your views you can use the recaptcha_tags method to embed the needed
Javascript, and you can validate in your controllers with verify_recaptcha.

Alternatives

Package Version Architecture Repository
ruby-recaptcha_4.11.1-2_all.deb 4.11.1 all Debian Main
ruby-recaptcha - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-json -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-recaptcha_4.11.1-2_all.deb
Source Package ruby-recaptcha

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-recaptcha deb package:
    # sudo apt-get install ruby-recaptcha

Files

Path
/usr/lib/ruby/vendor_ruby/recaptcha.rb
/usr/lib/ruby/vendor_ruby/recaptcha/client_helper.rb
/usr/lib/ruby/vendor_ruby/recaptcha/configuration.rb
/usr/lib/ruby/vendor_ruby/recaptcha/rails.rb
/usr/lib/ruby/vendor_ruby/recaptcha/railtie.rb
/usr/lib/ruby/vendor_ruby/recaptcha/verify.rb
/usr/lib/ruby/vendor_ruby/recaptcha/version.rb
/usr/share/doc/ruby-recaptcha/README.md.gz
/usr/share/doc/ruby-recaptcha/changelog.Debian.gz
/usr/share/doc/ruby-recaptcha/changelog.gz
/usr/share/doc/ruby-recaptcha/copyright
/usr/share/rubygems-integration/all/specifications/recaptcha-4.11.1.gemspec

Changelog

2019-03-06 - Pirate Praveen <praveen@debian.org>
ruby-recaptcha (4.11.1-2) unstable; urgency=medium
* Remove unneeded dependency on rails, add ruby-json dependency
* Bump Standards-Version to 4.3.0 (no changes needed)
* Update debhelper compatibility level to 11~
2018-08-24 - Lucas Kanashiro <lucas.kanashiro@collabora.co.uk>
ruby-recaptcha (4.11.1-1) unstable; urgency=medium
* Team upload.
* New upstream version 4.11.1
* Bump debhelper compatibility level to 11
* Declare complaince with Debian Policy 4.2.0
* Update VCS urls to point to salsa
* Update years of upstream copyright
* debian/copyright: use secure urls in Format and Source fields
* Update Debian packaging copyright
2017-02-19 - Pirate Praveen <praveen@debian.org>
ruby-recaptcha (3.2.0-3) unstable; urgency=medium
* Make the package officially team maintained (Closes: #843437)
* Add myself as uploader
2016-07-09 - Pirate Praveen <praveen@debian.org>
ruby-recaptcha (3.2.0-2) unstable; urgency=medium
* Team upload
* Reupload to unstable
* Check gemspec dependencies during build
2016-06-16 - Pirate Praveen <praveen@debian.org>
ruby-recaptcha (3.2.0-1) experimental; urgency=medium
* Team upload
* New upstream major release
* Remove patch gemspec_without_git.patch (gem2deb can handle it now)
2015-07-28 - David Martínez Moreno <ender@debian.org>
ruby-recaptcha (0.4.0-1) unstable; urgency=medium
* New upstream release:
- Support for ReCAPTCHA v2.
* Fix rails dependency to be >> 4.1, due to #754981.
* debian/patches: Added gemspec_without_git to deal with the infamous `git
ls-files` usual command, invalid in our chroots, and thus ship a valid
gemspec (LP: #1400564).
* debian/watch: Added.
* debian/control: Bumped to 3.9.6 (no changes).
2014-04-09 - Christian Hofstaedtler <zeha@debian.org>
ruby-recaptcha (0.3.6-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Replace ruby1.9 dependency with ruby metapackage.
2014-01-30 - David Martínez Moreno <ender@debian.org>
ruby-recaptcha (0.3.6-2) unstable; urgency=low
* debian/control: Remove ruby-pkg-tools from Build-Depends (closes:
#737179).
2014-01-08 - David Martínez Moreno <ender@debian.org>
ruby-recaptcha (0.3.6-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Bumped Standards-Version (no change).
- Changed a dependency on ruby1.8 to ruby1.9.
- Bumped Rails dependency to >> 3.
- Added Vcs-* fields.
2012-10-18 - David Martínez Moreno <ender@debian.org>
ruby-recaptcha (0.3.2+git20121017-1) unstable; urgency=low
* Initial release (closes: #690754).

See Also

Package Description
ruby-recursive-open-struct_1.1.0-1_all.deb OpenStruct subclass that returns nested hash attributes as RecursiveOpenStructs
ruby-redcarpet_3.4.0-4+b1_i386.deb Fast, safe and extensible Markdown to (X)HTML parser for Ruby
ruby-redcloth_4.3.2-3+b1_i386.deb Textile module for Ruby
ruby-redis-actionpack_5.0.1-2_all.deb Redis session store for ActionPack
ruby-redis-activesupport_5.0.4-1_all.deb Redis store for ActiveSupport::Cache
ruby-redis-namespace_1.6.0-1_all.deb Namespaces commands when multiple apps access same redis server
ruby-redis-rack_2.0.2-2_all.deb Redis Store for Rack
ruby-redis-rails_5.0.2-3_all.deb Redis stores for Ruby on Rails
ruby-redis-store_1.3.0-3_all.deb redis stores for Ruby frameworks
ruby-redis_3.3.5-1_all.deb Ruby client library for Redis
ruby-ref_2.0.0-1_all.deb library implements weak, soft, and strong references in Ruby
ruby-regexp-parser_1.2.0-1_all.deb Scanner, lexer, parser for ruby's regular expressions
ruby-regexp-property-values_0.3.4-1_i386.deb Inspect property values supported by Ruby's regex engine
ruby-remcached_0.4.1-3_all.deb Ruby EventMachine memcached client
ruby-remctl_3.15-1+b3_i386.deb Ruby extension for Kerberos-authenticated command execution
Advertisement
Advertisement