ruby-qdbm_1.8.78-9+b1_i386.deb


Advertisement

Description

ruby-qdbm - QDBM Database Libraries for Ruby

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename ruby-qdbm_1.8.78-9+b1_i386.deb
Package name ruby-qdbm
Package version 1.8.78
Package release 9+b1
Package architecture i386
Package type deb
Category ruby
Homepage http://fallabs.com/qdbm/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 26.15 KB
Installed size 147.00 KB
QDBM is an embedded database library compatible with GDBM and NDBM.
It features hash database and B+ tree database and is developed referring
to GDBM for the purpose of the following three points: higher processing
speed, smaller size of a database file, and simpler API.
This package provides the Ruby interface for the QDBM database library.

Alternatives

Package Version Architecture Repository
ruby-qdbm_1.8.78-9+b1_amd64.deb 1.8.78 amd64 Debian Main
ruby-qdbm - - -

Requires

Name Value
libc6 >= 2.3.6-6~
libqdbm14 >= 1.8.74
libruby2.5 >= 2.5.0~preview1
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-qdbm_1.8.78-9+b1_i386.deb
Source Package qdbm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-qdbm deb package:
    # sudo apt-get install ruby-qdbm

Files

Path
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.5.0/curia.rb
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.5.0/depot.rb
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.5.0/mod_curia.so
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.5.0/mod_depot.so
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.5.0/mod_villa.so
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.5.0/villa.rb
/usr/share/doc/ruby-qdbm/changelog.Debian.gz
/usr/share/doc/ruby-qdbm/changelog.Debian.i386.gz
/usr/share/doc/ruby-qdbm/changelog.gz
/usr/share/doc/ruby-qdbm/copyright

Changelog

2018-04-11 - Aurelien Jarno <aurel32@debian.org>
qdbm (1.8.78-9) unstable; urgency=medium
* Fix Build-Profiles entry for libqdbm-java.
* Move build-java-stamp from build-indep to build-arch.
2018-04-10 - Aurelien Jarno <aurel32@debian.org>
qdbm (1.8.78-8) unstable; urgency=medium
* QA upload.
* Add a nojava profile. 
2018-03-06 - James Clarke <jrtc27@debian.org>
qdbm (1.8.78-7) unstable; urgency=medium
* QA upload.
* Change maintainer to the Debian QA Group
* Fix include paths when building with GCJ.
Thanks to Jason Duerstock (Closes: #892200)
* Update Vcs-* to refer to new repository on Salsa
2018-02-06 - Matthias Klose <doko@debian.org>
qdbm (1.8.78-6.2) unstable; urgency=medium
* Non maintainer upload.
* Lower the optimization to -O1 to pass the test suite. Closes: #853627.
* Bump standards and debhelper versions.
* Don't set noopt flags, ignored anyway in the upstream build system.
* Do the extra/optional dance.
* ruby-qdbm: Remove obsolete ruby breaks/replaces/conflicts.
2018-02-01 - Matthias Klose <doko@ubuntu.com>
qdbm (1.8.78-6.1build2) bionic; urgency=medium
* No-change rebuild for ruby2.5 update.
2017-07-26 - Matthias Klose <doko@ubuntu.com>
qdbm (1.8.78-6.1build1) artful; urgency=medium
* No-change rebuild for perl 5.26.0.
2016-12-19 - Christian Hofstaedtler <zeha@debian.org>
qdbm (1.8.78-6.1) unstable; urgency=medium
* Non-maintainer upload.
* Drop explicit dependency on g++-5. (Closes: #835952)
* Replace Build-Depends: perl-modules with just perl.
2015-08-04 - KURASHIKI Satoru <lurdan@gmail.com>
qdbm (1.8.78-6) unstable; urgency=medium
* New Standards-Version: 3.9.6.
* update symbol file to fix ftbfs with gcc-5. (Closes: #791736)
2014-07-07 - KURASHIKI Satoru <lurdan@gmail.com>
qdbm (1.8.78-5) unstable; urgency=medium
[ gregor herrmann ]
* Fix "hardcodes /usr/lib/perl5":
- add patch that passes INSTALLDIRS=vendor to perl Makefile.PL calls
- remove usr/lib/perl5 from debian/libqdbm-perl.dirs, files are in the
right directories now
- remove some now unneeded (re)moving in debian/rules and adjust paths
- use $Config{vendorarch} in debian/rules to get the perl library path at
build time
(Closes: #752806)
2014-06-19 - KURASHIKI Satoru <lurdan@gmail.com>
qdbm (1.8.78-4) unstable; urgency=medium
* New Standards-Version: 3.9.5.
* update symbol file to fix ftbfs with gcc-4.9. (Closes: #746898)

See Also

Package Description
ruby-raabro_1.1.6-1_all.deb Very dumb PEG parser library
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
ruby-rabl_0.13.1-1_all.deb Ruby templating library with JSON, BSON, XML and MessagePack support
ruby-rack-accept_0.4.5-3_all.deb suite of tools for interpreting HTTP Accept family for Ruby/Rack
ruby-rack-attack_4.4.1-1_all.deb Block & throttle abusive requests
ruby-rack-cache_1.2-4_all.deb HTTP Caching for Rack
ruby-rack-cors_1.0.2-1_all.deb enable Cross-Origin Resource Sharing in Rack apps
ruby-rack-flash3_1.0.5-2_all.deb Flash hash for Ruby Rack applications
ruby-rack-google-analytics_1.2.0-2_all.deb Simple Rack middleware to inject the Google Analytics tracking code
ruby-rack-mobile-detect_0.4.0-4_all.deb rack middleware for ruby webapps to detect mobile devices
ruby-rack-mount_0.8.3-3_all.deb Stackable dynamic tree based Rack router
ruby-rack-oauth2_1.9.2-1_all.deb Rack interface for an OAuth 2.0
ruby-rack-openid_1.4.2-1_all.deb Ruby Rack library to provide access to OpenID
ruby-rack-piwik_0.3.0-2_all.deb piwik Analytics racking in your Ruby-Rack based project
ruby-rack-protection_2.0.5-4_all.deb Protects against typical web attacks for Rack apps
Advertisement
Advertisement