qtikz_0.12+ds1-3_i386.deb


Advertisement

Description

qtikz - editor for the TikZ drawing language - Qt version

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename qtikz_0.12+ds1-3_i386.deb
Package name qtikz
Package version 0.12+ds1
Package release 3
Package architecture i386
Package type deb
Category graphics implemented-in::c++ interface::graphical interface::x11 role::program science::publishing science::visualisation scope::application scope::utility uitoolkit::qt use::editing use::typesetting works-with-format::tex works-with::image works-with::image:vector works-with::text x11::application
Homepage https://github.com/fhackenberger/ktikz
License -
Maintainer Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Download size 754.52 KB
Installed size 1.68 MB
QtikZ is a small application to assist in the creation of diagrams and
drawings using the TikZ macros from the LaTeX package "pgf". It consists of
a text editor pane in which the TikZ code for the drawing is edited and a
preview pane showing the drawing as rendered by LaTeX. The preview pane can be
updated in real-time. Common drawing tools, options and styles are available
from the menus to assist the coding process.
This package contains the Qt version of the program.
TikZ is a user-friendly syntax layer for the PGF (portable graphics format)
TeX macro package. Pictures can be created within a LaTeX document and
included in the output using the most important TeX backend drivers including
pdftex and dvips.

Alternatives

Package Version Architecture Repository
qtikz_0.12+ds1-3_amd64.deb 0.12+ds1 amd64 Debian Main
qtikz - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libpoppler-qt5-1 >= 0.24.5
libqt5core5a >= 5.11.0~rc1
libqt5gui5 >= 5.8.0
libqt5printsupport5 >= 5.2.0
libqt5widgets5 >= 5.2.0
libstdc++6 >= 5
preview-latex-style -
texlive-pictures -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package qtikz_0.12+ds1-3_i386.deb
Source Package ktikz

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install qtikz deb package:
    # sudo apt-get install qtikz

Files

Path
/usr/bin/qtikz
/usr/lib/mime/packages/qtikz
/usr/share/applications/qtikz.desktop
/usr/share/doc/qtikz/changelog.Debian.gz
/usr/share/doc/qtikz/changelog.gz
/usr/share/doc/qtikz/copyright
/usr/share/man/man1/qtikz.1.gz
/usr/share/mime/packages/qtikz.xml
/usr/share/qtikz/qtikz-128.png
/usr/share/qtikz/documentation/qtikz.qch
/usr/share/qtikz/documentation/qtikz.qhc
/usr/share/qtikz/locale/qtikz_cs.qm
/usr/share/qtikz/locale/qtikz_de.qm
/usr/share/qtikz/locale/qtikz_es.qm
/usr/share/qtikz/locale/qtikz_fr.qm
/usr/share/qtikz/templates/beamer-example-template.pgs
/usr/share/qtikz/templates/template_example.pgs
/usr/share/qtikz/templates/template_example2.pgs

Changelog

2018-10-11 - Pino Toscano <pino@debian.org>
ktikz (0.12+ds1-3) unstable; urgency=medium
* Team upload.
* Do not install the upstream TODO file as documentation for ktikz,
as it is of no value for users.
* Install the examples for ktikz using dh_installexamples, not
dh_installdocs.
* Stop installing the xpm icons also for qtikz, as qtikz.desktop file
does not use them (and the menu file was removed long ago).
* Remove qtikz.dirs, as /usr/share/mime/packages/ is created automatically
on install.
* Remove debian/source/include-binaries, as it is obsolete.
* Bump Standards-Version to 4.2.1, no changes required.
* Update Vcs-* fields.
* Backport upstream commit bab16b2864888586c5d9044986e4891917addd08 to
install the appdata file; patch upstream_Install-appdata-file-1.patch
- remove ktikz.install, no more needed now
* Backport upstream commit 5018777fb62dd457f37aa8b25af7e1d0e00d26e3 to add
the proper placeholders in Exec keys of desktop files; patch
upstream_Add-F-placeholder-in-desktop-files.patch
- remove patch desktop-mime.patch, which is replaced by this upstream
change
* Remove empty line at the end of changelog.
* Backport upstream commit 3b137b2a4f12f74a6bc68f3a6ac093994cc418a0 to port
the documentation to DocBook 4.5; patch
upstream_Port-docbook-documentation.patch
- remove the libkf5kdelibs4support-dev build dependency, no more needed now
2018-04-07 - Pino Toscano <pino@debian.org>
ktikz (0.12+ds1-2) unstable; urgency=medium
* Team upload.
* Use the dh_auto_* commands to build the qmake version, specifying the build
directory, and the build system: this makes sure qmake is invoked with all
the needed options (like the envvars with the build flags), and that it
builds in a parallel way
- remove patches hardening-qtikz.patch, and qmake-noopt.patch, as they are
no more needed now
* Properly use the kf5 dh addon (instead of the kde one, for kdelibs 4.x)
for the KF5 build.
* Install the KF5 build directly in the ktikz package dir, so there is no
need to move all the files from debian/tmp.
* Link in as-needed mode.
* Stop installing the xpm icons for ktikz, as it has PNG icons in the hicolor
icon theme.
2018-03-12 - Stuart Prescott <stuart@debian.org>
ktikz (0.12+ds1-1) unstable; urgency=medium
* New upstream release supporting kf5 (no more Qt4/KDE4 components).
2018-02-28 - Stuart Prescott <stuart@debian.org>
ktikz (0.12~kf5~git20180116-1) experimental; urgency=medium
* New upstream git snapshot of the 'frameworks' branch.
- Drop qstring-ctor.patch applied upstream.
* Make the KDE Extras Team the maintainer.
* Add Vcs headers for salsa.debian.org.
2018-01-02 - Stuart Prescott <stuart@debian.org>
ktikz (0.12~kf5~git20180101-1) experimental; urgency=medium
* New upstream git snapshot of the 'frameworks' branch for KF5 support
(Closes: #874996, #883501).
* Add qstring-ctor.patch to permit compilation with QT_NO_CAST_FROM_ASCII.
* Update Standards-Version to 4.1.3 (no changes required).
* Update to debhelper 11.
2017-09-23 - Stuart Prescott <stuart@debian.org>
ktikz (0.11.ds1-1) unstable; urgency=medium
* New upstream release.
- drop patches applied upstream (cmake-defines, qreal-templates,
qt5-fromascii).
* Update Standards-Version to 4.1.0 (no changes required).
* Drop obsolete mimelnk file (Closes: #875515).
* Allow creation of a qtikz-dbgsym package.
* Optimistically switch watch file back to looking at releases.
2017-06-20 - Stuart Prescott <stuart@debian.org>
ktikz (0.11~git20161122-2) unstable; urgency=medium
* change dependency on pgf to texlive-pictures to match new texlive
packaging, thanks to Norbert Preining for the heads-up (Closes: #863684).
* Bump standards-version to 4.0.0 (no changes required).

See Also

Package Description
qtiplot-doc_0.9.8.9-18_all.deb data analysis and scientific plotting (documentation)
qtiplot_0.9.8.9-18_i386.deb data analysis and scientific plotting
qtlocation5-dev_5.11.3+dfsg-2_i386.deb Qt 5 Location development files
qtlocation5-doc-html_5.11.3+dfsg-2_all.deb Qt 5 Positioning HTML documentation
qtlocation5-doc_5.11.3+dfsg-2_all.deb Qt 5 Positioning documentation
qtlocation5-examples_5.11.3+dfsg-2_i386.deb Qt 5 Location and Positioning examples
qtltools-example_1.1+dfsg-3_all.deb Tool set for molecular QTL discovery and analysis - example
qtm_1.3.18-1_i386.deb Web-log interface program
qtmultimedia5-dev_5.11.3-2_i386.deb APIs for multimedia functionality - development files
qtmultimedia5-doc-html_5.11.3-2_all.deb Qt 5 multimedia HTML documentation
qtmultimedia5-doc_5.11.3-2_all.deb Qt 5 multimedia documentation
qtmultimedia5-examples_5.11.3-2_i386.deb Examples for Qt 5 Multimedia module
qtnetworkauth5-doc-html_5.11.3-2_all.deb online account access for Qt apps - HTML Documentation
qtnetworkauth5-doc_5.11.3-2_all.deb online account access for Qt apps - documentation
qtnetworkauth5-examples_5.11.3-2_i386.deb online account access for Qt apps - Examples
Advertisement
Advertisement