qemu-skiboot_6.2-1_all.deb


Advertisement

Description

qemu-skiboot - OpenPower firmware component

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename qemu-skiboot_6.2-1_all.deb
Package name qemu-skiboot
Package version 6.2
Package release 1
Package architecture all
Package type deb
Category admin
Homepage https://github.com/open-power/skiboot/
License -
Maintainer Frédéric Bonnard <frediz@debian.org>
Download size 408.45 KB
Installed size 1.55 MB
This package provides the upstream skiboot binary suitable for using with the
powernv Qemu machine.
It is not recommended to flash this binary as your system firmware.

Alternatives

Package Version Architecture Repository
qemu-skiboot_6.2-1_all.deb 6.2 all Debian Main
qemu-skiboot - - -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package qemu-skiboot_6.2-1_all.deb
Source Package skiboot

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install qemu-skiboot deb package:
    # sudo apt-get install qemu-skiboot

Files

Path
/usr/share/doc/qemu-skiboot/README.Debian
/usr/share/doc/qemu-skiboot/README.md.gz
/usr/share/doc/qemu-skiboot/changelog.Debian.gz
/usr/share/doc/qemu-skiboot/copyright
/usr/share/skiboot/skiboot.lid

Changelog

2019-01-11 - Frédéric Bonnard <frediz@debian.org>
skiboot (6.2-1) unstable; urgency=medium
* New upstream release 6.2
* Upgrade compat level
* Add Multi-Arch hinter
* Bump Standards-Version
2018-11-22 - Frédéric Bonnard <frediz@debian.org>
skiboot (6.1-4) unstable; urgency=medium
* Use file operation used on x86 for ARCH_UNKNOWN
2018-11-16 - Frédéric Bonnard <frediz@debian.org>
skiboot (6.1-3) unstable; urgency=medium
[ Ondřej Nový ]
* d/changelog: Remove trailing whitespaces
[ Frédéric Bonnard ]
* Use default m32 or m64 gcc flag for xscom-utils
* Build opal-utils on any architecture
* Define new package qemu-skiboot to provide skiboot firmware
* Bump Standards-Version (no change needed)
2018-08-02 - Frédéric Bonnard <frediz@debian.org>
skiboot (6.1-2) unstable; urgency=medium
* Fix wrong owner after log is being rotated (Closes: LP: #1785026)
2018-07-30 - Frédéric Bonnard <frediz@debian.org>
skiboot (6.1-1) unstable; urgency=medium
* New upstream release
* Improve formatting with wrap-and-sort
* Set proper debhelper Build-Depends
* Bump Standards-Version
2018-04-24 - Frédéric Bonnard <frediz@debian.org>
skiboot (5.10~rc4-2) unstable; urgency=medium
* Fix opal-prd spinning and consuming 100% CPU
2018-02-22 - Frédéric Bonnard <frediz@debian.org>
skiboot (5.10~rc4-1) unstable; urgency=medium
* New upstream version 5.10~rc4 (Closes: LP: #1744710)
* Improve watch file
* Add gbp configuration locally
* Rediff patches
* Update maintainer information
* Use https instead of https where available
* Add Vcs-* URI on salsa.debian.org
* Remove default PNOR device since autodetected now
* Remove upstart support
* Install man pages from the source
* Add getsram utility in the package (Closes: #874386)
* Avoid running tests on unsupported platforms
* Make use of Debian provided DEB_VERSION_UPSTREAM
* Improve logging support
* Bump Standards-Version (upstart support dropped)
* Bump compatibility level to 11 (dh systemd addon removed)
2017-03-08 - Frederic Bonnard <frediz@linux.vnet.ibm.com>
skiboot (5.4.3-1) unstable; urgency=medium
* New upstream release
* d/patches/fix-hardening-for-opal-gard.patch removed as it's applied upstream
* d/control :
- added Depends on lsb-base for opal-prd.init
- added ppc64 arch
* d/rules :
- proper clean is almost done by upstream, override_dh_auto_clean stripped
- enabled tests where they make sense
* d/patches/fix-distclean-for-gard-and-xscom-utils.patch : remaining cleanup
to be forwarded upstream
* d/opal-prd.socket : removed
d/opal-prd.service : linked to upstream service file
we now use service file from upstream that doesn't use systemd's socket
: opal-prd already does all the socket handling.
* d/patches/opal-prd-service-file-improvements.patch : added to handle man
page and /etc/default/opal-prd properly (Closes: LP : #1549098)
* Use upstream manpage :
d/opal-prd.8 : fixes were applied upstream
d/opal-prd.manpages : use upstream manpage
* d/patches/direct-systemd-to-always-restart-opal-prd.patch : applying
upstream patch in advance to restart opal-prd irrespective of why it
stopped.  (Closes: LP : #1671019)
2016-09-06 - Frederic Bonnard <frediz@linux.vnet.ibm.com>
skiboot (5.3.3-1) unstable; urgency=medium
* New upstream release
* Build and distribute getscom, putscom, pflash. Created basic manpages
(Closes: #836405))
* Changed d/opal-prd.docs, d/opal-utils.docs because README got renamed to
README
2016-07-18 - Frederic Bonnard <frediz@linux.vnet.ibm.com>
skiboot (5.2.4-2) unstable; urgency=medium
* Forced no-pie for Ubuntu 16.10 as previous change was not enough : in 16.10
gcc's default change to build PIE by default.

See Also

Package Description
qemu-slof_20180702+dfsg-1_all.deb Slimline Open Firmware -- QEMU PowerPC version
qemu-system-arm_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (arm)
qemu-system-common_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (common files)
qemu-system-data_3.1+dfsg-8+deb10u2_all.deb QEMU full system emulation (data files)
qemu-system-gui_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (user interface and audio support)
qemu-system-mips_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (mips)
qemu-system-misc_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (miscellaneous)
qemu-system-ppc_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (ppc)
qemu-system-sparc_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (sparc)
qemu-system-x86_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries (x86)
qemu-system_3.1+dfsg-8+deb10u2_i386.deb QEMU full system emulation binaries
qemu-user-binfmt_3.1+dfsg-8+deb10u2_i386.deb QEMU user mode binfmt registration for qemu-user
qemu-user-static_3.1+dfsg-8+deb10u2_i386.deb QEMU user mode emulation binaries (static version)
qemu-user_3.1+dfsg-8+deb10u2_i386.deb QEMU user mode emulation binaries
qemu-utils_3.1+dfsg-8+deb10u2_i386.deb QEMU utilities
Advertisement
Advertisement