python3-pyverbs_22.1-1_i386.deb


Advertisement

Description

python3-pyverbs - Pyverbs is a Python bindings for rdma-core

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename python3-pyverbs_22.1-1_i386.deb
Package name python3-pyverbs
Package version 22.1
Package release 1
Package architecture i386
Package type deb
Category python
Homepage https://github.com/linux-rdma/rdma-core
License -
Maintainer Benjamin Drung <benjamin.drung@cloud.ionos.com>
Download size 129.21 KB
Installed size 832.00 KB
It allows an easy development in Python language of RDMA applications.

Alternatives

Package Version Architecture Repository
python3-pyverbs_22.1-1_amd64.deb 22.1 amd64 Debian Main
python3-pyverbs - - -

Requires

Name Value
libc6 >= 2.4
libibverbs1 >= 1.1.6
libpython3.7 >= 3.7.0
python3 >= 3.7~
python3 << 3.8
python3:any -
rdma-core >= 21

Provides

Name Value
python3.7-pyverbs -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-pyverbs_22.1-1_i386.deb
Source Package rdma-core

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-pyverbs deb package:
    # sudo apt-get install python3-pyverbs

Files

Path
/usr/lib/python3/dist-packages/pyverbs/__init__.py
/usr/lib/python3/dist-packages/pyverbs/addr.cpython-37m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/pyverbs/base.cpython-37m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/pyverbs/device.cpython-37m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/pyverbs/enums.cpython-37m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/pyverbs/pyverbs_error.py
/usr/lib/python3/dist-packages/pyverbs/run_tests.py
/usr/lib/python3/dist-packages/pyverbs/tests/__init__.py
/usr/lib/python3/dist-packages/pyverbs/tests/device.py
/usr/share/doc/python3-pyverbs/changelog.Debian.gz
/usr/share/doc/python3-pyverbs/copyright
/usr/share/doc/python3-pyverbs/examples/ib_devices.py

Changelog

2019-02-06 - Benjamin Drung <benjamin.drung@cloud.ionos.com>
rdma-core (22.1-1) unstable; urgency=medium
* New upstream bugfix release.
2019-01-22 - Benjamin Drung <benjamin.drung@cloud.ionos.com>
rdma-core (22.0-1) unstable; urgency=medium
* New upstream release.
- mlx5: Add DEVX APIs for interop with verbs objects
- Add pyverbs Python binding
* Update private libibverbs symbols
* Bump Standards-Version to 4.3.0 (no changes required)
2018-11-20 - Benjamin Drung <benjamin.drung@cloud.ionos.com>
rdma-core (21.0-1) unstable; urgency=medium
* New upstream release.
- Drop ibacm sysV init script to avoid issues with the sysV to systemd
wrapper starting the service instead of the socket (LP: #1794825)
- Include static libraries in the build
* Update private libibverbs symbols
* Specify Build-Depends-Package in symbols
2018-09-10 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (20.0-1) unstable; urgency=medium
* New upstream release.
- Switch from net-tools to iproute2 for rxe_cfg
- Install pkg-config files
* Update libibverbs symbols and let libibverbs1 break ibverbs-providers < 20~
* Drop all patches (accepted upstream)
* Bump Standards-Version to 4.2.1 (no changes needed)
2018-06-28 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (19.0-1) unstable; urgency=medium
* New upstream release.
* Switch to debhelper 11
* Add patch to fix bad whatis entries in man pages
2018-06-12 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (18.1-1) unstable; urgency=medium
* New upstream bugfix release.
* Drop all patches (applied upstream)
2018-05-07 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (18.0-1) unstable; urgency=medium
* New upstream release.
* Update private libibverbs symbols and let libibverbs1 break
ibverbs-providers < 18~
* Fix bad whatis entries in man pages
* Fix spelling mistakes in ibv_create_flow_action.3 man page
* Use versioned Breaks & Replaces for ibverbs-providers to make it
multi-arch coinstallable (Closes: #898055)
2018-04-30 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (17.1-2) unstable; urgency=medium
* Support for new architecture riscv64 (Closes: #894995) by
- Whitelist (instead of blacklist) architectures that support valgrind
- Whitelist (instead of blacklist) coherent DMA supporting architectures
* Bump Standards-Version to 4.1.4 (no changes needed)
2018-03-19 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (17.1-1) unstable; urgency=medium
* New upstream bugfix release.
2018-02-19 - Benjamin Drung <benjamin.drung@profitbricks.com>
rdma-core (17.0-1) unstable; urgency=medium
* New upstream release
- Remove the obsolete libibcm library
* Update private libibverbs symbols and let libibverbs1 break
ibverbs-providers < 17~
* Update copyright for kernel-headers directory

See Also

Package Description
python3-pyvirtualdisplay_0.2.1-2_all.deb python wrapper for Xvfb, Xephyr and Xvnc
python3-pyvisa-py_0.3.1-2_all.deb Backend that implements a large part of the VISA in pure Python 3
python3-pyvisa_1.9.1-1_all.deb Python 3 bindings for Virtual Instrument Software Architecture
python3-pyvmomi_6.7.1-2_all.deb VMware vSphere Python SDK - Python 3.x
python3-pyvo_0.9.2-2_all.deb Python 3 library for data services of the Virtual observatory (VO)
python3-pywt_0.5.1-1.1+b3_i386.deb Python3 extension implementing of wavelet transformations
python3-pywws_18.10.1-1_all.deb software for wireless weather stations
python3-pyx-doc_0.14.1-9_all.deb Python 3 module for generating PostScript graphics (documentation)
python3-pyx_0.14.1-9_i386.deb Python 3 module for generating PostScript graphics
python3-pyxattr_0.6.1-1_i386.deb module for manipulating filesystem extended attributes (Python3)
python3-pyxb-bundles-common_1.2.6+dfsg-2_all.deb Python XML Schema Bindings (common bindings for Python3)
python3-pyxb-bundles-dc_1.2.6+dfsg-2_all.deb Python XML Schema Bindings (Dublin Core bindings for Python3)
python3-pyxb-bundles-saml20_1.2.6+dfsg-2_all.deb Python XML Schema Bindings (SAML bindings for Python3)
python3-pyxb-bundles-wssplat_1.2.6+dfsg-2_all.deb Python XML Schema Bindings (WS-* bindings for Python3)
python3-pyxb_1.2.6+dfsg-2_all.deb Python XML Schema Bindings (Python3 version)
Advertisement
Advertisement