python3-pythonmagick_0.9.19-4_i386.deb


Advertisement

Description

python3-pythonmagick - Object-oriented Python 3 interface to ImageMagick

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename python3-pythonmagick_0.9.19-4_i386.deb
Package name python3-pythonmagick
Package version 0.9.19
Package release 4
Package architecture i386
Package type deb
Category python
Homepage http://www.imagemagick.org
License -
Maintainer Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Download size 365.17 KB
Installed size 2.61 MB
PythonMagick an interface to ImageMagick to give all the functionality
of ImageMagick++ into Python 3.
ImageMagick is a software suite to create, edit, and compose bitmap images.
It can read, convert and write images in a variety of formats (over 100)
including DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript,
SVG, and TIFF. Use ImageMagick to translate, flip, mirror, rotate, scale,
shear and transform images, adjust image colors, apply various special
effects, or draw text, lines, polygons, ellipses and Bézier curves.
All manipulations can be achieved through shell commands as well as through
an X11 graphical interface (display).

Alternatives

Package Version Architecture Repository
python3-pythonmagick_0.9.19-4_amd64.deb 0.9.19 amd64 Debian Main
python3-pythonmagick - - -

Requires

Name Value
libboost-python1.67.0 -
libc6 >= 2.4
libgcc1 >= 1:3.0
libgomp1 >= 4.2.1
libmagick++-6.q16-8 -
libmagickcore-6.q16-6 >= 8:6.9.10.2
libmagickwand-6.q16-6 >= 8:6.9.10.2
libstdc++6 >= 5.2
python3 >= 3.7~
python3 << 3.8
python3:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-pythonmagick_0.9.19-4_i386.deb
Source Package pythonmagick

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-pythonmagick deb package:
    # sudo apt-get install python3-pythonmagick

Files

Path
/usr/lib/python3/dist-packages/PythonMagick/_PythonMagick.cpython-37m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/PythonMagick/__init__.py
/usr/share/doc/python3-pythonmagick/changelog.Debian.gz
/usr/share/doc/python3-pythonmagick/changelog.gz
/usr/share/doc/python3-pythonmagick/copyright

Changelog

2019-05-01 - Jochen Sprickerhof <jspricke@debian.org>
pythonmagick (0.9.19-4) unstable; urgency=medium
* Team upload.
* Fix autopkgtests
2019-05-01 - Jochen Sprickerhof <jspricke@debian.org>
pythonmagick (0.9.19-3) unstable; urgency=medium
* Team upload.
* Disable failing autopkgtest
* Add patch for ImageMagick < 7
2019-01-22 - Bastien Roucariès <rouca@debian.org>
pythonmagick (0.9.19-2) unstable; urgency=medium
* Fix debci
2019-01-20 - Bastien Roucariès <rouca@debian.org>
pythonmagick (0.9.19-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
* d/control: Deprecating priority extra as per policy 4.0.1
* d/changelog: Remove trailing whitespaces
* Convert git repository from git-dpm to gbp layout
[ Bastien Roucariès ]
* Bug fix by rebuilt: "Undefined symbol in python2.7
PythonMagick.x86_64-linux-gnu.so", thanks to Dave Williams
(Closes: #875610).
* Bug fix: "remove hack that prevents building C extension for all
supported versions of python", thanks to Michael Hudson-Doyle
(Closes: #905261).
2017-08-13 - Bastien Roucariès <rouca@debian.org>
pythonmagick (0.9.17-1) unstable; urgency=medium
* Bug fix: "FTBFS with python3.6 as a supported python3", thanks to
Scott Kitterman (Closes: #866694).
* Use lastest autoconf-archive for some python macros.
* Bump policy (no changes)
2016-11-13 - Bastien Roucariès <roucaries.bastien+debian@gmail.com>
pythonmagick (0.9.14-3) unstable; urgency=medium
* Remove obsolete m4 files that lead to FTBFS. This files will be
regenerated from autoconf-archive by dh_autoreconf.
(Closes: #843196).
2016-11-01 - Bastien Roucariès <roucaries.bastien+debian@gmail.com>
pythonmagick (0.9.14-2) unstable; urgency=medium
* Update copyright
2016-10-30 - Bastien Roucariès <roucaries.bastien+debian@gmail.com>
pythonmagick (0.9.14-1) unstable; urgency=medium
* Switch watch to .xz and add signature check
* Add myself as uploader.
* Switch to git-dpm.
* Bump Standards-Version no changes.
* Bump compat to 10.
* Fixed VCS URL (https) thanks to Ondřej Nový <novy@ondrej.org>
* Build python3 and python2 version.
* Add autopkgtest
* New upstream release:
- Bug fix: "FTBFS with newer experimental version of imagemagick",
(Closes: #840428).
2014-10-03 - Sebastian Ramacher <sramacher@debian.org>
pythonmagick (0.9.11-2) unstable; urgency=medium
* Team upload.
* debian/rules: Do not build static library. (Closes: #763716)
* debian/copyright: Add short license names.
* debian/control: Update Standards-Verison. No changes required.
2014-09-07 - Sebastian Ramacher <sramacher@debian.org>
pythonmagick (0.9.11-1) unstable; urgency=medium
* Team upload.
* New upstream release.
- Fix build with newer imagemagick releases. (Closes: #758001)
* debian/patches:
- 003_detect_py27.diff: Removed, no longer needed.
- 001_autofoo_fixes.diff: Refreshed.
* debian/{rules,control,source/format}: Use 3.0 (quilt) and remove quilt
from build depends and dh call.
* debian({rules,control}: Switch to dh_python2. Replace python-support with
dh-python in Build-Depends and invoke dh with --with python2 instead of
python-support.
* debian/control:
- Bump libmagic++-dev to >= 8:6.8.6. Required by the new upstream version.
- Bump Standards-Version to 3.9.5. No changes required.
* debian/rules:
- Build with --disable-silent-rules.
- Build with --parallel.
- Remove *.la files.
* debian/copyright: Update copyright years.

See Also

Package Description
python3-pytimeparse_1.1.5-2_all.deb time expression parser - Python 3.x
python3-pytoml_0.1.2-1_all.deb TOML parser and emitter for Python3
python3-pytools_2019.1-1_all.deb big bag of things supplementing Python 3 standard library
python3-pyuca_1.2-1_all.deb Unicode Collation Algorithm (UCA) for Python3
python3-pyudev_0.21.0-1_all.deb Python3 bindings for libudev
python3-pyvcf_0.6.8+git20170215.476169c-1_i386.deb Variant Call Format (VCF) parser for Python 3
python3-pyverbs_22.1-1_i386.deb Pyverbs is a Python bindings for rdma-core
python3-pyvirtualdisplay_0.2.1-2_all.deb python wrapper for Xvfb, Xephyr and Xvnc
python3-pyvisa-py_0.3.1-2_all.deb Backend that implements a large part of the VISA in pure Python 3
python3-pyvisa_1.9.1-1_all.deb Python 3 bindings for Virtual Instrument Software Architecture
python3-pyvmomi_6.7.1-2_all.deb VMware vSphere Python SDK - Python 3.x
python3-pyvo_0.9.2-2_all.deb Python 3 library for data services of the Virtual observatory (VO)
python3-pywt_0.5.1-1.1+b3_i386.deb Python3 extension implementing of wavelet transformations
python3-pywws_18.10.1-1_all.deb software for wireless weather stations
python3-pyx-doc_0.14.1-9_all.deb Python 3 module for generating PostScript graphics (documentation)
Advertisement
Advertisement