python-slimit_0.8.1-3_all.deb


Advertisement

Description

python-slimit - JavaScript minifier/parser in Python

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename python-slimit_0.8.1-3_all.deb
Package name python-slimit
Package version 0.8.1
Package release 3
Package architecture all
Package type deb
Category python
Homepage http://slimit.readthedocs.io/en/latest/
License -
Maintainer Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Download size 50.79 KB
Installed size 421.00 KB
SlimIt is a JavaScript minifier written in Python. It compiles JavaScript
into more compact code so that it downloads and runs faster.
SlimIt also provides a library that includes a JavaScript parser, lexer,
pretty printer and a tree visitor.
This package contains the Python 2 module

Alternatives

Package Version Architecture Repository
python-slimit_0.8.1-3_all.deb 0.8.1 all Debian Main
python-slimit - - -

Requires

Name Value
python-pkg-resources -
python-ply -
python:any << 2.8
python:any >= 2.7.5-5~

Replaces

Name Value
slimit << 0.8.1-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-slimit_0.8.1-3_all.deb
Source Package slimit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-slimit deb package:
    # sudo apt-get install python-slimit

Files

Path
/usr/lib/python2.7/dist-packages/slimit/__init__.py
/usr/lib/python2.7/dist-packages/slimit/ast.py
/usr/lib/python2.7/dist-packages/slimit/lexer.py
/usr/lib/python2.7/dist-packages/slimit/lextab.py
/usr/lib/python2.7/dist-packages/slimit/mangler.py
/usr/lib/python2.7/dist-packages/slimit/minifier.py
/usr/lib/python2.7/dist-packages/slimit/parser.py
/usr/lib/python2.7/dist-packages/slimit/scope.py
/usr/lib/python2.7/dist-packages/slimit/unicode_chars.py
/usr/lib/python2.7/dist-packages/slimit/yacctab.py
/usr/lib/python2.7/dist-packages/slimit-0.8.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/slimit-0.8.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/slimit-0.8.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/slimit-0.8.1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/slimit-0.8.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/slimit-0.8.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/slimit/tests/__init__.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_cmd.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_ecmavisitor.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_lexer.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_mangler.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_minifier.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_nodevisitor.py
/usr/lib/python2.7/dist-packages/slimit/tests/test_parser.py
/usr/lib/python2.7/dist-packages/slimit/visitors/__init__.py
/usr/lib/python2.7/dist-packages/slimit/visitors/ecmavisitor.py
/usr/lib/python2.7/dist-packages/slimit/visitors/minvisitor.py
/usr/lib/python2.7/dist-packages/slimit/visitors/nodevisitor.py
/usr/lib/python2.7/dist-packages/slimit/visitors/scopevisitor.py
/usr/share/doc/python-slimit/changelog.Debian.gz
/usr/share/doc/python-slimit/changelog.gz
/usr/share/doc/python-slimit/copyright

Changelog

2017-02-21 - Brian May <bam@debian.org>
slimit (0.8.1-3) unstable; urgency=medium
* Team upload.
* Add breaks/replaces headers. Closes: #855510.
2017-02-03 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.8.1-2) unstable; urgency=medium
* debian/control: Update homepage URL. (Closes: #740807)
* Split into python-slimit and python3-slimit. (Closes: #779321)
* Bump Standards-Version 3.9.8
* debian/control: Update Vcs-*. 
2013-05-08 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.8.1-1) unstable; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ TANIGUCHI Takaki ]
* debian/watch: Update to new github source archive URL.
* New upstream release
+ Drop debian/patches/drop_depend_odict. upstream does not require.
2012-06-10 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.7.4-1) unstable; urgency=low
* New upstream release
2012-05-22 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.7.3-1) unstable; urgency=low
* New upstream release
2012-05-21 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.7.2-1) unstable; urgency=low
* New upstream release
2012-05-16 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.7.1-1) unstable; urgency=low
* New upstream release
* debian/control: Add python-pkg-resources to Depends.(Closes: #672915)
2012-04-19 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.7-1) unstable; urgency=low
* New upstream release
2012-04-09 - TANIGUCHI Takaki <takaki@debian.org>
slimit (0.6.2-1) unstable; urgency=low
* Initial release (Closes: #662756)

See Also

Package Description
python-slimmer_0.1.30-7_all.deb HTML, XHTML, CSS, JavaScript optimizer for Python2
python-slixmpp-doc_1.4.2-1_all.deb Threadless, event-based XMPP Python library (documentation)
python-slowaes_0.1a1-2_all.deb implementation of AES in Python
python-slugify_2.0.1-1_all.deb Python module that provides tools for slugifying unicode strings
python-smartpm_1.4-2_i386.deb Python library of the Smart Package Manager
python-smartypants_2.0.0-1_all.deb smart-quotes plugin for pyblosxom
python-smbc_1.0.15.6-1+b2_i386.deb Python 2 bindings for the Samba client library
python-smbpasswd_1.0.1-1.3_i386.deb This module can generate both LANMAN and NT password hashes
python-smbus_4.1-1_i386.deb Python bindings for Linux SMBus access through i2c-dev
python-smclib_1.8.3-1+b1_i386.deb Robot OS 'bond' State Machine Compiler Python 2 package
python-smmap_2.0.5-1_all.deb pure Python implementation of a sliding window memory map manager
python-smoke-zephyr_1.4.1-1_all.deb Python utility collection
python-smstrade-doc_0.2.4-5_all.deb Python library to send SMS via the smstrade service (documentation)
python-smstrade_0.2.4-5_all.deb Python library to send SMS via the smstrade service (Python 2)
python-snappy_0.5.3-1_i386.deb snappy compression library from Google - Python 2.7
Advertisement
Advertisement