python-modestmaps_1.4.7-3_all.deb


Advertisement

Description

python-modestmaps - display and interaction library for tile-based maps

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename python-modestmaps_1.4.7-3_all.deb
Package name python-modestmaps
Package version 1.4.7
Package release 3
Package architecture all
Package type deb
Category devel::lang:python devel::library implemented-in::python python role::devel-lib
Homepage https://github.com/stamen/modestmaps-py
License -
Maintainer Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Download size 13.11 KB
Installed size 69.00 KB
Modest Maps is a display and interaction library for tile-based maps
in Flash (Actionscript 2.0 and Actionscript 3.0), Javascript and Python.
Its intent is to provide a minimal, extensible, customizable, and free
display library for designers and developers who want to use interactive
maps in their own projects. Modest Maps provides a core set of features
in a tight, clean package, with hooks for additional functionality.
This package contains the Python module.

Alternatives

Package Version Architecture Repository
python-modestmaps_1.4.7-3_all.deb 1.4.7 all Debian Main
python-modestmaps - - -

Requires

Name Value
python-pil -
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-modestmaps_1.4.7-3_all.deb
Source Package modestmaps-py

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-modestmaps deb package:
    # sudo apt-get install python-modestmaps

Files

Path
/usr/lib/python2.7/dist-packages/ModestMaps-1.4.7.egg-info
/usr/lib/python2.7/dist-packages/ModestMaps/BlueMarble.py
/usr/lib/python2.7/dist-packages/ModestMaps/CloudMade.py
/usr/lib/python2.7/dist-packages/ModestMaps/Core.py
/usr/lib/python2.7/dist-packages/ModestMaps/Geo.py
/usr/lib/python2.7/dist-packages/ModestMaps/MapQuest.py
/usr/lib/python2.7/dist-packages/ModestMaps/Microsoft.py
/usr/lib/python2.7/dist-packages/ModestMaps/OpenStreetMap.py
/usr/lib/python2.7/dist-packages/ModestMaps/Providers.py
/usr/lib/python2.7/dist-packages/ModestMaps/Stamen.py
/usr/lib/python2.7/dist-packages/ModestMaps/Tiles.py
/usr/lib/python2.7/dist-packages/ModestMaps/VERSION
/usr/lib/python2.7/dist-packages/ModestMaps/Yahoo.py
/usr/lib/python2.7/dist-packages/ModestMaps/__init__.py
/usr/share/doc/python-modestmaps/changelog.Debian.gz
/usr/share/doc/python-modestmaps/copyright

Changelog

2018-08-01 - Bas Couwenberg <sebastic@debian.org>
modestmaps-py (1.4.7-3) unstable; urgency=medium
* Team upload.
* Drop autopkgtest to test installability.
* Add lintian override for testsuite-autopkgtest-missing.
2018-07-29 - Bas Couwenberg <sebastic@debian.org>
modestmaps-py (1.4.7-2) unstable; urgency=medium
* Team upload.
* Change priority from extra to optional.
* Bump Standards-Version to 4.1.5, changes: priority.
* Update copyright-format URL to use HTTPS.
* Update Vcs-* URLs for Salsa.
* Change Source URL to pypi.debian.net.
* Update watch file to use HTTPS.
* Strip trailing whitespace from control & rules files.
* Add lintian override for python-foo-but-no-python3-foo.
* Add autopkgtest to test installability.
2016-12-28 - Bas Couwenberg <sebastic@debian.org>
modestmaps-py (1.4.7-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update Vcs-* URLs to use HTTPS.
* Bump Standards-Version to 3.9.8, no changes.
2015-08-16 - Bas Couwenberg <sebastic@debian.org>
modestmaps-py (1.4.6-1) unstable; urgency=medium
* Team upload.
* Fix Vcs-* URLs, use anonscm.d.o & modestmaps-py.git.
* Restructure control file with cme.
* Change Homepage from code.google.com to GitHub.
* Update watch file to use pypi.debian.net instead of modestmaps.com.
* Add gbp.conf to use pristine-tar by default.
* New upstream release.
* Update copyright file using copyright-format 1.0.
* Bump debhelper compatibility to 9.
* Add build dependency on dh-python.
* Use pybuild buildsystem.
* Bump Standards-Version to 3.9.6, changes:
- canonical Vcs-* URLs
- copyright-format 1.0
2011-12-29 - David Paleino <dapal@debian.org>
modestmaps-py (1.3.1-1) unstable; urgency=low
* New upstream version
2011-09-13 - David Paleino <dapal@debian.org>
modestmaps-py (1.2.1-1) unstable; urgency=low
* New upstream version
* Standards-Version bumped to 3.9.2, no changes needed
* Package switch from pysupport to dh_python2
2011-02-14 - David Paleino <dapal@debian.org>
modestmaps-py (1.1.0-1) unstable; urgency=low
* New upstream version
2010-11-10 - David Paleino <dapal@debian.org>
modestmaps-py (1.0.1-1) unstable; urgency=low
* Initial release (Closes: #603047)

See Also

Package Description
python-moinmoin_1.9.9-1+deb9u1_all.deb Python clone of WikiWiki - library
python-moksha.common_1.2.5-3_all.deb Common components for the Moksha framework (Python 2)
python-moksha.hub_1.4.1-2_all.deb Hub components for the Moksha framework
python-monasca-statsd_1.7.0-1_all.deb monasca statsd API client - Python 2.7
python-monascaclient_1.12.1-2_all.deb client bindings for the Monasca API - Python 2.7
python-moneyed_0.8.0-1_all.deb Currency and Money classes for use in Python 2 code
python-mongoengine-doc_0.15.3-1_all.deb Python Document-Object Mapper for working with MongoDB (documentation)
python-mongoengine_0.15.3-1_all.deb Python Document-Object Mapper for working with MongoDB
python-monotonic_1.1-2_all.deb implementation of time.monotonic() - Python 2.x
python-more-itertools_4.2.0-1_all.deb library with for operating on iterables, beyond itertools (Python 2)
python-morris-doc_1.2-1_all.deb documentation for the Python morris module
python-morris_1.2-1_all.deb announcement (signal/event) system for Python 2
python-motor_2.0.0-2_all.deb full-featured, non-blocking MongoDB driver - Python 2.x
python-move-base-msgs_1.13.0-8_all.deb Python 2 code for move-base-related ROS Messages,
python-mox3_0.24.0-1_all.deb Mock object framework - Python 2.7
Advertisement
Advertisement