python-libproxy_0.4.15-5_all.deb


Advertisement

Description

python-libproxy - automatic proxy configuration management library (Python 2)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename python-libproxy_0.4.15-5_all.deb
Package name python-libproxy
Package version 0.4.15
Package release 5
Package architecture all
Package type deb
Category network::configuration python role::program
Homepage https://libproxy.github.io/libproxy/
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 12.79 KB
Installed size 29.00 KB
libproxy is a lightweight library which makes it easy to develop
applications proxy-aware with a simple and stable API.
This package contains the Python 2 bindings.

Alternatives

Package Version Architecture Repository
python-libproxy_0.4.15-5_all.deb 0.4.15 all Debian Main
python-libproxy - - -

Requires

Name Value
libproxy1v5 >= 0.4.15-5
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-libproxy_0.4.15-5_all.deb
Source Package libproxy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-libproxy deb package:
    # sudo apt-get install python-libproxy

Files

Path
/usr/lib/python2.7/dist-packages/libproxy.py
/usr/share/doc/python-libproxy/changelog.Debian.gz
/usr/share/doc/python-libproxy/changelog.gz
/usr/share/doc/python-libproxy/copyright

Changelog

2018-12-28 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-5) unstable; urgency=medium
* Add -Wl,-O1 to our LDFLAGS
* Bump Standards-Version to 4.3.0
2018-12-24 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.15-4) unstable; urgency=medium
* Build the mozjs plugin against mozjs 60 and limit the architectures where
the package is built as mozjs 60 FTBFS on several architectures (Closes:
#912940)
2018-10-06 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.15-3) unstable; urgency=medium
* Reintroduce libproxy1-plugin-mozjs, the module now builds with mozjs 52
* debian/control.in: Drop X-Python(3)-Version to please lintian
* debian/control.in: Bump Standards-Version to 4.2.1 (no further changes)
* debian/rules: Use DEB_VERSION_UPSTREAM instead of SHLIBVER for the helpers
2018-09-19 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-2) unstable; urgency=medium
[ Helmut Grohne ]
* Demote python Build-Depends to Build-Depends-Indep (Closes: #909211)
2018-03-28 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-1) unstable; urgency=medium
* New upstream release
* Update Vcs fields for migration to https://salsa.debian.org/
* Drop libproxy1-plugin-mozjs since it depends on an outdated version
of mozjs. Use libproxy1-plugin-webkit instead. (Closes: #863783)
* Drop fix-clean-reload-cache.patch: Applied in new release
2017-12-18 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.14-4) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Update Maintainer
* Bump debhelper compat to 11
* Bump Standards-Version to 4.1.2
2017-05-27 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.14-3) unstable; urgency=medium
[ Alexander Volkov ]
* Don't build depend on libkf5config-bin on stage1 (Closes: #847365)
2017-02-08 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.14-2) unstable; urgency=medium
* debian/patches/fix-clean-reload-cache.patch: Make sure that the PAC/WPAD
cache is cleanup when network topology changes and prevent a segfault in
the process, patches merged upstream.
2017-01-22 - Michael Biebl <biebl@debian.org>
libproxy (0.4.14-1) unstable; urgency=medium
* New upstream release.
* Switch Build-Depends from network-manager-dev to the newer libnm-dev.
While the code has a fallback for the older header files, the new ones
provided by libnm are preferred by upstream.
* Use DEB_LDFLAGS_MAINT_APPEND to pass additional flags to the linker.
* Bump SHVER to 0.4.14.
2016-11-20 - Andrey Rahmatullin <wrar@debian.org>
libproxy (0.4.13-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS (Closes: #844956).

See Also

Package Description
python-libqcow_20181227-1_i386.deb QEMU Copy-On-Write image format access library -- Python 2 bindings
python-libravatar_1.7-5_all.deb Libravatar module for Python 2
python-librdf_1.0.17.1+dfsg-1.3+b6_i386.deb Python language bindings for the Redland RDF library
python-libregf_20181231-1_i386.deb Windows NT Registry File (REGF) format access library -- Python 2 bindings
python-librtmp_0.3.0-1+b3_i386.deb librtmp binding for Python 2
python-libsass_0.17.0-1_i386.deb SASS for Python: a straightforward binding of libsass for Python
python-libscca_20181227-1_i386.deb Windows Prefetch File access library -- Python 2 bindings
python-libsigscan_20190103-1_i386.deb binary signature scanning library -- Python 2 bindings
python-libsmdev_20181227-1_i386.deb storage media device access library -- Python 2 bindings
python-libsmraw_20181227-1_i386.deb split RAW image format access library -- Python 2 bindings
python-libssh2_1.0.0-1.2_i386.deb Python binding for libssh2 library
python-libsss-nss-idmap_1.16.3-3.1_i386.deb Python bindings for the SID lookups library
python-libsvm_3.21+ds-1.2_all.deb Python interface for support vector machine library
python-libtcod_1.7.0+dfsg-2_all.deb Python 2 bindings for the libtcod library
python-libthumbor_1.3.2-1_all.deb Python module to make usage of Thumbor easy in Python
Advertisement
Advertisement