puppet-module-puppetlabs-apt_6.1.1-1_all.deb


Advertisement

Description

puppet-module-puppetlabs-apt - Puppet module for apt

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename puppet-module-puppetlabs-apt_6.1.1-1_all.deb
Package name puppet-module-puppetlabs-apt
Package version 6.1.1
Package release 1
Package architecture all
Package type deb
Category admin
Homepage https://forge.puppet.com/puppetlabs/apt
License -
Maintainer Puppet Package Maintainers <pkg-puppet-devel@lists.alioth.debian.org>
Download size 37.90 KB
Installed size 135.00 KB
Puppet lets you centrally manage every important aspect of your system
using a cross-platform specification language that manages all the
separate elements normally aggregated in different files, like users,
cron jobs, and hosts, along with obviously discrete elements like
packages, services, and files.
The APT module provides a simple interface for managing APT source, key,
and definitions with Puppet.

Alternatives

Package Version Architecture Repository
puppet-module-puppetlabs-apt_6.1.1-1_all.deb 6.1.1 all Debian Main
puppet-module-puppetlabs-apt - - -

Requires

Name Value
puppet -
puppet-module-puppetlabs-stdlib >= 4.16.0
puppet-module-puppetlabs-translate -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package puppet-module-puppetlabs-apt_6.1.1-1_all.deb
Source Package puppet-module-puppetlabs-apt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install puppet-module-puppetlabs-apt deb package:
    # sudo apt-get install puppet-module-puppetlabs-apt

Files

Path
/usr/share/doc/puppet-module-puppetlabs-apt/MAINTAINERS.md
/usr/share/doc/puppet-module-puppetlabs-apt/NOTICE
/usr/share/doc/puppet-module-puppetlabs-apt/README.Debian
/usr/share/doc/puppet-module-puppetlabs-apt/README.md.gz
/usr/share/doc/puppet-module-puppetlabs-apt/changelog.Debian.gz
/usr/share/doc/puppet-module-puppetlabs-apt/changelog.gz
/usr/share/doc/puppet-module-puppetlabs-apt/copyright
/usr/share/doc/puppet-module-puppetlabs-apt/examples/backports.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/builddep.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/debian_testing.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/debian_unstable.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/disable_keys.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/fancy_progress.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/force.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/hold.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/key.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/pin.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/ppa.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/release.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/source.pp
/usr/share/doc/puppet-module-puppetlabs-apt/examples/unattended_upgrades.pp
/usr/share/puppet/modules.available/puppetlabs-apt/metadata.json
/usr/share/puppet/modules.available/puppetlabs-apt/lib/facter/apt_reboot_required.rb
/usr/share/puppet/modules.available/puppetlabs-apt/lib/facter/apt_update_last_success.rb
/usr/share/puppet/modules.available/puppetlabs-apt/lib/facter/apt_updates.rb
/usr/share/puppet/modules.available/puppetlabs-apt/lib/puppet/provider/apt_key/apt_key.rb
/usr/share/puppet/modules.available/puppetlabs-apt/lib/puppet/type/apt_key.rb
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/backports.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/conf.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/init.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/key.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/params.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/pin.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/ppa.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/setting.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/source.pp
/usr/share/puppet/modules.available/puppetlabs-apt/manifests/update.pp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/15update-stamp.epp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/_conf_header.epp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/_header.epp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/auth_conf.epp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/pin.pref.epp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/proxy.epp
/usr/share/puppet/modules.available/puppetlabs-apt/templates/source.list.epp
/usr/share/puppet/modules.available/puppetlabs-apt/types/auth_conf_entry.pp
/usr/share/puppet/modules.available/puppetlabs-apt/types/proxy.pp

Changelog

2018-11-10 - Sebastien Badia <sbadia@debian.org>
puppet-module-puppetlabs-apt (6.1.1-1) unstable; urgency=medium
* New upstream version 6.1.1
* d/rules: Fix lintian file-contains-trailing-whitespace
* d/control:
+ Add new dependency on puppet-module-puppetlabs-translate
+ Allow backport to stretch (update debhelper to 11~)
+ Bump to Standards-Version 4.2.1 (no changes needed)
+ Include new types in the package
2018-03-21 - Sebastien Badia <sbadia@debian.org>
puppet-module-puppetlabs-apt (4.5.1-1) unstable; urgency=medium
[ Thomas Bechtold ]
* Remove myself from Uploaders (Closes: #892668)
[ Sebastien Badia ]
* New upstream version 4.5.1
* d/watch: Bump to version 4 and use HTTPS for URI
* d/docs: Add missing NOTICE file (for Apache2 license)
* d/copyright: Update copyritght years and use HTTPS for URI
* d/upstream: Added Upstream metadata
* d/compat: Bump compat version to 11
* d/control:
+ Added myself as Uploader
+ Bump to Standards-Version 4.1.3 (no changes needed)
+ Use salsa.debian.org in Vcs-* fields
* d/compat: Bump compat version to 11
2017-12-16 - Russ Allbery <rra@debian.org>
puppet-module-puppetlabs-apt (4.4.1-1) unstable; urgency=medium
* Imported upstream release 4.4.1.
* Bump required minimum version of puppet-module-puppetlabs-stdlib.
* Depend on puppet instead of puppet-common.  (Closes: #864842)
* Add Rules-Requires-Root: no.
* Run wrap-and-sort -ast.
* Update standards version to 4.1.2 (no changes required).
2016-11-05 - Russ Allbery <rra@debian.org>
puppet-module-puppetlabs-apt (2.3.0-1) unstable; urgency=medium
* Imported upstream release 2.3.0.
* Add myself to Uploaders list.
* Update to debhelper compatibility level v10.
* Fix ordering in debian/copyright to correctly apply the more-specific
override for the copyright (and fix an info-level Lintian message).
2016-05-17 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-apt (2.2.2-1) unstable; urgency=medium
* Imported upstream relase 2.2.2
* Remove unnecessary version from dependency
* Declare compliance with Debian policy 3.9.8
* Update VCS-* URLs
* Add myself to Uploaders list
* Update source homepage
2015-10-02 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-apt (2.2.0-1) unstable; urgency=medium
* Team upload.
* Imported upstream release 2.2.0
2015-09-12 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-apt (2.1.1-1) unstable; urgency=medium
* Team upload.
[ Michael Weiser ]
* New upstream release.
[ Stig Sandbeck Mathisen ]
* Imported upstream release 2.1.1-1
* [a76dc3a] Add DEP-8 tests
* [b1d1e0c] Adjust dependencies
* [d57712a] Add examples
2014-11-21 - Michael Weiser <michael.weiser@gmx.de>
puppet-module-puppetlabs-apt (1.7.0-1) unstable; urgency=medium
* New upstream release.
2014-10-27 - Russ Allbery <rra@debian.org>
puppet-module-puppetlabs-apt (1.6.0-2) unstable; urgency=medium
* Team upload.
* Include the lib directory in the package.  apt_key is now a native
Puppet type implemented by code in lib, and the module now includes
facter plugins for various APT information.
2014-10-24 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-apt (1.6.0-1) unstable; urgency=medium
* Imported upstream relase 1.6.0
* Declare compliance with Debian policy 3.9.6
* Update debian/control metadata with cme (Vcs-*)
* Update dependencies
* Update file lists

See Also

Package Description
puppet-module-puppetlabs-concat_5.1.0-1_all.deb Puppet module for concat
puppet-module-puppetlabs-firewall_1.12.0-1_all.deb Puppet module for Firewall management
puppet-module-puppetlabs-haproxy_2.1.0-1_all.deb Puppet module for HAProxy
puppet-module-puppetlabs-inifile_2.2.1-1_all.deb Puppet module for ini files
puppet-module-puppetlabs-mongodb_0.7.0-2_all.deb Puppet module for managing mongodb installation and configuration
puppet-module-puppetlabs-mysql_5.3.0-1_all.deb Puppet module for MySQL
puppet-module-puppetlabs-ntp_7.2.0-1_all.deb Puppet module for ntp
puppet-module-puppetlabs-postgresql_5.4.0-1_all.deb Puppet module for PostgreSQL database
puppet-module-puppetlabs-rabbitmq_5.3.1-5_all.deb Puppet module for rabbitmq, manage everything from vhosts to exchanges
puppet-module-puppetlabs-rsync_1.1.0-1_all.deb Puppet module for rsync clients, repositories, and servers
puppet-module-puppetlabs-stdlib_5.0.0-1_all.deb Puppet module standard library
puppet-module-puppetlabs-tftp_0.2.3-2_all.deb Puppet module for managing tftp-hpa
puppet-module-puppetlabs-translate_1.1.0-1_all.deb Puppet module for translate
puppet-module-puppetlabs-vcsrepo_1.3.2-1_all.deb use Puppet to easily deploy content from your version control system (VCS)
puppet-module-puppetlabs-xinetd_3.0.0-1_all.deb Puppet module for xinetd
Advertisement
Advertisement