perdition-postgresql_2.2-3+b3_i386.deb


Advertisement

Description

perdition-postgresql - Library to allow perdition to access PostgreSQL based popmaps

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename perdition-postgresql_2.2-3+b3_i386.deb
Package name perdition-postgresql
Package version 2.2
Package release 3+b3
Package architecture i386
Package type deb
Category devel::lang:sql mail mail::pop protocol::pop3 protocol::ssl role::program role::shared-lib use::proxying works-with::db works-with::mail
Homepage http://horms.net/projects/perdition/
License -
Maintainer Simon Horman <horms@debian.org>
Download size 15.64 KB
Installed size 54.00 KB
Perdition allows for arbitrary user database access through
shared libraries much in the manner of NSS in glibc. This package
allows a user database stored in a PostgreSQL database.

Alternatives

Package Version Architecture Repository
perdition-postgresql_2.2-3+b3_amd64.deb 2.2 amd64 Debian Main
perdition-postgresql - - -

Requires

Name Value
libc6 >= 2.4
libdb5.3 -
libpq5 -
libvanessa-adt1 >= 0.0.9
libvanessa-logger0 >= 0.0.6
perdition = 2.2-3+b3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package perdition-postgresql_2.2-3+b3_i386.deb
Source Package perdition

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install perdition-postgresql deb package:
    # sudo apt-get install perdition-postgresql

Files

Path
/usr/lib/libperditiondb_postgresql.a
/usr/lib/libperditiondb_postgresql.so.0
/usr/lib/libperditiondb_postgresql.so.0.0.0
/usr/sbin/perditiondb_postgresql_makedb
/usr/share/doc/perdition-postgresql/changelog.Debian.gz
/usr/share/doc/perdition-postgresql/changelog.Debian.i386.gz
/usr/share/doc/perdition-postgresql/changelog.gz
/usr/share/doc/perdition-postgresql/copyright
/usr/share/man/man8/perditiondb_postgresql_makedb.8.gz

Changelog

2016-12-06 - Simon Horman <horms@debian.org>
perdition (2.2-3) unstable; urgency=high
* Correct syntax of ldconfig trigger
(closes: #http://bugs.debian.org/847214)
2016-11-28 - Simon Horman <horms@debian.org>
perdition (2.2-2) unstable; urgency=medium
* Switch to build depend on the metapackage default-libmysqlclient-dev
(closes: #845889)
* Update from standards version 3.9.6 to 3.9.8
* Update from compat level 7 to 9
2016-11-01 - Simon Horman <horms@debian.org>
perdition (2.2-1) unstable; urgency=medium
* New Upstream
* Add support for forward secrecy
(closes: #765867)
* Make builds reproducible
(closes: #787998)
* Allow compilation against OpenSSL 1.1
(closes: #828494)
* Update standards version to 3.9.6
2014-09-11 - Simon Horman <horms@debian.org>
perdition (2.1-2) unstable; urgency=medium
* Add missing call to dh_autoreconf
2013-12-01 - Simon Horman <horms@debian.org>
perdition (2.1-1) unstable; urgency=low
* New Upstream Release
(closes: #751430)
* Fix for CVE-2013-4584
Perdition fails to apply the administrator's specified ciphersuite
preferences when making outbound connections to IMAP and POP servers
using STARTTLS.  For these outbound connections, it applies the
administrator's listening ciphersuite preferences, which in many cases
may be significantly weaker.
This is not a critical vulnerability (it can be mitigated, for example,
by enforcing a strict minimalist ciphersuite on the backend server),
but in the absence of any such mitigation, it may cause the connections
between the proxy server and the backend server to negotiate a weaker
ciphersuite than the administrator's stated intent.
(closes: #729028)
* Versioned build dependency on dpkg-dev (>=1.16.1)
(closes: #680086)
* Use 1.0 as Managesieve version
(closes: #726175)
* Use autoreconf
(closes: #737666)
* Harden build flags
* Build verbosely
* Update standards version to 3.9.5
2013-10-04 - Simon Horman <horms@debian.org>
perdition (2.0-1) unstable; urgency=low
* New upstream release
2012-03-20 - Simon Horman <horms@debian.org>
perdition (1.19~rc5-1) unstable; urgency=low
* Use hardened build flags
(closes: #655412)
* Fix segmentation fault in strcasestr()
(closes: #660735)
* Added homepage to control file
(closes: #594026)
* Do not include .la files from binary packages
(closes: #633184)
* Set package format to 3.0 (quilt)
2011-08-23 - Simon Horman <horms@debian.org>
perdition (1.19~rc4-4) unstable; urgency=low
* Updated init script based on current /etc/inti.d/skeleton
(closes: #609653)
* Remove .la files
(closes: #633184)
2011-06-15 - Simon Horman <horms@debian.org>
perdition (1.19~rc4-3) unstable; urgency=low
* Handle IPv6 address literals in --bind-address
- Upstream patch
http://hg.vergenet.net/perdition/perdition/rev/06e0c2cdb64f
* managesieve: Fix handling of long authentication hashes
- Upstream patch
http://hg.vergenet.net/perdition/perdition/rev/6544c58ec144
- (closes: 630499)
2010-09-27 - Simon Horman <horms@debian.org>
perdition (1.19~rc4-2) unstable; urgency=low
* Clean up use of 4/8 byte types on architectures such as amd64
where ssize_t and long are 8 bytes white but int is only 4 bytes wide.
- Fix possible premature connection closure.
- Fix possible stack corruption in odbc module.
- Critical portions of upstream patch
http://hg.vergenet.net/perdition/perdition/rev/57268f4aaa94
- (closes: 59791)

See Also

Package Description
perdition_2.2-3+b3_i386.deb POP3 and IMAP4 Proxy server
perf-tools-unstable_1.0+git7ffb3fd-1_all.deb DTrace-like tools for Linux
perforate_1.2-5.1_i386.deb Utilities to save disk space
performous-tools_1.1+git20181118-2_i386.deb karaoke game that allows user supplied songs - tools
performous_1.1+git20181118-2_i386.deb karaoke game that allows user supplied songs
perftest_4.4+0.5-1_i386.deb Infiniband verbs performance tests
perl-base_5.28.1-6_i386.deb minimal Perl system
perl-byacc_2.0-8+b1_i386.deb Berkeley LALR parser generator, Perl version
perl-cross-debian_0.0.5_all.deb Cross build support for Debian perl configurations
perl-debug_5.28.1-6_i386.deb debug-enabled Perl interpreter
perl-depends_2016.1029+git8f67695-1_all.deb rough indicator of Perl module dependencies
perl-doc_5.28.1-6_all.deb Perl documentation
perl-modules-5.28_5.28.1-6_all.deb Core Perl modules
perl-openssl-defaults_3_i386.deb version compatibility baseline for Perl OpenSSL packages
perl-stacktrace_0.09-3+b1_i386.deb Create stack traces of a running perl processes
Advertisement
Advertisement