opensc-pkcs11_0.19.0-1_i386.deb


Advertisement

Description

opensc-pkcs11 - Smart card utilities with support for PKCS#15 compatible cards

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename opensc-pkcs11_0.19.0-1_i386.deb
Package name opensc-pkcs11
Package version 0.19.0
Package release 1
Package architecture i386
Package type deb
Category utils
Homepage https://github.com/OpenSC/OpenSC/wiki
License -
Maintainer Debian OpenSC Maintainers <pkg-opensc-maint@lists.alioth.debian.org>
Download size 798.18 KB
Installed size 2.69 MB
OpenSC provides a set of libraries and utilities to access smart
cards.  It mainly focuses on cards that support cryptographic
operations. It facilitates their use in security applications such as
mail encryption, authentication, and digital signature. OpenSC
implements the PKCS#11 API. Applications supporting this API, such as
Iceweasel and Icedove, can use it. OpenSC implements the PKCS#15
standard and aims to be compatible with all software that does so as
well.
Before purchasing any cards, please read carefully documentation in
/usr/share/doc/opensc/html/wiki/index.html - only some cards are
supported. Not only does card type matters, but also card version,
card OS version and preloaded applet. Only a subset of possible
operations may be supported for your card. Card initialization may
require third party proprietary software.
This package contains the pkcs11 module.

Alternatives

Package Version Architecture Repository
opensc-pkcs11_0.19.0-1_amd64.deb 0.19.0 amd64 Debian Main
opensc-pkcs11 - - -

Requires

Name Value
libc6 >= 2.11
libglib2.0-0 >= 2.39.4
libssl1.1 >= 1.1.0
zlib1g >= 1:1.1.4

Replaces

Name Value
libopensc2 << 0.12.0
opensc << 0.13.0-5~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package opensc-pkcs11_0.19.0-1_i386.deb
Source Package opensc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opensc-pkcs11 deb package:
    # sudo apt-get install opensc-pkcs11

Files

Path
/usr/lib/i386-linux-gnu/libopensc.so.6
/usr/lib/i386-linux-gnu/libopensc.so.6.0.0
/usr/lib/i386-linux-gnu/libsmm-local.so.6
/usr/lib/i386-linux-gnu/libsmm-local.so.6.0.0
/usr/lib/i386-linux-gnu/onepin-opensc-pkcs11.so
/usr/lib/i386-linux-gnu/opensc-pkcs11.so
/usr/lib/i386-linux-gnu/pkcs11-spy.so
/usr/lib/i386-linux-gnu/pkcs11/onepin-opensc-pkcs11.so
/usr/lib/i386-linux-gnu/pkcs11/opensc-pkcs11.so
/usr/lib/i386-linux-gnu/pkcs11/pkcs11-spy.so
/usr/share/doc/opensc-pkcs11/NEWS.gz
/usr/share/doc/opensc-pkcs11/README
/usr/share/doc/opensc-pkcs11/README.md
/usr/share/doc/opensc-pkcs11/changelog.Debian.gz
/usr/share/doc/opensc-pkcs11/copyright
/usr/share/p11-kit/modules/opensc-pkcs11.module

Changelog

2018-09-30 - Eric Dorland <eric@debian.org>
opensc (0.19.0-1) unstable; urgency=medium
* New upstream release (Closes: 908363, 909444)
* Fix linebreak in watch file
2018-09-09 - Eric Dorland <eric@debian.org>
opensc (0.19.0~rc1-1) unstable; urgency=medium
* New upstream release
* Update watch rules
* Standards-Version to 4.2.1.1
2018-06-02 - Eric Dorland <eric@debian.org>
opensc (0.18.0-3) unstable; urgency=medium
* Include the opensc-notify tool
2018-05-22 - Eric Dorland <eric@debian.org>
opensc (0.18.0-2) unstable; urgency=medium
* Install all binaries and manpages (Closes: 899236)
* Standards-Version to 4.1.4
2018-05-20 - Eric Dorland <eric@debian.org>
opensc (0.18.0-1) unstable; urgency=medium
* New upstream release.
2018-02-24 - Eric Dorland <eric@debian.org>
opensc (0.17.0-3) unstable; urgency=medium
* Switch to debhelper 11
* Standards-Version to 4.1.3
* Move VCS to salsa.debian.org
* Install README.md file (Closes: 870292)
2017-11-26 - Eric Dorland <eric@debian.org>
opensc (0.17.0-2) unstable; urgency=medium
* debian/control: Switch to openssl 1.1. (Closes: #828471)
* debian/control: Switch to priority optional.
* debian/control: Standards-Version to 4.1.1.
2017-07-23 - Eric Dorland <eric@debian.org>
opensc (0.17.0-1) unstable; urgency=medium
* New upstream release.
2017-07-09 - Eric Dorland <eric@debian.org>
opensc (0.17.0~rc2-1) UNRELEASED; urgency=medium
* New upstream release candidate.
* debian/control: Build depend on help2man for npa-tool.1.
2017-06-24 - Eric Dorland <eric@debian.org>
opensc (0.17.0~rc1-1) unstable; urgency=medium
* New upstream release candidate.
* debian/patches/0001-Fix-interaction-with-DNIe-UI.patch: Remove
upstreamed patch.
* debian/control: Standards-Version to 4.0.0.

See Also

Package Description
opensc_0.19.0-1_i386.deb Smart card utilities with support for PKCS#15 compatible cards
openscad-mcad_2019.02-1_all.deb library for the OpenSCAD 3D modeling software
openscad-testing-data_2019.01~RC2-2_all.deb script file based graphical CAD environment (test suite data)
openscad-testing_2019.01~RC2-2_i386.deb script file based graphical CAD environment (test suite)
openscad_2019.01~RC2-2_i386.deb script file based graphical CAD environment
openscap-daemon_0.1.10-3_all.deb Daemon for infrastructure continuous SCAP compliance checks
openscenegraph-3.4-doc_3.4.1+dfsg1-5_all.deb 3D scene graph, documentation
openscenegraph-3.4-examples_3.4.1+dfsg1-5_all.deb 3D scene graph, examples (sources)
openscenegraph-3.4_3.4.1+dfsg1-5_i386.deb 3D scene graph, utilities and examples (binaries)
openscenegraph-doc_3.2.3+dfsg1-3_all.deb 3D scene graph, documentation
openscenegraph-examples_3.2.3+dfsg1-3_all.deb 3D scene graph, examples (sources)
openscenegraph-plugin-osgearth_2.10.0+dfsg-1+b1_i386.deb OpenSceneGraph plugins for osgEarth
openscenegraph_3.2.3+dfsg1-3_i386.deb 3D scene graph, utilities and examples (binaries)
opense-basic_3.1.2-3_all.deb Free software ROM for the Sinclair ZX Spectrum
openshot-doc_2.4.3+dfsg1-1_all.deb documentation for openshot-qt (transitional package)
Advertisement
Advertisement